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About This
Manual

About This Manual

The Aspen Plus User Guide consists of three volumes that provide step-by-step
instructions for using Aspen Plus® to build and use a process simulation model.

Volume 1 describes the Aspen Plus user interface and explains how to perform
the basic tasks for creating and running simulations. Topics include:
• Creating a simulation model
• Defining the flowsheet
• Entering the required information, such as components, streams and physical

property data
• Running the simulation
• Examining results

Volume 2 contains procedures for using additional Aspen Plus capabilities:
• Convergence
• Sensitivity
• Design specifications
• Optimization
• Property analysis
• Data regression

Volume 3 contains information about:
• Pressure relief calculations
• Stream libraries
• Working with other Windows™ programs
• The Aspen Plus ActiveX® automation interface
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For More Information

Online Help  Aspen Plus has a complete system of online help and
context-sensitive prompts. The help system contains both context-sensitive help
and reference information. For more information about using Aspen Plus help, see
the Aspen Plus User Guide, Chapter 3.

Aspen Plus Getting Started Building and Running a Process Model  This
tutorial includes several hands-on sessions to familiarize you with Aspen Plus.
The guide takes you step-by-step to learn the full power and scope of Aspen Plus.

Aspen Plus Getting Started Modeling Processes with Electrolytes  This
tutorial includes several hands-on sessions to familiarize you with simulating
electrolyte systems with Aspen Plus.

Aspen Plus Getting Started Modeling Petroleum Processes  This tutorial
includes several hands-on sessions to familiarize you with simulating petroleum
processes with Aspen Plus.

Aspen Plus Getting Started Customizing Unit Operation Models  This
tutorial includes several hands-on sessions to familiarize you with the
customization of unit operation models with Aspen Plus.

Aspen Plus User Guide  The three-volume Aspen Plus User Guide provides
step-by-step procedures for developing and using an Aspen Plus process
simulation model. The guide is task-oriented to help you accomplish the
engineering work you need to do, using the powerful capabilities of Aspen Plus.

Aspen Plus reference manual series  Aspen Plus reference manuals provide
detailed technical reference information. These manuals include background
information about the unit operation models and the physical properties methods
and models available in Aspen Plus, tables of Aspen Plus databank parameters,
group contribution method functional groups, and a wide range of other reference
information. The set comprises:
• Unit Operation Models
• Physical Property Methods and Models
• Physical Property Data
• User Models
• System Management
• System Administration
• Summary File Toolkit

Aspen Plus application examples  A suite of sample online Aspen Plus
simulations illustrating specific processes is delivered with Aspen Plus.
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Aspen Plus Installation Guides   These guides provide instructions on
platform and network installation of Aspen Plus. The set comprises:
• Aspen Plus Installation Guide for Windows
• Aspen Plus Installation Guide for OpenVMS
• Aspen Plus Installation Guide for UNIX

The Aspen Plus manuals are delivered in Adobe portable document format (PDF)
on the Aspen Plus Documentation CD.

Technical Support
World Wide Web  For additional information about AspenTech products and
services, check the AspenTech World Wide Web home page on the Internet at:

http://www.aspentech.com/

Technical resources  To obtain in-depth technical support information on the
Internet, visit the Technical Support homepage. Register at:

http://www.aspentech.com/ts/

Approximately three days after registering, you will receive a confirmation e-mail
and you will then be able to access this information.

The most current Hotline contact information is listed. Other information
includes:
• Frequently asked questions
• Product training courses
• Technical tips
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AspenTech Hotline  If you need help from an AspenTech Customer Support
engineer, contact our Hotline for any of the following locations:

If you are located in: Phone Number Fax Number E-Mail Address

North America & the
Caribbean

+1-617/949-1021

+1-888/996-7001
     (toll free)

+1-617/949-1724 support@aspentech.com

South America
   (Argentina office)

   (Brazil office)

+54-11/4393-5308

+55-11/5506-0756

+54-11/4394-8621

+55-11/5506-0567

tecnoba@aspentech.com

tecnosp@aspentech.com

Europe, Gulf Region, & Africa
   (Brussels office)

   (UK office)

+32-2/724-0100

+44-1223/312220

+32-2/705-4034

+44-1223/366980

atesupport@aspentech.com

Japan +81-3/3262-1743 +81-3/3262-1744 atjsupport@aspentech.com

Asia & Australia

   (Hong Kong office)

   (Korea office)

+85-2/2838-6077

+82-2/761-5800

+85-2/2833-5642

+82-2/761-5803

atasupport@aspentech.com

❖     ❖     ❖     ❖ 
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Chapter 1

1 The User Interface

This chapter provides basic information on the Aspen Plus user interface. For
information on how to use Aspen Plus to create a simulation model, see
Chapter 2. If you are new to Aspen Plus, do the exercises in Aspen Plus Getting
Started Building and Running a Process Model before using this manual.

This chapter explains the following topics:

• Starting Aspen Plus
• Aspen Plus windows
• Displaying, browsing, and completing forms
• Using Next—the Expert Guidance System

For more information on getting help on buttons, menus and other screen items,
see Chapter 3.
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The User
Interface

Starting Aspen Plus
To start Aspen Plus:
1. Click Start, and then point to Programs

2. Point to AspenTech, point to Aspen Plus and then click Aspen Plus User
Interface.

3. In the startup dialog box, choose whether you want to create a new
simulation using a blank simulation or a Template, or open an existing
simulation.

 If you choose to create a new run from a Template, you will be prompted to
specify the Template and Run Type for the new run . See Chapter 2 for more
information on creating a new run.

Perform the remaining steps only if you are opening an existing run.

4. To open an existing simulation, either select the filename from the list in the
startup dialog box, or select More Files, and click OK.

If you select a file from the startup dialog box, the Aspen Plus main window
appears with the chosen file displayed. If you choose More Files, the Open
dialog box appears.

Perform the remaining steps only if you chose More Files.

5. In the Open dialog box, in the Files of Type box, select the file format in
which the run was saved. For example, Aspen Plus Document format (.apw)
or Backup file format (.bkp).  See Chapter 16 for more information on file
formats and saving runs.

6. Use the Look In list box to locate the directory where the file is stored, then
click the file you want to open, and click Open.

If the Connect to Engine dialog box appears, see Connecting to the
Aspen Plus Host Computer on page 1 - 3.

Tip  To open an existing file quickly, just double-click the file from Windows
Explorer.
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Connecting to the Aspen Plus Host
Computer

Use this section if:

• The Aspen Plus simulation engine is not installed on your PC
• The Aspen Plus simulation engine is installed on your PC and you are using

the network license manager.

Skip this section if you are using the Activator security device on your PC.

These instructions assume that you are connected to the computer where the
Aspen Plus simulation engine will run. See your Aspen Plus system
administrator for information specific to your installation.
1. Start Aspen Plus and select a previous run, template, or blank simulation.

The Connect to Engine dialog box appears.

2. Specify where the Aspen Plus engine will run:

Server Type If the Aspen Plus engine runs on

Local PC Your PC, using the network license manager

Unix host A Unix server

OpenVMS host An OpenVMS server

Windows NT server A Windows NT server (Intel or AXP)

3. If you specified Unix host, OpenVMS host, or Windows NT server, enter the
following information in the dialog box:

Enter this information In this box

The type of Aspen Plus engine you want to connect to Server Type

Node name of the computer the Aspen Plus simulation will run on Node Name

Your logon name on the host computer User Name

Password for your account on the host computer Password

Working directory on the host computer for Aspen Plus runs Working Directory

4. When the network connection is established, a message box appears saying
Connection Established.
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If the Connection Established box does not appear, see the Aspen Plus system
administrator at your site for more information on network protocols and
Aspen Plus host computers.

Tip It is possible to change the Connection by selecting Connect to Engine
from the Run menu.

Tip You can specify additional host settings in the Settings dialog box. To do
this, from the Run menu, click Settings.

The Aspen Plus Main Window

When you start Aspen Plus, the main window appears:

Titlebar Menu bar

Toolbars

Next
button

Process
Flowsheet
window

Select
Mode
button

Model Library

Status Bar

Use the workspace to create and display simulation flowsheets and PFD-style
drawings. You can open other windows, such as Plot windows or Data Browser
windows, from the Aspen Plus main window.
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Tip  You can display a window by selecting it from the Window menu. You can
arrange the windows by selecting Tile or Cascade from the Window menu.

The parts of the Aspen Plus main window are:

Window Part Description

Titlebar Horizontal bar at top of window that displays the Run ID.
Simulation 1 is the default ID until you give the run a name.

Menubar Horizontal bar below the titlebar. Gives the names of the available menus.

Toolbar Horizontal bar below the menubar. Contains buttons that when clicked, perform
commands.

Next Button Invokes the Aspen Plus expert system. Guides you through the steps required to complete
your simulation.

Status Area Displays status information about the current run.

Select Mode button Turns off Insert mode for inserting objects, and returns you to Select mode.

Process Flowsheet Window Window where you construct the flowsheet

Model Library Area at the bottom of the main window. Lists available unit operation models.

Use the buttons on the toolbars to perform actions quickly and easily.

The default toolbars are shown here:

Standard toolbar Data Browser
toolbar

Simulation Run
toolbar

Process Flowsheet toolbar

For information on viewing different toolbars, see chapter 16.

The Process Flowsheet Window

The Process Flowsheet window is where you create and display simulation
flowsheets and PFD-style drawings.
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You can display the process flowsheet window in three different ways:

To display the
Process Flowsheet window as

From the Window menu, click

A normal window Normal

A window always in the background Flowsheet as Wallpaper

A sheet of a workbook Workbook mode

The Model Library

Use the Model Library to select unit operation models and icons that you want
placed on the flowsheet. The Model Library appears at the bottom of the
Aspen Plus main window.
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To select a unit operation model:
1. Click the tab that corresponds to the type of model you want to place in the

flowsheet.

2. Click the unit operation model on the sheet.

3. To select a different icon for a model, click the down arrow next to the model
icon to see alternate icons. The icon you select will appear for that model in
the Model Library.

4. When you have selected a model, click the flowsheet where you want to place
the model.

When you place blocks this way, you are in Insert mode.  Each time you click
in the Process Flowsheet window, you place a block of the model type that you
specified.  To exit Insert mode and return to Select mode, click the Mode
Select Button on the upper left of the Model Library.

Tip  You can also place blocks in your flowsheet by dragging and dropping from
the Model Library to the Process Flowsheet window.

To select the stream type:
1. Click the down arrow next to the stream type displayed in the Model Library.

2. Select the stream type you want to place in the flowsheet.

3. Once a stream type is selected, simply click the ports on the flowsheet where
you want to connect the stream.

When placing blocks and streams, the mouse pointer changes to the crosshair
shape, indicating Insert Mode. After placing each block or stream, you remain in
Insert Mode until you click the Select Mode button in the upper right corner of
the Model Library.  For more information on what the mouse pointers mean, see
Chapter 4.

Tip   You can undock the Model Library and use it as a floating palette. You can
also dock the Model Library under the toolbar.

For more details and examples for setting up a flowsheet, see Getting Started,
Building and Running a Process Model.
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The Data Browser
The Data Browser is a sheet and form viewer with a hierarchical tree view of the
available simulation input, results, and objects that have been defined.

To open the Data Browser:

➤ Click the Data Browser button  on the Data Browser toolbar.

– or –

➤ From the Data menu, click Data Browser.

The Data Browser also appears when you open any form.

Go to a
different
folder

Menu tree

Folder list

Up One
L l

Units
box

Go
 forward

Go
back

Previous
 sheet

Input/Results
 View menu

Next sheet

Next

Status

Comments

Form
(consisting
of sheets)

Prompt areaStatus bar

Use the Data Browser to:

• Display forms and sheets and manipulate objects
• View multiple forms and sheets without returning to the Data menu, for

example, when checking Properties Parameters input
• Edit the sheets that define the input for the flowsheet simulation
• Check the status and contents of a run
• See what results are available
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The parts of the Data Browser window are:

Window Part Description

Form Displays sheets where you can enter data or view results

Menu Tree Hierarchical tree of folders and forms

Status Bar Displays status information about the current block, stream
 or other object

Prompt Area Provides information to help you make choices or perform tasks

Go to a Different Folder Enables you to select a folder or form to display.

Up One Level Takes you up one level in the Menu Tree

Folder List Displays or hides the Menu Tree

Units Units of measure used for the active form

Go Back button Takes you to the previously viewed form

Go Forward button Takes you to the form where you last chose the Go Back Button

Input/Results View Menu Allows you to view folders and forms for Input only, Results only, or All

Previous Sheet button Takes you to the previous input or result sheet for this object

Next Sheet button Takes you to the next input or result sheet for this object

Comments button Allows you to enter comments for a particular block, stream,
or other object

Status button Displays any messages generated during the last run related to a
particular form

Next button Invokes the Aspen Plus expert system. Guides you through the
steps required to complete your simulation.

Displaying Forms and Sheets in the Data Browser
Use the Data Browser to view and edit the forms and sheets that define the input
and display the results for the flowsheet simulation. When you have a form
displayed, you can view any sheet on the form by clicking on the tab for that
sheet.
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There are several ways to display forms. You can display a form in a new Data
Browser by using:

• The Data menu
• Block or stream popup menus
• The Check Results button on the Control Panel, the Check Results command

from the Run menu, or the Check Results button on the Simulation Run
toolbar

• The Setup, Components, Properties, Streams, or Blocks buttons on the Data
Browser toolbar

• The Next button on the Data Browser toolbar
• The Data Browser button on the Data Browser toolbar

You can move to a new form within the same data browser by using the:

• Menu tree
• Object Managers
• Next button on the Data Browser
• Previous Form and Next Form buttons (<<, >>)
• Go Back and Go Forward buttons (Å, Æ)
• Select View menu
• Up One Level button

For example, the Components Specifications Selection form looks like this:

Note A form is a collection of sheets.
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Status Indicators
Status indicators display the completion status for the entire simulation as well
as for individual forms and sheets.

The status indicators appear:

• Next to sheet names on the tabs of a form
• As symbols representing forms in the Data Browser menu tree

This table shows the meaning of the symbols that appear:

This Symbol On an Means

Input form Required input complete

Input form Required input incomplete

Input form No data entered

Mixed form Input and Results

Results form No results present (calculations have not been run)

Results form Results available without Errors or Warnings (OK)

Results form Results available with Warnings

Results form Results available with Errors

Results form Results inconsistent with current input (input changed)

 Input folder No data entered

 Input folder Required input incomplete

 Input folder Required input complete

 Results folder No results present

 Results folder Results available – OK

 Results folder Results available with Warnings

 Results folder Results available with Errors

 Results folder Results inconsistent with current input (input changed)

Using Next

Click the Next button  to move to the next input form or menu at any point in
Aspen Plus. The Next button is on the Data Browser toolbar in the main window
and the toolbar of the Data Browser.
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Use Next to:

• Guide you through the required and optional input for a run by displaying
messages

• Tell you what you need to do next
• Ensure you do not make incomplete or inconsistent specifications, even when

you change options and specifications you have already entered

This table shows what happens if you click Next:

If Using Next

The sheet you are on is incomplete Displays a message listing the input you must provide to complete
the sheet.

The sheet you are on is complete Takes you to next required input sheet for the current object.

You have selected an object that is complete Takes you to next object or the next step in making a run.

You have selected an object that is incomplete Takes you to the next sheet you must complete.

Using the Previous and Next Sheet Buttons
You can browse through sheets and forms sequentially by using the Previous
Sheet and Next Sheet buttons on the Data Browser toolbar. These buttons take
you through input sheets, results sheets, or both, depending on the current
selection of the Input/Results View menu button in the Data Browser toolbar.

To view the next sheet in a series, click the Next Sheet button .

To view the previous sheet, click the Previous Sheet button .

Using the Go Back and Go Forward Buttons

You can trace through previously viewed forms using the Go Back button .
The Go Back button can be clicked many times to continue through a reverse
sequence of the forms you have viewed.

When you have gone back once, the Go Forward button  is enabled, so you can
return to the form that you were on.
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Using the Object Manager

Every block, stream, and other simulation object has a unique ID. When you select
a folder in the Data Browser tree which contains several simulation objects, an
Object Manager form appears in the form area of the Data Browser. For example:

Use the Object Manager buttons to perform the following functions:

Button Description

New Create a new object.  You will be prompted for the ID for the object.
The forms for the object will display.

Edit Display the forms for the object

Delete Delete the object

Clear Delete the data for an object.  The object still exists.

Rename Rename the object

Hide Temporarily remove an object from the simulation, without deleting it.

Reveal Put a hidden object back into the simulation

Not all functions are available for all objects.  For example, New is inactive on
the Block Object Manager.  Use the Process Flowsheet window and the Model
Library to create a new block.
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Deleting Objects and Clearing Forms
You can delete the following from a simulation:

• A component, from the Components Specification Selection sheet
• Blocks and streams, from the flowsheet
• Other input, such as a design specification, using the Data Browser or an

Object Manager

When you delete input, all references to the deleted object (even on other forms)
are automatically deleted. If this results in an inconsistent or incomplete
specification, the Expert System marks the affected forms as incomplete, and the
Next function takes you to any incomplete sheets.

You cannot delete:

• Sheets that do not represent objects, such as the Setup forms
• Properties Parameters (Binary or Pair) and Molecular Structure objects

However, you can clear these sheets of all existing input and restore their default
values. To do this, click Clear from an Object Manager or from the menu that
appears when you click the right mouse button on an item in the menu tree.

Using the Expert System When You Make
Changes

The Aspen Plus Expert System (the Next function):

• Tells you when your specifications are inconsistent or incomplete
• Guides you through reconciling changes

If the field where you want to enter data is inactive, the Prompt for the field tells
you why. To make the field active, delete any conflicting entries or options. For
example, if you are using RadFrac to model a distillation column and specify
None for the Reboiler, one of the Operating Specifications fields will become
inactive since there is only one degree of freedom in the column specifications.  If
you change the Reboiler field, the other Operating Specification field will become
active.

If you change an option or specification that makes other entries inconsistent,
Aspen Plus displays a dialog box asking if you want to temporarily override the
error.
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Click Yes if you want to continue without correcting the inconsistency error.
Then go to the affected fields and make them consistent with the new
specification.

The affected forms are marked incomplete until you reconcile the specifications.
The Expert System guides you to incomplete sheets.

Using Shortcut Keys

The following tables show the shortcut keys that are available in Aspen Plus.

• General shortcut keys
• Working with blocks and streams
• Editing
• Working with files
• Working with flowsheets
• Help
• Plotting
• Regions
• Running simulations
• Viewing

General Shortcut Keys
This table shows general shortcut keys:

Item Shortcut Key

Close active window ALT+F4

Copy CTRL+C

Context Help F1

Cut CTRL+X

Display popup menu SHIFT+F10

Display next MDI-child window CTRL+F6

Paste CTRL+V

Print CTRL+P

Redo CTRL+Y

Continued
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Item Shortcut Key

Save CTRL+S

Select All CTRL+A

Switch to next window ALT+F6

What's This Help SHIFT+F1

Shortcut Keys for Working with Blocks and Streams
This table shows the shortcut keys for working with blocks and streams:

Item Shortcut Key

Align Blocks CTRL+B

Center View CTRL+HOME

Change Section CTRL+F11

Change Stream Class CTRL+Q

Delete Blocks or Streams DEL

Exchange Icon CTRL+K

Hide Annotation CTRL+L

Hide Global Data CTRL+G

Hide ID CTRL+H

Input CTRL+I

Rename Block or Stream CTRL+M

Reroute Streams CTRL+J

Results CTRL+R

Stream Results CTRL+D

Unplace Block or Group CTRL+U
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Shortcut Keys for Editing
This table shows the shortcut keys for editing:

Item Shortcut Key

Copy CTRL+C

Delete DEL

Paste CTRL+V

Rename CTRL+M

Select All CTRL+A

Shortcut Keys for Working with Files
This table shows the shortcut keys for working with files:

Item Shortcut Key

Export CTRL+E

Import CTRL+T

New CTRL+N

Open CTRL+O

Print CTRL+P

Save CTRL+S

Shortcut Keys for Working with Flowsheets
This table shows the shortcut keys for working with flowsheets:

Item Shortcut Key

Align Blocks CTRL+B

Change Section CTRL+F11

Change Stream Class CTRL+Q

Continued
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Item Shortcut Key

Exchange Icons CTRL+K

Flowsheet Sections F11

Hide Annotation CTRL+L

Hide Global Data CTRL+G

Hide ID CTRL+H

Reroute Streams CTRL+J

Unplace Blocks CTRL+U

Shortcut Keys for Help
This table shows the shortcut keys for help:

Item Shortcut Key

Context Help F1

Display popup menu SHIFT+F10

What's This Help SHIFT+F1

Shortcut Keys for Plotting
This table shows the shortcut keys for plotting:

Item Shortcut Key

Display Plot CTRL+ALT+P

Parametric Variable CTRL+ALT+Z

Plot Wizard CTRL+ALT+W

 X-Axis Variable CTRL+ALT+X

 Y-Axis Variable CTRL+ALT+Y
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Shortcut Keys for Working with Regions
This table shows the shortcut keys for working with regions:

Item Shortcut Key

Bookmarks F3

Center View CTRL+HOME

Page Break Preview F2

Pan CTRL+F3

Print CTRL+P

Reset Page Breaks SHIFT+F2

Select All CTRL+A

Zoom Full CTRL+END

Zoom In CTRL+UP ARROW

Zoom Out CTRL+DOWN ARROW

Shortcut Keys for Running Simulations
This table shows the shortcut keys that you can use when running simulations:

Item Shortcut Key

Check Results CTRL+F8

Connect to Engine SHIFT+F7

Move To CTRL+F9

Reinitialize SHIFT+F5

Run F5

Settings CTRL+F7

Step CTRL+F5

Stop Points F9
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Shortcut Keys for Viewing
This table shows the shortcut keys that you can use for viewing:

Item Shortcut Key

Annotation CTRL+ALT+L

Bookmarks F3

Center View CTRL+HOME

Control Panel F6

Current Section Only SHIFT+F11

Global Data CTRL+ALT+G

History CTRL+ALT+H

Input Summary CTRL+ALT+I

OLE Objects CTRL+ALT+F

Model Library F10

Page Break Preview F2

Pan CTRL+F3

PFD Mode F12

Redraw CTRL+W

Refresh PFD SHIFT+F12

Report CTRL+ALT+R

Reset Page Breaks SHIFT+F2

Zoom Full CTRL+END

Zoom In CTRL+UP ARROW

Zoom Out CTRL+DOWN ARROW

Supplying Comments

You can write notes or keep track of information by entering comments for
particular forms. Each object has just one Comments form which you can access
from any input or results form for the object.



Aspen Plus User Guide 1-21
Version 10.1-0

Chapter 1

To enter comments on a form:
1. Click the Comments button on the Data Browser toolbar.

If there are no existing comments, the button looks like this:  .

If there are existing comments, the button looks like this: 

2. Enter your one line description in the Description box of the Comments form.

The description is printed in the Aspen Plus report.

3. Enter your comments in the Comments area of the Comments form.

4. Click OK to close the Comments form.

❖     ❖     ❖     ❖ 
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2 Creating a Simulation
Model

This chapter describes how to use Aspen Plus to create a simulation model, including the
following topics:

• Creating a new run
• Selecting a Template
• Selecting a Run Type
• Completing the input specifications for a run
• About the templates
• The Aspen Plus online applications library

Process Simulation Using Aspen Plus

Process simulation with Aspen Plus allows you to predict the behavior of a process using
basic engineering relationships such as mass and energy balances, phase and chemical
equilibrium, and reaction kinetics. Given reliable thermodynamic data, realistic operating
conditions, and the rigorous Aspen Plus equipment models, you can simulate actual plant
behavior. Aspen Plus can help you design better plants and increase profitability in
existing plants.

With Aspen Plus you can interactively change specifications, such as flowsheet
configuration, operating conditions, and feed compositions, to run new cases and
analyze alternatives. To analyze your results, you can generate plots, reports,
PFD-style drawings, and spreadsheet files.
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Aspen Plus allows you to perform a wide range of additional tasks. You can:

• Perform sensitivity analyses and case studies
• Generate custom graphical and tabular output
• Estimate and regress physical properties
• Fit simulation models to plant data
• Optimize your process
• Interface results to spreadsheets
• Share input and results among other Windows applications using OLE

Aspen Plus contains data, properties, unit operation models, built-in defaults,
reports, and other features and capabilities developed for specific industrial
applications, such as petroleum simulation. For more information about
industry-specific defaults and features, see Selecting a Template on page 2 - 3.

Creating a New Run

Follow these instructions to either:

• Start Aspen Plus and create a new run
• Create a new run when you are already in Aspen Plus

Starting Aspen Plus and Creating a New Run
To start Aspen Plus and create a new run:
1. Start Aspen Plus from the Start Menu or by double-clicking the Aspen Plus

icon on your desktop.

2. On the Aspen Plus Startup dialog box, click the appropriate button to create a
new simulation using a Blank Simulation or a Template, then click OK.

3. If you choose a blank simulation, the Aspen Plus main window opens and you
can begin building your new model.

4. If you choose a Template, follow the steps below.

5. In the New dialog box, select the type of simulation template and the units
you wish to use, from the list. For more information on choosing a Template,
see Selecting a Template on page 2 -3.

6. Choose the desired Run Type in the Run Type list box. For more information,
see Selecting a Run Type on page 2-4.

7. Click OK.
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8. If the Connect to Engine dialog box appears, specify where the Aspen Plus
engine will execute. See Chapter 1 for more information.

Creating a New Run in Aspen Plus
To create a new run if you are already in Aspen Plus:
1. Save the current run if you want to open it later.

2. From the File menu, click New.

3. A dialog box appears, asking if you want to close the current run before
opening a new run. Click Yes, No, or Cancel:

If you choose This happens

Yes The current run will be closed, and the new run will open in the existing Aspen Plus window.

You will be given the option to save the current run before the new run opens.

No The current run will remain active in the existing window, and a new run will open in a second Aspen Plus
window.

Cancel You will be returned to the current run.

4. In the New dialog box, select the type of simulation Template and the units
you wish to use, from the list. For more information on choosing a Template,
see Selecting a Template on page 2-3.

5. Choose the desired Run Type in the Run Type list box. For more information
on Run Types, see Selecting a Run Type on page 2-4.

6. Click OK.

Selecting a Template

When starting a new simulation, you can start with a blank simulation or you can
begin with a Template. Templates set defaults commonly used by specific
industries for:

• Units of measurement
• Stream composition information and properties to report
• Stream report format
• Default setting for Free-Water option
• Property method
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• Other application-specific defaults

For information about creating your own templates, see Chapter 16.

There are built-in Templates for the following applications:

• Air Separation
• Chemicals
• Electrolytes
• Gas Processing
• General
• Hydrometallurgy
• Petroleum
• Pharmaceuticals
• Pyrometallurgy
• Solids
• Specialty Chemicals

For each Template, you can select either metric or English units of measurement
as a default units set. Other units sets are also available.

See the sections at the end of this chapter for a description of the Templates.

Selecting a Run Type

When creating a new run, you must select a Run Type from the Run Type list box
on the New dialog box.

Use the Flowsheet run type for flowsheet simulations (including sensitivity
studies and optimization). Flowsheet runs can also include the following
calculations integrated with a flowsheet simulation:

• Property constant estimation
• Assay data analysis/pseudocomponents generation
• Property analysis
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Other run types are used to run Aspen Plus without performing a flowsheet
simulation:

Run Type Description Use to

Assay Data Analysis A standalone assay data
analysis/pseudocomponents
generation run

Analyze assay data when you do not want to
perform a flowsheet simulation in the same run.
See Chapter 32.

Data Regression A standalone data regression
run. Can contain property
constant estimation and
property analysis
calculations.

Fit physical property model parameters required
by Aspen Plus to measured pure component,
VLE, LLE and other mixture data. Aspen Plus
cannot perform data regression in a Flowsheet
run. See Chapter 31.

PROPERTIES PLUS A PROPERTIES PLUS
setup run

Prepare a property package for use with Aspen
Custom Modeler or ADVENT, with third-party
commercial engineering programs, or with your
company's in-house programs.

You must be licensed to use PROPERTIES
PLUS.

Property Analysis A standalone property
analysis run. Can contain
property constant estimation
and assay data analysis
calculations.

Perform property analysis by generating tables of
physical property values when you do not want to
perform a flowsheet simulation in the same run.
See Chapter 29.

Property Estimation A standalone property
constant estimation run

Estimate property parameters when you do not
want to perform a flowsheet simulation in the
same run. See Chapter 30.

Completing Input Specifications for a
Run

For Flowsheet runs, follow these basic steps to complete the required and optional
input specifications:
1. Define the simulation flowsheet (blocks, streams, and connectivity) in the

Process Flowsheet window. See Chapter 4.
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2. Enter required input specifications on the following forms in the Data
Browser:

Forms Specify

Setup Global simulation options (see Chapter 5)

Components Conventional chemical components, petroleum assays, and pseudocomponents
in the simulation. For information on working with components, see Chapter 6. For more
information on petroleum assays and pseudocomponents, see Chapter 32.

Physical Properties Methods and data to use for calculating physical properties. For more information
on entering property methods and entering property parameters and data, see Chapters 7
and 8 respectively.

Streams Feed stream compositions, flows, and conditions. For more information, on
specifying streams,  see Chapter 9.

Blocks Design and operating conditions for each unit operation block in the flowsheet
(see Chapter 10).

3. Provide additional specifications if needed by opening the Data Browser and
using the forms shown in this table:

Use these forms To

Reactions Define electrolytes chemistry; specify reaction kinetics for use in reactor and
reactive distillation models (see Chapter 27)

Convergence Specify automatic flowsheet analysis options; specify user-defined tear
streams, convergence blocks, and sequences (see Chapter 17)

Flowsheeting Options Add additional constraints and specifications to the flowsheet model.
Request pressure relief calculations

Model Analysis Tools Specify sensitivity studies, optimization runs, and Data-Fit problems. Data-Fit
is used to fit simulation models to plant or laboratory data.

Setup ReportOptions Specify options for generating the Aspen Plus report. For more information on
specifying the elements in the Report file and on generating the report file, see Chapters
5 and 12 respectively.

Tip   Although you can enter most specifications in any order, it is best to use
Next and let the Aspen Plus Expert System guide you. For more information on
using Next see Chapter 1.
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Completion Status for the Flowsheet
The completion status for the overall flowsheet appears in the status bar of the
main window. When completing specifications for a run, you see the following
status messages:

This status message Means You can

Flowsheet Not Complete The simulation flowsheet has not been
defined or the flowsheet connectivity is
incomplete.

Use Next on the Data Browser
toolbar to find out why
connectivity is incomplete.

Required Input Incomplete Input specifications for the run are
incomplete.

Use Next from the main
window or Data Browser
toolbars to find out what you
must specify to complete the
input specifications and to go
to forms that are incomplete.

Required Input Complete Required input specifications for the run
are complete.

Run the simulation or enter
optional specifications.

Completion Status on Forms
The completion status for the active form or menu appears in the status bar of
the Data Browser. When completing specifications for a new run, you see the
following status messages:

This status message Means You can

Required Input Incomplete Input specifications for the form
or object are incomplete.

Use Next from the Data Browser toolbar to
find out what you must specify to complete
the input specifications.

Input Complete Required input specifications for
the form or object are complete.

Enter specifications for other forms or run the
simulation.
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Completion Status Indicators in the Data Browser Menu
Tree

In the Data Browser menu tree, the following symbols indicate the input
completion status:

Symbol In an Means

Input form Required Input Complete

Input form Required Input Incomplete

Input form No data entered

Mixed form Input and Results

Results form No results present (calculations have not been run)

Results form Results available without Errors or Warnings (OK)

Results form Results available with Warnings

Results form Results available with Errors

Results form Results inconsistent with current input (input changed)

 Input folder No data

 Input folder Input Incomplete

 Input folder Input complete

 Results folder No results present

 Results folder Results available without Errors or Warnings (OK)

 Results folder Results available with Warnings

 Results folder Results available with Errors

 Results folder Results inconsistent with current input (input changed)
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Completion Status Indicators on Sheets

On forms, the completion status for each individual sheet is displayed on the
sheet tab:

Symbol Means

Input specifications for the sheet are incomplete.

Click the tab of the incomplete sheet and complete the input

– or –
Use Next

Input specifications for the sheet are complete.
The required input has been entered by the user.

 (blank) Input for this sheet is optional.

Completion Status for Objects

When you are on an Object Manager for a block or other object, the completion
status for each object appears in the Status column.

Status message Means You can

Input Incomplete Input specifications for the object are
incomplete.

Use Next from the Data Browser toolbar
to go to an incomplete form, or
select an incomplete object from the
Object Manager, and click Edit.

Input Complete Required input specifications for the
object are complete.

Use Next from the Data Browser toolbar
to go to the next step, or enter
optional specifications by selecting an object
from the Object Manager and clicking Edit.

Results Present Results are present. View results, make input changes,
and re-run the simulation

Input Changed Results are present, the input
specifications have been changed
and the input is complete.

View results, make further input changes,
and re-run the simulation

About the Templates

There are built-in Templates for the following applications:

• Air Separation
• Chemicals
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• Electrolytes
• Gas Processing
• General
• Hydrometallurgy
• Petroleum
• Pharmaceuticals
• Pyrometallurgy
• Solids
• Specialty Chemicals

About the General Template
Use the General Template for a wide range of vapor-liquid applications. The
General Template defines the following units sets. These units sets are also
available in all other Templates. For more information on units sets, see
Chapter 5.

Unit-Set Temp Pres Mass Flow Mole Flow Enthalpy Flow Volume Flow

ENG† F psi lb/hr lbmol/hr Btu/hr cuft/hr

MET K atm kg/hr kmol/hr cal/sec l/min

METCBAR†† C bar kg/hr kmol/hr MMkcal/hr cum/hr

METCKGGM C kg/sqcm kg/hr kmol/hr MMkcal/hr cum/hr

SI K n/sqm kg/sec kmol/sec watt cum/sec

SI-CBAR C bar kg/hr kmol/hr watt cum/hr

† 
Default English units set for General Template

†† 
Default metric units set for General Template
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General Template Defaults

The General Template sets the following defaults. See Chapter 5 for information
about setting and changing defaults.

Specification Default

Physical property method None

Flow-basis for input Mole

Stream report composition Mole flow

Stream report format General purpose with enthalpy and density on a mass basis.
Entropy is not reported.

Stream class Conventional.
Appropriate for systems containing vapor, liquid, and salts.

General Template Property Sets

The General Template defines the following property sets. These property sets
are also available in many of the other Templates. For more information about
property sets, see Chapter 28.

Property Set Description

HXDESIGN Thermal and transport properties in SI units needed by
heat exchanger design programs and ADVENT, including:

Mass vapor fraction

Mass flow rate for total, vapor, and liquid phases

Mass enthalpy for total, vapor, and liquid phases

Mass density for total, vapor, and liquid phases

Mass heat capacity for total, vapor, and liquid phases

Pseudo-critical pressure for total, vapor, and liquid phases:

Viscosity for vapor and liquid phases

Thermal conductivity for vapor and liquid phases

Average molecular weight for total, vapor, and liquid phases

THERMAL Thermal properties, including:

Vapor and liquid phase enthalpy

Vapor and liquid phase heat capacity

Vapor and liquid phase thermal conductivity

Continued
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Property Description

TXPORT Transport properties, including:

Vapor and liquid phase mass density

Vapor and liquid phase viscosity

Liquid phase surface tension

VLE Vapor-liquid equilibrium component information, including:

Component fugacity coefficient in vapor and liquid phases

Component activity coefficient in liquid phase

Pure component vapor pressure

VLLE Vapor-liquid-liquid equilibrium component information, including:

Component fugacity coefficient in each phase

Component activity coefficient in each liquid phase

Pure component vapor pressure

About the Petroleum Template
The Petroleum Template defines defaults commonly used in the petroleum
industry. It is also appropriate for petrochemical applications such as ethylene
plants, which involve petroleum fractions as feedstocks.

This table shows the defaults used:

Specification English Default Metric Default

Units F, psi, lb/hr, lbmol/hr,
MMBtu/hr, bbl/day

C, bar, kg/hr, kmol/hr,
MMkcal/hr, bbl/day

Physical property method None None

Free water Yes (see Chapter 5) Yes (see Chapter 5)

Flow basis Standard liquid volume Mass

Stream report composition Standard liquid volume flow Mass flow

Because petroleum applications encompass a wide range of boiling fractions/
components and process conditions, this Template does not have a default
physical property method. These methods are used most frequently:

• BK10
• CHAO-SEA
• GRAYSON
• RK-SOAVE
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• PENG-ROB
• IDEAL

You should consider additional methods for various operations within a refinery
(such as ELECNRTL for sour water strippers and amine treatment units, and
UNIFAC for aromatic extraction). For information to help you determine which
property method is best for your application, see Chapter 7.

Aspen Plus provides comprehensive methods for analyzing assay data and
automatically generating pseudocomponents. You can select from five built-in
pseudocomponent property methods to characterize pseudocomponents. You can
also enter curves of petroleum properties, such as sulfur and metal contents.
Aspen Plus tracks these properties throughout the flowsheet. You can use them
in design specifications, optimization constraints, and objective functions. See
Chapter 32 for more information.

The Aspen Plus PetroFrac model simulates a wide range of fractionation units
within a refinery. PetroFrac can model a tower with any number of:

• Side strippers, including the bottom liquid return to the main tower
• Pumparounds and bypasses
• Partial and total drawoffs

PetroFrac can model the feed furnace as an integral part of the tower, including
the slop cut recycle for a vacuum unit. It lets you enter petroleum-specific
property specifications, such as ASTM distillation temperatures, gaps, and
overlaps. It also offers extensive column sizing and rating capabilities, including
the ability to handle structured packings and integrated pressure drop
calculations. For complete information on PetroFrac, see the Aspen Plus Unit
Operation Models manual.

Petroleum Property Sets

In Aspen Plus, many properties can be used to characterize streams in a refinery.
Chapter 28 lists these properties and explains how to use them.

The Petroleum Template includes property sets for many widely used
petroleum-related properties.

Property Set Description

CUTS-E Standard liquid volume flow of petroleum cuts at 100º F
intervals. Valuable for concise reporting of stream composition.

CUTS-M Mass flow rate of petroleum cuts at 50º C intervals. Valuable for
concise reporting of stream composition.

D86-5 ASTM D86 temperature at 5 liquid volume %

D86-95 ASTM D86 temperature at 95 liquid volume %

Continued
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Property Set Description

GASPROPS Vapor phase properties, including:

Compressibility factor for a mixture

Actual volume flow

Standard vapor volume flow

Heat capacity ratio (CP/CV)

KINVISC Kinematic viscosity at 100°F and 212°F or 40°C and 100°C (dry
basis)

LIGHT Petroleum characteristics for light distillates (dry basis),
including:

Reid vapor pressure

Flash point based on API method

Aniline point

MIDDLE Petroleum characteristics for middle distillates (dry basis),
including:

Cetane number

Flash point based on API method

Pour point based on API method

Aniline point

PETRO† General petroleum properties on dry basis, including:

Standard liquid volume flow (bbl/day) and (bbl/hr)

Standard API gravity

Standard specific gravity

Watson UOP K-factor

True boiling point distillation curve

ASTM D86 distillation curve

ASTM D1160 distillation curve

TBP-5 True boiling point temperature at 5 liquid volume %

TBP-95 True boiling point temperature at 95 liquid volume %

† 
Default for stream results

Petroleum Stream Report Options

The large number of pseudocomponents and distillation curves in a petroleum
application can result in a lengthy stream report.
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The Petroleum Template defines several stream report format (TFF) options so
you can view or print subsets of stream information:

TFF Displays

PETRO-E State variables, stream flows, properties, distillation curves,
component flows. Standard volume flows of the 100°F petroleum
cuts if CUTS-E property set was selected

PETRO-M State variables, stream flows, properties, distillation curves,
component flows. Mass flows of the 50°C petroleum cuts if
CUTS-M property set was selected

PET-COMP Only component flow and total flow results

PET-CURVE Only distillation curve stream results

PET-PROP Only state variables, stream flows, properties, and flows of
petroleum cuts

About the Gas Processing Template
The Gas Processing Template defines defaults commonly used in the gas
processing industry. For example, stream flows are standard vapor volume flows
in millions of standard cubic feet per day or millions of standard cubic meters per
hour.

The gas processing defaults are:

Specification Default

English units F, psi, lb/hr, MMscfd, MMbtu/hr, MMcuft/hr

Metric units C, bar, tonne/hr, MMscmh, MMkcal/hr, cum/hr

Physical property method Peng-Robinson

Flow basis Mole with MMscfd† or MMscmh††

Stream report compositions Mole flow with MMscfd† or MMscmh††

† 
MMscfd is millions of standard cubic feet per day.

††
MMscmh is millions of standard cubic meters per hour.

Peng-Robinson is the default method for calculating physical properties. For
many gas processing applications, such as gas sweetening, gas dehydration, and
the Claus process, you may want to select other physical property methods. For
help selecting physical property methods for your application, see Chapter 7. For
example, you may want to use the ELECNRTL method together with the special
amines data package for gas sweetening.
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Gas Processing Property Sets

This Template also provides property sets commonly needed in gas processing
applications:

Property Set Description

CRITICAL Pseudo critical properties, including:

Pseudo critical temperature

Pseudo critical pressure

Pseudo critical volume

GASPROPS† General gas properties, including:

Compressibility factor

Actual volume flow

Standard vapor volume (MMscfd†† or MMscmh†††)

Heat Capacity Ratio (CP/CV) for mixture

TDEW Dew point temperature

†
Default for stream results

††
MMSCFD is millions of standard cubic feet per day.

†††
MMSCMH is millions of standard cubic meters per hour.

About the Air Separation Template
Use the Air Separation Template for cryogenic air separation simulations. The
defaults are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/hr, cuft/hr

Metric units C, bar, kg/hr, kmol/hr, watt, cum/hr

Physical property method Peng-Robinson

Components included O2, N2, AR

Flow basis Mole

Stream report composition Mole flow and mole fraction

These Aspen Plus unit operation models are used extensively in air separation
simulations:
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Model Description

RadFrac Rigorous distillation

MultiFrac Multiple column simulation

HeatX Rigorous heat exchange

MHeatX Cold box heat exchange

The MultiFrac model is especially useful for modeling the double- and
triple-column systems typically found in air plants. MultiFrac solves these
interlinked column systems as a single unit, without recycle flow estimates.

Air plants are highly heat-integrated. You can specify heat streams to model the
complex heat integration between units.

Air Separation Property Sets

The air separation property sets are:

Property Set Description

CRITICAL Pseudo critical properties, including:

Pseudo critical temperature

Pseudo critical pressure

Pseudo critical volume

GASPROPS† General gas properties, including:

Compressibility factor

Actual volume flow

Standard vapor volume (MMscfd†† or MMscmh†††)

Heat Capacity Ratio (CP/CV) for mixture

TBUBBLE Bubble point temperature

TDEW Dew point temperature

†
Default for stream results

††
MMscfd is millions of standard cubic feet per day.

†††
MMSCMH is millions of standard cubic meters per hour.
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About the Chemicals Template
The Chemicals Template is suitable for a wide range of chemical (non-electrolyte)
applications. It is also appropriate for petrochemical applications, such as MTBE
production and VCM plants, where feedstocks are defined in terms of chemical
components.

The defaults are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/hr, cuft/hr

Metric units C, bar, kg/hr, kmol/hr, MMkcal/hr, cum/hr

Physical property method NRTL

Flow basis Mole

Stream report composition Mole flow

The default base property method is NRTL, which has wide application for
low-pressure ideal and non-ideal chemical systems. Aspen Plus has several
additional activity coefficient models and equations of state for modeling
chemical systems. For example, for systems containing organic acids, use
NRTL-HOC, WILS-HOC, or UNIQ-HOC methods. For chemical systems at high
pressures, use an equation-of-state method, such as RK-ASPEN, SR-POLAR,
PRWS, PRMHV2, or PSRK. For more information on Aspen Plus physical
property methods, see Chapter 7.

Each activity coefficient and equation-of-state model has a large databank of
binary interaction parameters suitable for modeling chemical systems.
Aspen Plus automatically retrieves and displays these binary parameters. If the
database does not have binary parameters for a component pair, Aspen Plus can
estimate the missing binary parameters for your application (see Chapter 30).

If you have measured data for your chemical system you can use Aspen Plus to
regress model parameters. For more information on regressing property data, see
Chapter 31. Aspen Plus has interactive tools for analyzing the properties and
vapor-liquid equilibrium of chemical systems. For more information on property
analysis, see Chapter 29.

The built-in property sets are the same as for the General Template.
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About the Electrolytes Template
The Electrolytes Template is used for applications that require rigorous modeling
of electrolyte species. You can use this Template in any application where
electrolytes are important.

The defaults are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/hr, cuft/hr

Metric units C, bar, kg/hr, kmol/hr, MMkcal/hr, cum/hr

Physical property method ELECNRTL

Components included H2O

Flow basis Mass

Stream report composition Mass flow

Stream report format Displays all electrolyte properties that are requested in
property sets

The ELECNRTL property method model is recommended for rigorously modeling
electrolyte systems. This property method is described in more detail in
Chapter 7.

Aspen Plus has a large built-in databank of electrolyte reactions and interaction
parameters for many electrolyte systems. The Aspen Plus Electrolytes Wizard
generates electrolytes chemistry automatically and interactively, so you can
control the species and reactions to include in your simulation. See Chapter 6
and Aspen Plus Getting Started Modeling Processes with Electrolytes for
instructions on how to build an electrolytes application.

Electrolytes Property Sets

The built-in property sets are:

Property Set Property Description

FAPP Apparent component mole flow

FTRUE True component mole flow

LVOLFLOW Liquid volumetric flow

MASSCONC Mass concentration

MOLECONC Mole concentration

PH pH at current temperature

Continued
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Property Set Property Description

SOLINDEX Solubility index

TBUBBLE Bubble point temperature

VMOLFLOW Component mole flows in vapor phase

VMOLFRAC Component mole fractions in vapor phase

WXAPP Apparent component mass fraction

WAPP Apparent component mass flow

XTRUE True component mole fraction

About the Specialty Chemicals Template
The Specialty Chemicals Template is for specialty chemical applications, with or
without electrolytes. You can view stream results on a:

• Concentration basis
• Per batch basis, if you select the Batch-Operations report option (see

Chapter 12)

The defaults for this Template are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/hr, gal/hr

Metric units C, bar, kg/hr, kmol/hr, kcal/hr, l/hr

Physical property method NRTL

Flow basis Mass

Stream report composition Mass flow

Stream report format Displays standard properties, plus concentration and batch
stream report, if requested. Electrolyte properties are also
displayed if an electrolyte method and electrolyte property
set are selected.

Aspen Plus has two batch unit operation models that are especially useful for
specialty chemicals applications:

• RBatch, a batch reactor
• BatchFrac, for batch distillation

See Chapter 10 or Aspen Plus Unit Operation Models for more information.
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The default base property method is NRTL, which has wide application for
low-pressure ideal and non-ideal chemical systems. Aspen Plus has additional
activity coefficient models and equations of state for modeling chemical systems.
For more information on Aspen Plus physical property methods, see Chapter 7.

Each activity coefficient model has a large databank of binary interaction
parameters suitable for modeling chemical systems. Aspen Plus automatically
retrieves and displays these binary parameters. If the database does not have
binary parameters for a component pair, Aspen Plus can estimate the missing
binary parameters for your application.

If you have measured data for your chemical system, you can use Aspen Plus to
regress model parameters. Aspen Plus has interactive tools for analyzing the
properties and vapor-liquid equilibrium of chemical systems. For more
information on property analysis, see Chapter 29.

If your process involves electrolytes, use the Electrolytes Wizard to define the
reactions and ionic species. For more information on the Electrolytes Wizard, see
Chapter 6. The NRTL method will be replaced by ELECNRTL, and the
electrolytes database will be used.

The built-in property sets are the same as for the Electrolytes Template.

About the Pharmaceuticals Template
The Pharmaceuticals Template uses NRTL as the default base property method.
You can use this method for two-liquid-phase systems, or vapor and liquid
systems at low pressure. This Template reports stream composition on a mass
concentration and mass flow basis. You can also view the vapor-liquid-liquid
equilibrium for any stream and examine results on a per batch basis, if you select
the Batch-Operations report option.

The defaults for this Template are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/hr, gal/hr

Metric units C, bar, kg/hr, kmol/hr, kcal/hr, l/hr

Physical property method NRTL

Flow basis Mass

Stream report composition Mass flow and mass concentration

Stream report format Displays standard properties, plus batch stream report if
requested
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Aspen Plus has two batch unit operation models that are especially useful for
pharmaceutical applications:

• RBatch, a batch reactor
• BatchFrac, for batch distillation

For more information, see Chapter 10 or Aspen Plus Unit Operation Models.

The built-in property sets are:

Property Set Description

LVOLFLOW Liquid volumetric flow

MASSCONC† Mass concentration

MOLECONC Mole concentration

VMOLFLOW Component mole flows in vapor phase

VMOLFRAC Component mole fractions in vapor phase

†
Default for stream report

About the Hydrometallurgy Template
Use the Hydrometallurgy Template to model electrolytes and solids in
hydrometallurgical processes.

The defaults for this Template are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/HR, cuft/hr

Metric units C, bar, kg/hr, kmol/hr, MMkcal/HR, cum/hr

Physical property method ELECNRTL

Component included H2O

Flow basis Mass

Stream class MIXCISLD, for modeling hydrometallurgy systems with vapor, liquid,
electrolytes, salts, and inert molecular solids.

Stream report composition Not displayed with default stream report format

Stream report format Displays all substreams together

The ELECNRTL property method is recommended for rigorously modeling the
electrolyte systems present in hydrometallurgy processes. This property method
is described in more detail in Chapter 7 and in Aspen Plus Physical Property
Methods and Models, Chapter 2.
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Aspen Plus has a large built-in databank of electrolyte reactions and interaction
parameters for many electrolyte systems. The Aspen Plus Electrolytes Wizard
generates electrolytes chemistry automatically and interactively, so you can
control the species and reactions to include in your simulation. See Chapter 6
and Aspen Plus Getting Started Modeling Processes with Electrolytes for
instructions on how to build an electrolytes application.

Property Sets for Hydrometallurgy

The built-in property sets for hydrometallurgical simulations include all property
sets listed for Electrolytes Simulation, plus the following:

Property Set Description

ALL-SUBS Characteristics for entire stream, including:

Temperature

Pressure

Volumetric flow

Mass vapor fraction

Mass solids fraction

Mass density

Mass flow

This property set is the default for stream report

About the Pyrometallurgy Template
Use the Pyrometallurgy Template to model high temperature metals processing
applications. The defaults are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/hr, cuft/hr
Metric units C, bar, tonne/hr, kmol/hr, MMkcal/hr, cum/hr
Physical property method SOLIDS
Flow basis Mass
Stream class MIXCISLD, for modeling pyrometallurgy systems with only molecular

species. If you have ores that must be defined as non-conventional
components or if you need to model particle size distribution, you will
need a different stream class (see Chapter 9).

Stream report composition Not displayed with default stream report format
Stream report format Displays all substreams together
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Pyrometallurgical processes often involve chemical and phase equilibrium
between multiple liquid phases and a vapor phase. Aspen Plus uses the RGibbs
model to simulate these multiphase operations. Pyrometallurgical applications
often require different activity coefficient models for different liquid phases in the
system. You can create multiple methods, based on the SOLIDS method, to use
different activity coefficient models. You can then assign the new method to
specified liquid phases. For more details on how to modify a physical property
method, see Chapter 7.

Pyrometallurgy Property Sets

The pyrometallurgy property sets are:

Property Set Description

ALL-SUBS† Characteristics for entire stream, including:

Temperature

Pressure

Volumetric flow

Mass vapor fraction

Mass solids fraction

Mass density

Mass flow

VMOLFLOW Vapor mole flow

VMOLFRAC Vapor component mole fractions

†
Default for stream results

About the Solids Template
Aspen Plus can model solids anywhere in a process flowsheet. A wide range of
unit operation models for solids handling equipment is available, including
crystallizers, crushers, screens, and cyclones. See Aspen Plus Unit Operation
Models for more information on the models. See Getting Started Modeling
Processes with Solids to learn how to model solids processes step-by-step.

The Solids Template reports the properties and component flows of all types of
components (vapor, liquid, and solid) together. You can also request Aspen Plus
to report:

• Overall stream concentrations
• Vapor fractions
• Solid fractions
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If you use attributes in your simulation, substream and component attributes
appear in the default stream report.

The defaults for this Template are:

Specification Default

English units F, psi, lb/hr, lbmol/hr, Btu/hr, cuft/hr

Metric units C, bar, kg/hr, kmol/hr, MMkcal/hr, cum/hr

Physical property method None, but SOLIDS is recommended

Flow basis Mass

Stream class MIXCISLD, but you will often want to select a different
stream class based on your application

Stream report composition Not displayed with default stream report format

Stream report format Displays all substreams together

Solids Property Sets

The built-in property sets for solids are:

Property Set Description

ALL-SUBS† Characteristics for entire stream, including:

Temperature

Pressure

Volumetric flow

Mass vapor fraction

Mass solids fraction

Mass density

Mass flow

MASSCONC Mass concentration

MOLECONC Mole concentration

VMOLFLOW Component mole flows in vapor phase

VMOLFRAC Component mole fractions in vapor phase

†
Default for stream results
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Using the Online Applications Library

Aspen Plus includes a library of Application Examples to illustrate how Aspen Plus
is used to solve a range of industrial problems.

These application examples cover a range of process industries, including gas
processing, petroleum refining, petrochemicals, chemicals, pharmaceuticals, and
metals processing. You can examine the input and results for these applications,
see how to use various Aspen Plus features, and modify and run these
applications to simulate your own processes.

These examples demonstrate the value of many Aspen Plus features, including
residue curves, three-phase reactive distillation, rigorous heat exchange rating,
and extraction with user liquid-liquid distribution correlations.

Accessing the Online Applications Library
To access the online applications library in Aspen Plus:
1. From the File menu, click Open.

– or –

If you have just started Aspen Plus, from the Aspen Plus Startup dialog box,
click Open an Existing Simulation, select More Files… from the list of files,
and Click OK.

2. In the Open dialog box, click the Favorites button .

3. Click the app directory.

4. To view a description of a file, click the file then click the Preview button 
on the Open dialog box toolbar.

5. Click the file you want to open, then click Open.

6. The input and results are then loaded. You can examine, modify, and run the
simulation.

Examining Descriptions of Files

To view a description of a file before opening it:

➤ Click the file then click the Preview button (button that is furthest right) on
the Open dialog box toolbar.
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To view a description of an open file:
1. From the Data menu, click Setup, then click Specifications.

2. Click the Description sheet.

To examine available comments for blocks and other objects, click the Comments
button from the toolbar of the Data Browser.

If comments are available, the Comments button looks like this: 

If there are no comments available, the Comments button looks like this: 

❖     ❖     ❖     ❖ 
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3 Using Aspen Plus Help

Aspen Plus has online Help, prompts and expert system messages, to give you
information as you use the program.

This chapter explains how to use Help including:

• Getting online Help
• Using hypertext links
• Using the Back button
• Searching for help on a topic
• Printing help
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Getting Help
There are several ways to get help in Aspen Plus:

If you want help about Do this

A particular topic On the Help menu, click Help Topics.
From the Help Topics dialog box, click the Index tab.

A form or field On the Aspen Plus toolbar, click the What's This button
then click the field or form.

A dialog box Click the Help button on the dialog box.

The item the cursor or mouse pointer is on Press F1.

About The Help Window
Aspen Plus help topics appear in Help windows.

Help Topics
button displays
the Help
Contents window

Title of Help topic

Hypertext links
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This table provides more information about elements you might find on a Help
window:

Window Element Description

Help title Title of the help topic currently displayed in the Help window. For example, Aspen Plus Help.

Hyperlink A word or phrase that displays information on a related topic when you click it

See Also hyperlink An additional topic you can move to by clicking  it

Help Topics button or
Contents button

Displays the Help Contents window, including Contents,  Index and Find tabs

Back button Returns you to the last help topic you viewed

Search button Displays the Index. You can enter a topic you want more information about.

Options button Displays options you can use to change your view of Help

Menus Contains commands to print help topics, close the Help window, and so on

Browse buttons (<< and >>) Enables you to browse forward and back through help topics

Note  Not all buttons are available in all help windows:

To keep the Help window on top of any other open windows:
1. In the Help window, click the Options button or menu.

2. Point to Keep Help On Top, and then click On Top.

Hypertext Links
You can move directly from one help topic to a related topic by clicking on a
hypertext link. Any underlined text (green on a color monitor) in the Help
window is a hypertext link.

Hypertext links can be:

• Words in a paragraph
• Topics listed at the end of a help topic

To jump to the topic indicated by the hypertext link, click the underlined text.

Using the Back Button
Use the Back button to move back through help screens you have seen. If there is
no previous topic to view, the Back button is unavailable. Back keeps a complete
record of all the help topics you view. This list is cleared each time you exit help.
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Searching for Help on a Topic

You can find specific information quickly by searching for it. To search for a topic or
keyword:
1. From the Help menu, click Help Topics, then click the Index tab.

The Index dialog box appears:

2. Start typing a word or phrase to display a list of index entries that match
what you are looking for.

3. Click Display or double-click on the entry in the list.

Either the topic appears, or a dialog box containing a list of topics appears:

4. To display the topic you want, click the topic, then click Display.

The help topic appears in the Help window.
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Displaying Help on Dialog Boxes, Forms
and Sheets

To access online Help that gives you an overview of a dialog box, form or sheet:

➤ Click the Help button on the dialog box, form or sheet.

– or –

Press F1 on the dialog box, form or sheet.

Displaying Help on Screen Elements
To access online Help on buttons, fields, commands on menus, and similar screen
elements:

➤ Click the What's This button  or on the window toolbar and then click
the element.

– or –

Select the element, then press F1.

Getting Step by Step Help
To get help on preparing, specifying, and running simulations, and reviewing
results:
1. From the Help Topics dialog box, click the Contents tab.

2. Double-click Using Aspen Plus, then click the topic you want.

Getting Reference Information
To obtain reference information:

➤ From the Help Topics dialog box, click the Contents tab, then click the
appropriate topic.



3-6 Aspen Plus User Guide
Version 10.1-0

Using Aspen
Plus Help

Printing Help
To print a help topic:
1. Make sure the printer settings are correct.

To check this, Click Start, then point to Settings then Printers.

2. Display the Help topic you want to print.

3. Click the Print button.

– or –

Click the Options button, then click Print Topic.

– or –

From the File menu, click Print Topic.

Printing Popup Help

To print popup help windows:
1. Click with the right mouse button on the Help window.

2. From the popup menu, click Print Topic.

Improving Help

We value your comments, suggestions, and criticisms. If you couldn’t find the Help
you were looking for, needed more assistance that the online help provided, or have
any suggestions for future improvements to our online information, we want to
know.

Please email your comments to Docs@Aspentech.com

Note  If you have a query about Aspen Plus itself and want to email the
AspenTech Support team, please email your local Technical Support office.

❖     ❖     ❖     ❖ 
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4 Defining the Flowsheet

This chapter describes defining a process flowsheet in Aspen Plus including:

• Creating a process flowsheet
• Using heat and work streams
• Using pseudoproduct streams
• Viewing a process flowsheet
• Checking flowsheet completeness
• Modifying a process flowsheet
• Using flowsheet sections
• Printing

For descriptions and information about the user interface, see Chapter 1.

Creating a Process Flowsheet

To define a process flowsheet:
1. From the View menu, ensure that PFD mode is turned off. Otherwise, the

blocks and streams you place graphically, do not become part of your
simulation model. For more information, see Chapter 14.

2. Select the unit operation blocks and place them in the Process Flowsheet
Window.

3. Connect the streams to the blocks.

After placing blocks and streams, you can:

• Delete blocks and streams
• Rename the blocks and streams
• Change stream connections
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You can also improve the appearance of your flowsheet in many different ways.
For more information, see Modifying the Flowsheet on page 4  - 11.

When you are defining your flowsheet, the shape of the mouse pointer changes,
indicating the particular mode Aspen Plus is in:

Pointer Shape Function Use

Select mode Click an object to select it.
Click and hold an object to enter Move mode.
Click and drag to select a region or to move or resize a region
(The pointer changes to the Resize shape).

Insert mode Click to place a model of the type selected in the Model Library.
Note  After placing each block, you remain in Insert Mode until you
click the Select Mode button in the upper left corner of the Model Library.

Connect mode Click a port to connect the stream to it
Click a blank area of the flowsheet to to place a feed or product

Move mode Click and hold to move the object to a desired location

 Port move mode Click and hold to move the port to a desired location
Drag the port away from the model to enter Disconnect mode

  Disconnect mode Click and hold on a stream while dragging it away from a block to
disconnect it. Release the mouse button to enter Connect mode.

Resize mode Click and drag to resize a model or region

Use the Model Library to select unit operation models to be used in the
simulation.

Placing Blocks
To place a unit operation block in a simulation flowsheet:
1. Click a model category tab in the Model Library to display a list of models in

that category.

2. In the Model Library, select the unit operation model that you want to place
in your process flowsheet. To choose a different icon for the model, click the
down arrow, and click an icon to select it. The icon you select will remain the
default icon when placing that model, until you change the icon.

3. Click and hold down the mouse button on the unit operation model, and drag
it to the Process Flowsheet window.

4. The mouse pointer is in the shape of a box with an arrow,  which indicates
that only one block will be placed.
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5. In the Process Flowsheet window, release the mouse button where you want
to place the block.

If you have switched off Automatically Assign Block Names, you are
prompted to enter the Block ID. For more information on IDs, see Options for
Naming Blocks and Streams on page 4-12. The icon that you selected appears
on the flowsheet.

6. Continue creating your flowsheet. To place another block repeat steps 1
through 4.

When you place or move blocks, the center of the block icon snaps to a grid
location if Snap to Grid is enabled on the Grid/Scale tab of the Tools Options
dialog box.

Placing Multiple Blocks

To place multiple blocks of the same type in the flowsheet:
1. Click a model category tab in the Model Library to display a list of models in

that category.

2. In the Model Library, select the unit operation model that you want to place
in your process flowsheet. To choose a different icon for the model, click the
down arrow, and click an icon to select it. The icon you select will remain the
default icon when placing that model, until you change the icon.

3. Click the unit operation model (click the icon then release the mouse button.)

The pointer appears in the shape of a crosshair, representing Insert mode.

4. In the Process Flowsheet window, click where you want to place the block.
The icon that you selected appears on the flowsheet.

If you have switched off Automatically Assign Block Names, you are
prompted to enter the Block ID. For more information on IDs, see Options for
Naming Blocks and Streams on page 4-12. The icon that you selected appears
on the flowsheet.

5. Continue creating your flowsheet.

If you want to Do this

Place another block for the same model Click in a new location on the flowsheet.

Place a block for a different model Repeat steps 1 to 4.

Stop placing blocks
Click the Select Mode button  in the upper left corner
of the Model Library. This turns off insert mode. Insert
mode is on when the Select Mode button is raised, and off
when the button is depressed.
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When you place or move blocks, the center of the block icon snaps to a grid
location if Snap to Grid is enabled on the Grid/Scale tab of the Tools Options
dialog box.

Placing Streams and Connecting Blocks
To place a stream:
1. Click the STREAMS icon on the left side of the Model Library.

2. If you want to select a different stream type (Material, Heat or Work), click
the down arrow next to the icon and choose a different type.

Move the mouse pointer to the Process Flowsheet window. For each block in
the Process Flowsheet window, all ports that are compatible with that stream
type are highlighted.
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Ports that must have at least one stream connected are shown in red. Other
optional ports are shown in blue. If you position the mouse over a displayed
port, the arrow is highlighted and a text box with the description of the port
appears.

3. Click a highlighted port to make the connection.

If the port is not at the location you want it, click and hold the mouse button
on the port. When the mouse pointer changes to the port move shape (  )
drag to relocate the port on the icon.

4. Repeat step 4 to connect the other end of the stream.

Only those ports that you can connect the other end of the stream to remain
highlighted. For example, if you connect a stream to an outlet port, inlet ports
remain highlighted but outlet ports are no longer highlighted.

If you have switched off Automatically Assign Stream Names on the
Flowsheet tab of the Tools Options box, then you will be prompted for a
Stream ID.

5. To place one end of the stream as either a process flowsheet feed or product,
click a blank part of the Process Flowsheet window.

If the stream’s source is already connected, then a product will be placed. If
the stream’s destination is already connected, then a feed will be placed. By
default, if you click a blank part of the window before connecting either
stream end, a feed is placed.
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6. To stop placing streams click the Select Mode button  in the upper left
corner of the Model Library:

To cancel connecting the stream at any time, press ESC or click the right
mouse button.

To place another stream of the same type, repeat steps 4 through 6.

To place a stream of a different type, repeat steps 2 through 6.

You can also use drag and drop to connect streams.  The procedure is similar to
the one described above.
1. Select the stream type you want, by clicking the Material Stream icon in the

Model Library or using the down arrow next to the icon to select a Heat or
Work stream.

2. Click and hold down the mouse button on the stream icon.

Tip   Hold down the CTRL key during drag and drop to remain in Insert
mode after completing connections for the first stream.

3. Move the cursor to the Process Flowsheet Window.

The compatible ports are highlighted.

4. Release the mouse button on:

• A port to make a connection
• A blank part of the flowsheet to place a feed

5. Move the mouse and click:

• Another highlighted port to connect the other end of the stream
• A blank part of the flowsheet to place a product
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Using Heat and Work Streams
You can define heat and work streams to transfer heat and power between
blocks, or for duty and power specifications. For example, you can use a work
stream to transfer power from a turbine to a compressor. For more information
on Heat and Work streams, see Chapter 9.

When creating a heat or work stream:

• Select the heat or work icon from the Model Library.
• Use a port labeled Heat Stream(s) or Work Streams(s).

Heat and work streams appear as dashed lines in the flowsheet.

Using PseudoProduct Streams
You can define pseudoproduct streams to represent column internal flows,
compositions, thermodynamic conditions streams for some unit operations
models. For more information, see Chapter 9.

Pseudoproduct streams from one block may be an inlet to another block. Using a
pseudo-stream as a block inlet results in an imbalance in the overall flowsheet
material and energy balance report.

To define a pseudoproduct stream:

➤ When creating the stream select a port labeled Pseudo Streams.

Viewing The Flowsheet

If your flowsheet contains more than a few blocks, your workspace will soon be full.

Sometimes block and stream IDs appear off the screen, so it is difficult to locate a
particular block or stream.

To display a block that is off the screen or a specific part of the flowsheet, you can
use the:

• Zoom level
• Scrollbars
• Data Browser
• Bookmarks
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• Pan

Adjusting the Zoom Level
To change your view of the flowsheet by zooming:

➤ From the View menu point to Zoom, then the option you require.

– or –

1. Position the mouse pointer in an empty area of the Process Flowsheet window
and click the right mouse button.

2. From the menu that appears, click:

This zoom option To

Zoom In Zoom in

Zoom Out Zoom out

Zoom Full Show the full flowsheet

With the view zoomed in, you can display a specific part of the flowsheet by using
the scroll bars.

Adjust the effect of Zoom In and Zoom Out by selecting Options from the Tools
menu and changing the value of the Zoom Scale Factor on the Grid/Scale tab.

Using the Scrollbars
If you are working in a large flowsheet, the block you want to connect to may be
off the screen. You can use the scrollbars to display:

• A block that is off the screen
• A specific part of the flowsheet

To use the Workspace scrollbars:

➤ Click a scrollbar arrow.

The amount that this moves the view is determined by the Scroll Step Size on
the Grid/Scale tab of the Tools Options dialog box.

– or –

➤ Click between the slider and an arrow.

This moves the view by a set amount.
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Using the Data Browser to Find Blocks in a Large
Flowsheet

If you are working in a large flowsheet, it may be difficult to locate a particular
block. You can use the Data Browser to find a block:
1. From the Data menu, click Data Browser (or press F8).

2. Expand the Blocks folder.

3. Select the block that you want to find.

4. Return to the Process Flowsheet window, without clicking it. To do this:

If you have/are in this view Do this

Normal From the Window menu, click Process Flowsheet window
– or –
Click the titlebar of the Process Flowsheet window

Flowsheet as Wallpaper Minimize or close the Data Browser

Workbook Click the Process Flowsheet tab

The block you selected is highlighted.

5. Click the block with the right mouse button and from the menu that appears,
click Center View.

6. Click an empty part of the flowsheet and click with the right mouse button,
and from the menu that appears, click Zoom In if you want a closer view.

Using Bookmarks
If you are working in a large flowsheet, there may be sections that you want to
look at frequently. Use Bookmarks to save these views.

To create a bookmark:
1. While in Select mode, click and drag to select an area of the flowsheet.

2. Click the right mouse button and from the menu that appears, click
Bookmarks.

3. Tip  You can also press F3 to access Bookmarks.

4. Type a name for the Bookmark in the Name box, then click Add to add the
bookmark to this list.

5. To exit the Bookmarks dialog box, click Close.

To go to a bookmarked view:
1. In the Process Flowsheet window, click the right mouse button.
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2. From the menu that appears, click Bookmarks.

Tip   You can also press F3 to access Bookmarks.

3. Click the name of the desired Bookmark, then click Go To.

4. The flowsheet appears in the predefined view you selected.

Using Pan
Use Pan to select a view of the flowsheet at the current zoom level.
1. In the Process Flowsheet window, click the right mouse button.

2. A full view of the flowsheet appears and a dashed rectangle.

3. Move the rectangle to an area that you wish to zoom in on and click the left
mouse button.

4. To cancel pan, click the right mouse button.

Checking Flowsheet Completeness

To check completeness for the entire flowsheet, look at the status indicator in the
bottom right of the main window.

If the status is Flowsheet Not Complete, then flowsheet connectivity is incomplete
because:

• Additional streams must be connected to one or more blocks in the flowsheet.
• Streams have been disconnected but not reconnected.
• No blocks have been defined.
• To find out why the connectivity is incomplete:

➤ Click the Next button  on the Data Browser toolbar.

A Flowsheet Not Complete window indicates what is required to complete the
flowsheet definition.

If any other status message appears, then flowsheet connectivity is complete.
All required streams are connected to flowsheet blocks.
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Modifying the Flowsheet
You can modify the flowsheet at any time to:

• Change its connectivity
• Improve the appearance
• Redraw all or part of the flowsheet

Changing Flowsheet Connectivity
To change the flowsheet connectivity, you can:

• Delete blocks and streams
• Rename blocks and streams
• Change stream connections
• Insert a block into a stream

Deleting Blocks and Streams

To delete a block or stream:
1. Click the block or stream to select it.

2. Click with the right mouse button on the block or stream.

3. From the popup menu that appears, click Delete Block or Delete Stream.

4. When prompted, click OK.

Tip   You can also select the block or stream, then press Delete on the
keyboard.

Renaming Blocks and Streams

To rename a block or stream from the flowsheet:
1. Select the block or stream you want to rename.

2. Click the right mouse button on the block or stream.

3. From the menu that appears, click Rename Block or Rename Stream.

4. When prompted, enter the new name and click OK.

You can also rename blocks and streams using the Data Browser.
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Options for Naming Blocks and Streams

By default, Aspen Plus automatically assigns IDs to blocks and streams. You can
either:

• Supply prefixes for the automatic naming
• Turn off the automatic naming and be prompted for a name for each block

and stream as you place it

To specify the naming options:
1. From the Tools menu, click Options.

2. Click the Flowsheet tab.

3. Select the Automatically Assign Block Name with Prefix and/or Automatically
Assign Stream Name with Prefix check box(es).

4. If desired, you can also type a prefix in the field. A sequential number is
added to the prefix. If no prefix is supplied, the blocks or streams are
numeric.

For more information on flowsheeting options, see Chapter 16.

Changing Stream Connections

You can disconnect the end of a stream from a unit operation block and then
connect it to another port on the same or a different block. To change the port
that a stream is connected to:

Method 1:
1. Click to select the stream that you want to move or click the block to which

the streams is connected.

2. Position the mouse pointer where the end of the stream connects to the block,
so the arrow is highlighted and a text box with the name of the port appears.

3. Hold down the left mouse button and the mouse pointer changes to the port
move shape.

4. Move the stream end away from the block. The mouse pointer changes to the
disconnect shape indicating that the stream is about to be disconnected.

5. Click the mouse button to disconnect.

For each block all available ports are highlighted. For example, for a feed
stream, the outlet ports are highlighted. The ID of the stream appears in a
text box by the end that is being reconnected. Ports that must have at least
one stream connected are shown in red. Others are shown in blue.

6. Click the port to which you want to connect the stream end.
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Method 2:
1. Click the stream.

2. Click the right mouse button.

3. From the menu that appears, click:

• Reconnect Source to disconnect the source end of the stream
• Reconnect Destination to disconnect the output end of the stream
For each block all available ports are highlighted. For example, for a feed
stream, the outlet ports are highlighted. The ID of the stream appears in a
text box by the end that is being reconnected. Ports that must have at least
one stream connected are shown in red. Others are shown in blue.

4. Continue as you would for a new stream. Click the port to which you want to
connect the stream end, or click a blank part of the flowsheet to place a feed
or product.

Inserting a Block into a Stream

To insert a block into a stream:
1. Place the new block on the flowsheet by selecting a unit operation model from

the Model Library and dragging it to the flowsheet. For more information, see
Placing Blocks on page 4-2.

2. Select the desired stream and click the right mouse button on the stream.

3. From the menu that appears, click Reconnect Source or Reconnect
Destination.



4-14 Aspen Plus User Guide
Version 10.1-0

Defining the
Flowsheet

4. Click a port on the new block to reconnect the stream to it.

5. Connect a new stream from the new block to the original source or
destination, by clicking the STREAMS icon and clicking the inlet or outlet
port. For more information, see Placing Blocks on page 4-2.

Improving the Appearance of the Flowsheet
You can change the flowsheet layout at any time to improve the appearance of
your drawing. You can move:

• Blocks
• Multiple blocks and streams at once
• Block IDs
• Stream segments
• Stream corners
• Streams IDs
• Stream connnection locations

You can also:

• Hide block and stream IDs
• Reroute streams
• Align blocks
• Change icons
• Resize icons
• Rotate icons
• Use Place to redraw flowsheets automatically

Many commands and actions can apply to multiple blocks or streams as well as
to an individual one.

You can select multiple blocks and streams in several ways:

• Click and hold the mouse button while dragging the mouse over a region.
• Hold down the Ctrl key while clicking on the blocks or streams.
• Click the right mouse button in the Process Flowsheet window.  From the

menu that appears, click Select All.
Click here for information on moving multiple objects at once.

Moving Multiple Objects at Once

To move multiple objects at once:
1. Select the objects you want to move.

2. Hold down the mouse button on any object within the region.
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The mouse pointer changes to the move shape ( ).

3. Drag the objects to the location you want, and release the mouse button.

Tip   You can also select multiple objects and then use the arrow keys
(←↑→↓) to move them to the new location.

Moving a Block

To move a block:
1. Press and hold down the mouse button on the unit operation block (but not on

the block ID) that you want to move.

The outline of the block is highlighted and the mouse pointer changes to the
move shape. Also a text box appears showing information about the block,
including name, section and status of the block.

2. Drag the block to the location you want and release the mouse button.

When you place or move blocks, the center of the block icon snaps to a grid
location if Snap to Grid is enabled. For information on changing the grid
options, see Chapter 16.

Tip   You can also select the block and then use the arrow keys
(←↑→↓) to make minor adjustments to the position of the block.

Moving a Block ID

To move a Block ID:
1. Press and hold down the mouse button on the block ID.
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The mouse pointer changes to the move shape ( ).

2. Drag the block to the location you want and release the mouse button.

Tip   You can also select the block ID and then use the arrow keys
(←↑→↓) to move the block ID.

If you later move the block, the ID maintains its position relative to the block.

Hiding a Block or Stream ID

To hide a block or stream ID:
1. Click the block or stream in the flowsheet to select it.

2. From the Flowsheet menu, point to Hide and then ensure ID is checked.

– or –

Click the right mouse button and from the menu that appears, point to Hide
and then ID.

– or –

Press CTRL + H on the keyboard.

Tip   To hide the block IDs for all future blocks created, clear the Display
Block Name checkbox on the Flowsheet tab of the Tools Options dialog box.
For more information, see Chapter 16.

Changing the Icon

To change an icon:
1. Click the block whose icon you wish to change.

2. Click with the right mouse button on the block.

3. From the popup menu that appears, click Exchange Icon.

4. The icons for the block changes to the next icon in the list for the model.

Tip   You can also change the icon by clicking the block, then pressing the
letter n to change to the next icon available for the block, or p to change to the
previous available icon.

Rotating Icons

To rotate an icon:
1. Click the block whose icon you wish to rotate.
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2. Click with the right mouse button on the block.

3. From the menu that appears, click Rotate Icon.

4. A submenu appears, allowing you to rotate the icon to the right (clockwise) or
left, or flip the icon around either axis (for example, to reverse flow direction).

Tip   You can also use the buttons on the Process Flowsheet toolbar

 to rotate and flip an icon.

Resizing Icons

To resize an icon:
1. Click the block whose icon you wish to resize.

2. Click with the right mouse button on the block.

3. From the menu that appears, point to Resize Icon, then Shrink or Enlarge to
shrink or enlarge the icon by a built-in factor.

– or –

Position the mouse pointer over one of the corners of the block icon until the
Resize mode pointers appear. Drag the mouse pointer until the icon until it is
the desired size.

Aligning Blocks

To align two blocks:
1. Click the stream between the two blocks.

2. Click with the right mouse button on the stream.

3. From the menu that appears, click Align Blocks.

Tip   You can also select one or more streams and press CTRL + B.

Note  Blocks attached to selected streams are aligned on a grid if Snap to Grid is
enabled on the Grid/Scale tab. For information on this, see Chapter 16.

Moving Stream Connection Locations

To move the point where a stream connects to a unit operation block without
changing the stream's connection to its current port on the icon:
1. Click the stream that you want to move or click the block to which it is

connected. The stream is selected.
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2. Position the mouse pointer where the end of the stream connects to the block.

3. The arrow is highlighted and a text box with the descriptions of the port
appears.

4. Hold down the left mouse button. The mouse pointer changes to the move
shape.

5. Drag the stream end to the preferred point on the block and release the
mouse button.

Moving the stream end does not move the port to which the stream is
connected. Consequently, the point where the stream end is now attached to
the block is not a port and may not be used to directly connect further
streams.

6. To display the location of the port, click the stream end:

port

Relocated
stream end

Tip   You can also move any part of the stream by selecting it and dragging
the part of the stream you want to move to its new location.
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Moving a Stream Segment

To move a stream segment:
1. Press and hold down the mouse button on the segment of the stream you wish

to move (but not on the stream ID).

2. The mouse pointer changes to the move shape.

3. Drag the segment of the stream to the location you want and release the
mouse button.

Tip  You can also select the stream and then use the arrow keys (←↑→↓)
to make minor adjustments to the position of the stream.

Moving a Stream Corner

To move a stream corner:
1. Press and hold down the mouse button on the corner of the stream (but not on

the stream ID).

The mouse pointer changes to the move shape.

2. Drag the corner of the stream to the location you want and release the
mouse button.

Tip   You can also select the stream and then use the arrow keys (←↑→↓) to
make minor adjustments to the position of the stream.

Moving a Stream ID

You cannot move a stream ID off a stream but you can move a stream ID along a
stream. To do this:
1. Press and hold down the mouse button on the stream ID, until the mouse

pointer changes to the move shape ( ).

2. Drag the block to the location you want and release the mouse button.

Rerouting Streams

To reroute a stream automatically:
1. Click the stream you wish to reroute.

2. Click the right mouse button on the stream.

3. From the menu that appears, click Reroute Stream.
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Tip   You can also select one or more streams and then press CTRL + J to
reroute them.

Using Place and Unplace to Redraw the Flowsheet

When you want to make several changes to the layout of all or part of a
flowsheet, you might find it easier to temporarily remove (unplace) one or more
blocks and then replace them.

To do this, use Place and Unplace to redraw all or part of the flowsheet at any
time. You can place:

• All of the blocks at once and let Aspen Plus choose the layout
• Blocks one at a time to create the layout you want

Before you can redraw the flowsheet, you need to temporarily remove (or
unplace) one or more blocks:

To remove Do this

A group of blocks Select a group of blocks.
Click the right mouse button on one of the blocks and
from the menu that appears, click Unplace Blocks.

 A single block Select a block.
Click the right mouse button and
from the menu that appears, click Unplace Blocks.

The unplaced blocks appear in the Unplaced Blocks dialog box.

Tip   You can also select one or more blocks and then press CTRL + U to
unplace them.

Using Place to Place a Block on the Flowsheet

Use Place to place an individual block on the flowsheet. Do this when you want to
achieve a specific layout.

To place an unplaced block on the flowsheet yourself:
1. In the Unplaced Blocks dialog box, click and hold down the mouse button on

the ID of the block that you want to place.
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2. Drag the block to the flowsheet and drop it where you want the block located.

If you want Aspen Plus to place the next block automatically:

➤ In the Unplaced Blocks dialog box, click Place Next.

Aspen Plus selects the block that logically should appear next in the
flowsheet and places it in the appropriate position. This will not necessarily
be the block listed first in the Unplaced Blocks dialog box.

If you do not like where Aspen Plus has placed the block, move it to a
different location.

As you place blocks, the streams that connect them also appear. You can move
stream segments or corners to achieve the desired routing.

Using Place All to Place All the Blocks at Once

If the number of unplaced blocks is small or you are not concerned about the
layout of the flowsheet, you can place any unplaced blocks quickly by using Place
All to place all the blocks on your flowsheet at once.

Aspen Plus chooses the layout for you.

To place all the blocks at once:
1. Select a block or group of blocks.

2. Click the right mouse button.

3. From the popup menu that appears, click Unplace Blocks.

4. In the Unplaced Blocks dialog box, click Place All.

5. Move individual blocks and reroute streams if necessary.

About Flowsheet Sections
A flowsheet section is a group of blocks and streams within the flowsheet. Use
flowsheet sections to:

• Enhance clarity
• Simplify viewing and printing large flowsheets
• Simplify assignments of physical property specifications or stream classes

A stream belongs to a flowsheet section if it is an outlet of a block in the section.
A process feed stream belongs to a section if it is an inlet to a block in the section.
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To see which section a block or stream belongs to, select the block or stream and
a text box with the information will be displayed while the pointer is over the
selected item.

Aspen Plus predefines a default section GLOBAL for your convenience. It assigns
all blocks to GLOBAL unless you create additional sections.

Use the Properties Specifications Flowsheet Section sheet to specify physical
property options for sections.

The remaining sections of this chapter describe how to create and use flowsheet
sections.

Creating a Flowsheet Section
To create a new flowsheet section:
1. From the Flowsheet menu, click Flowsheet Sections.

2. On the Flowsheet Sections dialog box, click New.

3. Enter an ID or accept the default ID then click OK.

The new section becomes the current section. Any additional blocks you create
are assigned to this section, until you select a new current section.

Tip   You can use this button    on the Section toolbar to quickly open the
Flowsheet Sections dialog box.

Specifying the Current Section
The current section is shown by the Section box on the Section toolbar. All new
blocks defined using graphics are assigned to the current section.

To change the current section:
1. From the Flowsheet menu, click Flowsheet Section.

2. In the Flowsheet Sections dialog box, select a section from the list or click the
New button and create a new section.

3. Click the Make Current button.

4. Click OK to close the Flowsheet Sections dialog box.

The section you selected becomes the current section. Any additional blocks you
create are assigned to this section, until you select a new current section.
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Tip   You can use the current section list  on the Section toolbar
quickly specify the current section.

Using the Section Toolbar
The Section toolbar can be used to quickly change some options on the flowsheet
sections.

Specifies the
current selection

Display only the
current flowsheet
section

Opens the
Flowsheet
Sections dialog
box

Moving Blocks to a New Section
To move blocks from one section to another:
1. In the Process Flowsheet window, select one or more blocks.

2. Click the right mouse button on a selected block and from the menu that
appears, click Change Section.

3. To move the block or blocks to a different section, select the Move to section
option and select a section from the list.

– or –

To create a new section, select the Create new section option and enter a
section ID or accept the default ID.

4. Click OK to close the Change Section dialog box.

The selected block or blocks are moved to the section you selected or created.

Specifying the Stream Class for a Section
The stream class assigned to section GLOBAL is the default stream class. By
default, Aspen Plus assigns the stream class for section GLOBAL to any new
sections you create.

To assign a different stream class to a section:
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1. If the stream class you want to assign to the section does not contain the
appropriate substreams, use the Setup StreamClass form to modify it. For
more information, see Chapter 5.

2. From the Flowsheet menu, click Flowsheet Sections.

3. In the Flowsheet Sections dialog box, do one of the following:

• Select a section from the list
• Click the New button and create a new section

4. Click the Stream class button.

5. Select a stream class using the list. Click OK.

You can also use the Setup Specifications Global sheet to assign the GLOBAL
stream class.

Viewing the Current Section
To view only the current section:
1. Click the Process Flowsheet window.

2. From the View menu, click Current Section Only.

Only the blocks and streams in the current section appear on the screen. Streams
to and from other sections are terminated by icons containing the ID of the other
sections.

To specify what is the current section see Specifying the Current Section on page
4-22.

Tip   You can use the   button on the Section toolbar to quickly view only the
current Flowsheet Section.

Printing a Flowsheet
To print a flowsheet:
1. Click in the Process Flowsheet Window to make it active.

2. Click the Printer button on the Standard toolbar.

– or –

From the File menu, select Print.

3. Choose the printer and desired settings in the Print dialog box.
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4. Click OK.

Printing a Section of Flowsheet

To print a section of flowsheet:
1. From the Flowsheet menu, click Flowsheet Sections.

2. Choose the flowsheet section you want to print and click OK.

3. From the View menu, click Current Section Only.

4. Click the Printer button on the toolbar.

– or –

From the File menu, select Print.

5. Choose the printer and desired settings in the Print dialog box.

6. Click OK.

For more information on printing, see Chapter 14.

❖     ❖     ❖     ❖ 
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5 Global Information for
Calculations

This chapter explains how to specify and change all types of global information,
including:

• About global information
• Entering global specifications
• Overriding default simulation options
• Units of measure
• Report options
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About Global Information
Global specifications establish defaults for an entire run. Specify global
information before entering any engineering specifications for your Aspen Plus
run.

You can override these defaults for specific objects on other sheets. Although you
can return to these forms and change entries at any time, it is recommended that
you use them before any others when starting a new run.

Enter global specifications on the Setup forms. To access the Setup forms:
1. From the Data menu, click Setup.

2. The following table shows which form to use to enter information:

Use this form To

Specifications Enter global information

Simulation Options Specify calculations, flash convergence, and system options,
and time and errors limits

Stream Class Define stream class and stream properties

Substream Define substreams and attributes

Units Sets Define units-of-measurement sets

Report Options Specify report options

All of the global information you normally need to specify is on the Setup
Specifications Global sheet. When you create a new run, the Application Type
you choose establishes the defaults for the Global sheet. The Aspen Plus expert
system takes you to the Global sheet so you can view the defaults and change or
supplement them if you want to. For most simulations, it should not be necessary
to change the defaults on the other Setup sheets.
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Entering Global Specifications
Use the Setup Specifications form to enter global specifications, accounting
report information, diagnostic levels, and a run description for reports. The
following table shows the information you can enter on each sheet:

On this sheet of the
Specifications form

Enter this information

Global Run type, run title, run description, global defaults (units, flow basis, phase equilibrium,
calculation options, stream class)

Accounting Run accounting information (required at some installations)

Diagnostics Simulation history and Control Panel diagnostic message levels

Description User supplied description of the simulation problem

Global Sheet
Use this sheet to enter a run title, specify default input and output units of
measurement for the run, and specify global settings. The global settings include
Run Type, Input Mode, Stream Class, Flow Basis, Ambient Pressure, Valid
Phases, and Use Free Water Calculation.

You can override global specifications for individual unit operations blocks using
the Block Options form for each block.

Changing the Run Type

You specify a Run Type when you create a new run. You can change this run type
at any time.See Chapter 2 for a description of the available run types.

To change the run type:
1. On the Data menu, select Setup.

2. Click the Global sheet.

3. In the Run-Type box, select a run type.

Because each run type has different input requirements, changing the run type
may cause the input for the run to become incomplete. Use Next to guide you
through the required forms.

You can change the run type even after you have entered specifications for a
different run type. Aspen Plus hides forms that the new run type does not allow.
But if you switch back to the original run type, data entered on these hidden
forms are not lost.
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Examples of when you might want to change the run type are:

• You used a Property Estimation run to estimate and examine properties for a
non-databank component. Now you want to run a flowsheet simulation using
that component. If you change the run type to Flowsheet, Aspen Plus retains
the component information and prompts you for the flowsheet information.

• You used a Property Estimation run to estimate and examine properties for a
non-databank component. Now you want to run property analysis or property
data regression involving that component. If you change the run type to
Property Analysis or Data Regression, Aspen Plus retains the component
information, and prompts you for additional information to complete your run
specifications.

Specifying the Run Title

To specify the run title:
1. From the Data menu, click Setup.

2. Select the Global sheet.

3. In the Title box, specify a brief run title.

You can supply additional descriptive information about the run on the Setup
Specification Description sheet, and on the Comment forms available from any
input sheet.

Specifying Global Units Sets

You can specify separate global input and output units sets. For more
information about how to customize an existing unit set, see Units of Measure on
page 5 - 16.

This global units set Becomes the default for all

Input Data Input sheets in the run

Output Results Results sheets

To specify global units sets:
1. From the Data menu, click Setup.

2. Select the Global sheet.

3. Specify the global units sets in the Input data and Output results boxes.

You can change the global units set specifications at any time. When you change
the Input Data set, all new input forms you display default to the new units set.
Aspen Plus does not change the units on forms you have already completed.
When you change the Output Results units set, all results sheets default to the
new units set after you complete a run.
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Selecting a Default Stream Class

Stream classes define structures for simulation streams when solid substreams
are present. When you create a new run, Aspen Plus chooses a default stream
class based on the application type. You can change the default stream class on
the Setup Specifications Global sheet.

To change the default stream class:
1. From the Data menu, click Setup.

2. Select the Global sheet.

3. In the Stream Class box, select a stream class.

All streams in the simulation are assigned to the default stream class, unless you
assign a stream class to one of the following:

• A flowsheet section
• An individual stream, on the Stream-Class Streams sheet

For more information on using and creating stream classes, see Chapter 9.

Selecting the Simulation Flow Basis

You can enter specifications for most flows on a molar, mass, or standard liquid
volume basis. For example, you can enter total stream flow rate on any of these
bases.

To select the global basis for flow-related information:
1. On the Data menu, select Setup.

2. Select the Global sheet.

3. In the Flow-Basis box, specify Mass, Mole, or StdVol.

The basis you select becomes the default basis for the run. You can override the
basis locally on most forms.

You can return to the Setup Specifications Global sheet and change the default
basis at any time. The basis for previously entered values does not change.

Specifying Ambient Pressure for Gauge Pressure Units

Aspen Plus accepts gauge pressure units for all pressure variables. The default
value for the ambient pressure is 1 atm.

To change the ambient pressure:
1. From the Data menu, click Setup.

2. Select the Global sheet.
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3. In the Ambient Pressure box, type a pressure. Change the units if necessary.

Specifying Valid Phases

Aspen Plus performs phase equilibrium calculations throughout a simulation run
for blocks, streams, and other objects. You can specify the valid phases to be used
in these calculations. Choose from Vapor-Only, Liquid-Only, Vapor-Liquid, and
Vapor-Liquid-Liquid.

To change the valid phases:
1. From the Data menu, click Setup.

2. Select the Global sheet.

3. In the Valid phases box, select either Vapor-Only, Liquid-Only, Vapor-Liquid,
or Vapor-Liquid-Liquid.

You can override the global setting locally, at the individual block or stream
level, using the Valid Phases box.

Requesting Free Water Calculations

Aspen Plus can handle the presence and decanting of water as a second liquid
phase in water-hydrocarbon systems. Free-water calculations:

• Assume the water phase is pure
• Use special methods for calculating the solubility of water in the organic

phase

To request free-water calculations globally:
1. From the Data menu, click Setup.

2. Select the Global sheet.

3. Select the Use Free Water Calculations check box.

You can override the global setting locally, at the individual block or stream
level, using the Valid Phases box to select Vapor-Liquid-Free Water.
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Description Sheet
Use this sheet to enter the description for the simulation. The description you
enter on this sheet will be printed once, at the beginning of the report. You can
enter any amount of text in uppercase and lowercase letters to document your
run in more detail. You can use any number of lines to enter text. However, you
cannot exceed the maximum length of each line (72 characters): the excess will be
truncated.

Specifying a Run Description

To specify a run description:
1. From the Data menu, click Setup.

2. Select the Description sheet on the Setup Specifications form.

3. Enter a description in the Description box.

Tip   You can write a description in your text editor (for example, Notepad), and
then copy and paste them onto the Description sheet.

Accounting Sheet
Use this sheet to enter run accounting information (required at some
installations). The accounting information includes: a user name, an account
number, a project ID, and a project name. This information is stored for the run
by the Aspen Plus Run Accounting System, if it is active for your installation.

Accounting Report Information

Accounting report information tracks the use of Aspen Plus at your installation.
This information may be required at some installations.

To specify run accounting information:
1. From the Data menu, click Setup.

2. Select the Accounting sheet on the Setup Specifications form.

3. In the User Name box, specify a username.

4. In the Account Number box, specify an account number.

5. In the Project ID box, specify a project ID.

6. In the Project Name box, specify a project name.
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The Aspen Plus Run Accounting System logs this information for the run, if it is
active for your installation.

Diagnostic Sheet
Aspen Plus writes progress and diagnostic messages to the Control Panel and the
History File during a run. The default for all types of messages is level 4. You can
control the amount of diagnostic information produced, although it is generally
not necessary. It is sometimes necessary to increase the level in order to converge
a flowsheet or to debug user Fortran.

Use this sheet to override defaults for simulation history diagnostic message
levels and Control Panel message levels printed. You can set message levels and
diagnostics for input translation, simulation, physical properties, stream,
convergence, Fortran variables, cost and economics.

Specifying Global Defaults for Diagnostic Information

To specify global defaults for diagnostic information:
1. From the Data menu, click Setup.

2. Click the Diagnostics sheet.

3. Use the slider controls to adjust the message levels you want to change. The
slider on the top of each line is for the Control Panel messages, and the slider
on the bottom is for the History File messages.

4. Click the History Options button to change the print options for the History
file. Check Insert files used in the simulation or Sorted input if this
information is desired in the History file.

Tip  You can override the global defaults locally, using the Block Options sheets
for streams, blocks, property tables, and other objects that perform calculations.

Setup Simulation Options
Use the Setup Simulation Options form to override defaults for simulation
options set by Aspen Plus. Aspen Plus provides defaults for performing energy
balances and convergence calculations. Aspen Plus also has default time limits.
You can use this form to override these defaults. You also can specify simulation
options at the individual block level.
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This table shows which sheets are used for which information:

Sheet Information

Calculations Options for Heat and mass balances, molecular weight from formula,
reinitialize calculations, bypass Prop-Set calculations, reaction stoichiometry checking

Flash Convergence Global temperature and pressure limits, maximum iterations, flash tolerance,
extrapolation threshold for equations of state

System Interpret or compile Fortran, unit operation model and Fortran error checking

Limits Simulation time and error limits

Calculations Sheet
Use this sheet to specify calculation options for:

• Checking mass balances around blocks
• Performing mass-balance-only calculations
• Calculating component molecular weight from atomic formula
• Using results from a previous convergence pass
• Bypassing prop-set calculations if flash fails

You can also use this sheet to specify reactions stoichiometry error checking
options.

Checking Mass Balances Around Blocks

Aspen Plus performs a mass balance check around each block as it is executed
and at the end of the simulation. Mass balance checking is performed with a
relative tolerance of 0.0001.

Imbalances can occur for numerous reasons — for instance, improper
stoichiometry or yield fraction specifications, loose convergence tolerances,
inconsistent user kinetic rates, or flows changed by Fortran, Transfer, or Balance
blocks. Mass balance checking will point out these imbalances and in many cases
provide the reason for the imbalance.

You can turn off this checking to lower the number of error or warning messages
generated during a simulation. To disable mass balance checking around blocks:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Simulation Options
form.

3. Click to clear the Check Mass Balance Error Around Blocks check box.
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About Mass-Balance-Only Simulations

Mass-balance-only simulations:

• Are appropriate when energy balances are not required
• Do not calculate enthalpies, entropies, or free energies, thus reducing

calculation time
• Reduce data input requirements for physical property parameters

Mass-balance-only simulations do not require:

• CPIG, DHFORM, and DGFORM parameters
• Parameters for models that calculate only enthalpy, entropy, or free energy

To request a mass-balance-only simulation:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Simulation Options
form.

3. Click to clear the Perform Heat Balance Calculations check box.

In a mass-balance-only run, you can use these unit operation models without
restriction:

CFuge HyCyc

Crusher Mixer

Cyclone Mult

Dupl Screen

ESP Sep

FabFl Sep2

Filter SSplit

FSplit VScrub

You can use these models only if you do not specify heat duty:

CCD RBatch

Decanter RCSTR

Distl RPlug

DSTWU RSstoic

Flash2 RYield

Flash3 SWash

Heater
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You cannot use these models in a mass-balance-only run:

BatchFrac PetroFrac

Compr Pipeline

Crystallizer Pump

Extract RadFrac

HeatX RateFrac

MCompr REquil

MHeatX RGibbs

MultiFrac SCFrac

Heat and work streams are not allowed in a mass-balance-only simulation.

Calculating Molecular Weight from Formula

The molecular weight is available in Aspen Plus databanks (parameter MW).
However, the databank molecular weight value may not contain enough
significant figures for certain applications for which atomic balance is important,
such as reactor modeling.

Aspen Plus calculates the molecular weight for all components in the simulation
from the molecular formula (parameters ATOMNO and NOATOM) and the
atomic weight. The calculated molecular weight is more accurate than the
databank molecular weight. By default, the calculated molecular weight is used
in the simulation.

To request to calculate from the formula in a simulation:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Simulation Options
form.

3. Click the Calculate Component Molecular Weight from Atomic Formula check
box.

Reinitializing Calculations

By default, iterative calculations in Aspen Plus use any available previous
results as an initial guess. If necessary, you can override this default and request
that all calculations be reinitialized each calculation pass.

Request reinitialization when:

• A block has multiple solutions and you can obtain the one you want only by
starting from your own initial estimate.

• A block or flowsheet fails to converge for no apparent reason, after one or
more successful passes.
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To request reinitialization globally:
1. From the Data menu, click Setup.

If the Use Results from Previous
Convergence Pass check box is

Then Aspen Plus

Selected Uses results from a previous calculation pass as the initial guess for the new pass

Clear Performs initialization or uses initial estimates at every new calculation pass

You can override the global setting:

• At the block level, on the Block Options sheet for the block
• Interactively, using the Reinitialize commands from the Run menu
• If the reinitialization option for a block is clear when you request

reinitialization interactively, reinitialization occurs only on the next
calculation pass.

Bypassing Prop-Set Calculations When Flash Fails
1. By default, Aspen Plus will not calculate the property sets if a flash error

occurs. In the left pane of the Data Browser window, select the Simulation
Options form.

2. On the Calculations sheet, click to clear the Use Results from Previous
Convergence Pass check box.

If the property sets are calculated when severe flash errors occurs, the property
set calculations may be unreliable, and may cause further errors.

To request to calculate the prop-set calculations even when the flash fails:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Simulation Options
form.

3. On the Calculations sheet, clear the Bypass Prop-Set Calculations if Flash
Failure Occurs checkbox.

Checking Reaction Stoichiometry

If reactions stoichiometry (such as Reactors, Chemistry, Reaction) is specified,
Aspen Plus checks the mass-balance of stoichiometry based on the stoichiometric
coefficient and molecular weight of the components.

You can use the option button to select whether Aspen Plus gives an error or a
warning during Input translation if mass imbalance occurs. Simulation will not
proceed if an error occurs during Input translation.
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You can also use the Mass Balance Error Tolerance box to specify the absolute
tolerance of the mass balance check of stoichiometry. The default value of the
tolerance is 1 kg/kgmole.

The error severity depends on the Mass Balance Error Tolerance and what
checking option you specify:

Checking Option Absolute Error Error Severity

Issue Error When Mass Imbalance
Occurs

> Tolerance Error

Issue Error When Mass Imbalance
Occurs

< Tolerance and  > 0.01 Warning

Issue Warning When Mass Imbalance
Occurs

> Tolerance Warning

To request a warning rather than an error to be issued when a mass imbalance
occurs:
1. On the Data menu, click Setup.

2. In the left pane of the Data Browser window, click the Simulation Options
form.

3. On the Calculations sheet, select the Issue Warning when Mass Imbalance
Occurs check box.

4. The tolerance can be changed by typing a new tolerance in the Mass Balance
Error Tolerance box.

Flash Convergence Sheet
Use the Flash Convergence sheet to specify calculation options for setting:

• Upper and lower limits of temperature for flash calculations
• Upper and lower limits of pressure for flash calculations
• Flash options for flash calculations
• Extrapolation threshold for equations of state

Specifying Temperature and Pressure Limits

To specify upper and lower limits on the temperature and pressure variables
used in iterative flash and distillation calculations:
1. From the Data menu, click Setup.
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2. In the left pane of the Data Browser window, select the Simulation Options
form.

3. Select the Flash Convergence sheet on the Simulation Options form.

4. Use the Lower Limit and Upper Limit boxes to specify upper and lower limits
for temperature and pressure.

These limits apply to the entire simulation. You cannot override them locally.

Specifying Global Flash Options

Aspen Plus performs phase equilibrium (flash) calculations throughout a
simulation run, for blocks, streams, and other objects. You can specify global
values for the maximum number of iterations and the convergence tolerance to
be used in these calculations.

The flash tolerance may need to be tightened (lowered) in complex simulations
with a number of recycle loops in order to help the convergence. For more
information on convergence, see Chapter 18.

To specify global flash options:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Simulation Options
form.

3. Select the Flash Convergence sheet.

4. In the Maximum Number of Iterations box, specify the default for the
maximum number of flash iterations.

5. In the Tolerance box, specify the default flash tolerance.

You can override the maximum number of flash iterations and flash tolerance on
forms for blocks, streams, and other calculations.

Specifying Extrapolation Threshold for Equations of
State

All equations of state in Aspen Plus use a root finder to calculate the molar
volume iteratively at given temperature, pressure and mole fractions. Given
physically meaningful conditions, the real molar volume root can always be
located by the root finder. However, during iterative calculations in flash or a
distillation model, the temperature, pressure, compositions and phase
specification may be such that a real molar volume root does not exist.
Aspen Plus provides an estimate of the molar volume that is reasonable, allowing
the flash or distillation algorithm to converge to a physically meaningful solution.
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If you encounter convergence problems due to extrapolation of an equation of
state root finder, you can improve performance by changing the extrapolation
threshold. A smaller value of the threshold makes it less likely for the
extrapolation to occur.

To specify the extrapolation threshold for equations of state:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Simulation Options
form.

3. Select the Flash Convergence sheet.

4. In the Extrapolation Threshold for Equation of State box, specify a value for
the extrapolation threshold.

This limit applies to the entire simulation. You cannot override it locally.

System Sheet
Use this sheet to override the defaults for system options that affect error
checking and handling of in-line Fortran statements:

You can override these defaults:

• Interpret all in-line Fortran statements at execution time
• Compile all Fortran statements into the Aspen Plus main program
• Check unit operation block for errors and inconsistencies
• Print Fortran tracebacks when a Fortran error occurs

Limits Sheet
Use this sheet to specify limits for:

• Maximum CPU time for a batch run
• Maximum number of severe errors for a batch run
• Maximum number of Fortran errors for a batch run
• Maximum number of errors and warnings printed in the History file
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Units of Measure

Use the Units Sets form to create new user-defined units sets and to view existing
units sets. A units set is a collection of units for each dimensional quantity in
Aspen Plus.

A units set defined using this form can be specified in the Input Data or Output
Results boxes on the Setup Specifications Global Sheet or on the Units box on the
toolbar of the Data Browser.

Sheet Information

Standard List and select an existing units set as a base for a new units set;
search for all the dimensional quantities alphabetically;
specify flow, temperature, and pressure-related units

Heat Specify enthalpy, heat, heat capacity, and entropy-related units

Transport Specify volume, density, transport-related and miscellaneous thermo units

Concentration Specify energy/power, time, concentration, and composition-related units

Size Specify size, equipment sizing, cost, and column sizing-related units

Miscellaneous Specify miscellaneous units

Selecting Units of Measure
A units set is a collection of units specifications for each dimensional quantity
used in Aspen Plus. Aspen Plus provides these basic units sets:

• International system units (SI)
• English engineering units (ENG)
• Metric engineering units (MET)

Additional built-in units sets are available, depending on which Application Type
you choose when you create a new run.
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In Aspen Plus you have complete flexibility in specifying units of measure. You
can specify units on three different levels:

Level For For input sheets For results sheet

Global units sets Entire run Yes Yes

Sheet units set Individual form or object Yes Yes

Field units Individual fields or a group
of fields

Yes Yes

Viewing Units Specifications

To see what units are specified by a units set:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Units Sets folder.

3. In the Units Sets object manager, select the units set you want to view and
click Edit.

The unit types used by Aspen Plus appear on six sheets: Standard, Heat,
Transport, Concentration, Size, and Miscellaneous.

4. Select a sheet and view the units specifications.

You can create your own units sets on the Setup Units Set sheets. The following
sections describe how to specify units for each level, andhow to define your own
units set.

Specifying Units Sets for Forms or Objects

You can override the global units sets for individual forms and objects, such as
for a block, stream, or property table. To do this:

➤ On the Data Browser toolbar, use the Units box to select a units set.

A units set specification applies to all forms for an object.

For example, if you specify a units set on the Data Browser toolbar while the
RadFrac Setup Streams sheet is active, the new units set applies to all input
forms for the block. For each object, you specify units sets separately for input
forms and results forms.
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Specifying Units Sets for Fields

You can specify units for individual fields and groups of fields on an input form.
Selects units in the units fields next to the data fields.

Changing the units for an individual data field does not convert any value
entered previously. Aspen Plus assumes you entered the numeric value you
intend to use and that you will specify appropriate units for the value.

Defining Your Own Units Set

To define your own units set:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser, select the Units Sets form.

3. On the Units-Sets Object Manager, click New.

4. In the Create dialog box, enter an ID or accept the default ID for the units set
and click OK.

The unit types you can specify are on six sheets: Standard, Heat, Transport,
Concentration, Size, and Miscellaneous.

5. On the Standard sheet, use the drop down arrow in the Copy From/View box
to select an existing units set as the starting point for your new units set.
Choose the units set that is closest to the new set you are creating.

Aspen Plus fills in the units for each units type and a dialog box appears.

6. Click Yes or No.

7. If you select Yes, the global units of measurement for both Input data and
Output results are changed to the new units set.

8. Click the appropriate sheet and go to the units type you want to modify. Use
the drop down arrow to select the units option you want.

9. Repeat Step 6 for all units types you want to modify.

Tip  To see all of the units types arranged alphabetically click the Search button.
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Example of Defining a New Units Set
1. Create a new units set, US-1, that is identical to the ENG units set, except

US-1 uses units of ATM for pressure and C for temperature.

2. From the Data menu, click Setup.

3. In the left pane of the Data Browser, click the Units Sets form.

4. In the Units-Sets Object Manager that appears, click the New button.

5. Accept the default ID in the Create New ID dialog box (US-1).

6. Click OK. The Units-Sets Form appears with the Standard sheet displayed.

7. Aspen Plus asks if you want to make your new units set the global default for
subsequent specifications. After you have defined the new units set, you can
specify US-1 in the Units box in the Data Browser toolbar.

8. On the Copy From box, use the drop down arrow and select ENG as the set to
copy from. The ENG units set values appear in the units box.
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9. On the Temperature box, use the drop down arrow and select C as the
temperature.

10. On the Pressure box, use the drop down arrow and select atm as the pressure.

Report Options
Use the Setup Report Options form to customize the simulation report. See
Chapter 12, for more information on generating and accessing the reports.

Click one of the following for help on customizing the stream report:

• Options for customizing the stream report
• Specifying stream results format
• Including streams
• Designating property sets
• Using the Batch Operation button
• About Batch stream reports
• About Supplementary stream reports

The following table shows what you can specify and where it is located:

On this sheet Specify

Stream What stream information is included and in what format. You can use the Standard form to tailor the Stream-
Summary report.

Use the Batch Operation button to select options for batch streams

Items that can be included in the stream report are any combination of Mole, Mass, or Standard Liquid Volume flow
or fraction, any number of property sets, component attributes, substream attributes, particle size distribution size
limits and stream structure information.

Streams can be listed alphanumerically or in the order that they are listed on the flowsheet form.

These options are only available when the Stream option is checked on the General sheet.

Property The property information to be included

Items that can be included are List of component IDs, formulas and names, the values in SI units of all physical
property parameters used in the simulation, property constant estimation results, and the values of all physical
property parameters along with the property parameters’ descriptions, equations and sources of data.

Additional property files [DMS format input file (*.DFM), Project data file (*.PRJ), and/or Property data format file
(*.PRD)]  can also be generated automatically when you export a report file.

All of these options are only available when the Property option is checked on the General sheet.

ADA What assay data analysis information is included

Items that can be included are the list of generated pseudocomponents, a distillation curve report, and the values of
all pseudocomponent property parameters in SI units.

All of these options are only available when the ADA option is checked on the General sheet.
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Customizing the Stream Report
You can customize the stream format using these options:

Stream Report Options Description

Flow basis Display flow rate of each component in each streams in the basis
specified. Any combination of Mole, Mass, or Standard Liquid
Volume can be chosen.

Fraction basis Display fraction of each components in each streams in the basis
specified. Any combination of Mole, Mass, or Standard Liquid
Volume can be chosen.

TFF Table Format File used to specify the order and format of values
printed in the stream report. For more information, see Specifying
Stream Results Format on page 5-21.

Report width Print five streams (80 column) or ten streams (132 column) across a
page. Applies only to Report file.

Sort stream alphanumerically Streams sorted alphanumerically. Applies only to Report file.

Include components with zero flow
or fraction

Include components in the stream report, even if they have zero
flow or fraction.
If this option is not selected, components with zero flow or fraction
are not printed for that stream

Include Streams Specify which streams are printed in the report and order the
streams. Applies to the Report file and does not apply to the Stream Results
Summary.

Property Sets Specify property sets for additional properties to be calculated and
printed for all of the streams.

Component Attributes Component attributes, particle size distribution values, particle size
distribution size limits and stream structure information can be
printed for all of the streams. Applies to the Report file and does not apply
to the Stream Results Summary.

Batch Operations Designated streams can be reported on a batch basis. For more
information, see Specifying Batch Streams on page 5-23.

Supplementary stream Specify additional (supplementary) stream reports.  A
supplementary report can have different options from the standard
report.  A supplementary stream report can be generated even if
you suppress the standard stream report. Applies to the Report file and
does not apply to the Stream Results Summary.

Specifying Stream Results Format

The table format file (TFF) determines the format (order, labels, precision, and
other options) of the stream results shown on the Stream Summary sheet.
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Aspen Plus provides built-in TFFs tailored to each Application Type, and chooses
an appropriate TFF for the Application Type you choose when you create a new
run. You can also create your own TFFs. For more information on this, see
Chapter 36.

You can specify the TFF in either of these places:

• Format box of the Results Summary Streams Material sheet
• Stream Format box on Setup ReportOptions Stream sheet

Aspen Plus uses the TFF you select in either box for all Results Summary
Streams Material sheets you display, until you select another TFF.

It is not necessary to re-run the simulation in order to see the results in another
format.

Including Streams

By default, all of the streams are included in the report.

To customize the list of streams to be included in the report:
1. Click the Include Streams button Setup ReportOptions Stream sheet.

2. The right arrow button can be used to move streams from the Available
streams list to the Selected streams list to be included in the report. The left
arrow button is used to remove streams from the Selected streams list. The
double arrows are used to move all of the streams in a list at once.

Designating Property Sets

In addition, you may designate property set IDs for additional stream properties
to be included in the report.

To customize the list of property sets to be included in the report:
1. Click the Property Sets button on the Setup ReportOptions Stream sheet.

2. The right arrow button can be used to move Property Sets from the Available
property sets list to the Selected property sets list to be included in the
report. The left arrow button is used to remove property sets from the
Selected property sets list. The double arrows are used to move all of the
property sets in a list at once.

Component Attributes

Use the Component Attribute button to select options for component attributes.
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Any combination of the following can be printed for all of the streams:

• Component attributes
• Substream attributes
• Particle size distribution (PSD) values
• Particle size distribution size limits
• Stream structure information

Specifying Batch Streams

Use the Batch Operation button to select options for batch streams. The Batch-
Operation form is used to designate streams as batch streams and to specify:

• Cycle times
• Down times
• Operation times
• Number of parallel trains for these streams

You can specify just cycle time or any two of the three times.

An Aspen Plus simulation computes the average flow of all streams, assuming
continuous steady-state flows. You can designate any type of stream (material,
heat, or work) as a batch stream, to report it on a batch basis. Batch stream
reporting is used to represent:

• Batch charges
• Batch discharges
• Semi-continuous streams (streams that operate for only a portion of a

complete batch cycle)

Each batch stream can have different time specifications, such as cycle time or
down time.

All batch stream results appear in the standard stream report of the Aspen Plus
report file. The following information is reported:

• Cycle time
• Operation time
• Number of trains
• All material and energy flows in three ways:

• Average flow rate over entire cycle for all trains
• Total amount of material and energy per cycle per parallel production

train (average flow rate * cycle time / number of trains)
• Flow rate per train during actual operation

[ amount / cycle / train / operation time ]
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The Stream Results Summary sheet displays all batch stream results if you
select the FULL Table Format File (TFF) on the Format box. If you select
PHARM-E, PHARM-M, SPEC-E, or SPEC-M in the Format box, Aspen Plus
excludes the operating time, number of trains, and flowrate during actual
operation from the stream summary. If you select any other built-in TFF, the
stream summary form displays average flow rate of material and energy only. It
does not display batch stream results.

To designate a stream as a batch stream:
1. Click the Batch Operation button on the Setup ReportOptions Streams sheet.

2. In the stream box, select a stream ID from the list.

3. You can specify cycle time only, or two of the following times:

• Cycle time
• Down time
• Operation time (Zero indicates an instantaneous charge or discharge.)

4. You can also specify the number of parallel trains. The default is one.

About Supplementary Stream Reports

A supplementary stream report can be generated in the Report file. This
selection only applies to the Report file and does not affect to the Stream Results
Summary in the graphical user interface.

You can print the standard stream report whether a supplementary stream
report is to be generated or not. A supplementary stream report can be generated
even if you suppress the standard stream report.

The options available for the Standard stream report are also available for the
Supplementary stream report. In addition, a subroutine can be used to generate
a user stream report. The subroutine is specified by clicking on the Subroutine
button.

❖     ❖     ❖     ❖ 
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6 Specifying Components

This chapter explains how to define the components in your simulation and includes
information on:

• Forms for specifying component information
• Specifying databank and non-databank components
• Adding, deleting, and changing components
• Generating electrolyte components and reactions
• Identifying solid components
• Assigning attributes for conventional and nonconventional components
• Specifying supercritical (HENRY) components
• Specifying UNIFAC groups
• Defining component groups

Use these forms to specify component information:

Form Sheet What is Specified

Specifications Selection
Petroleum
Nonconventional
Databanks

All components used in a simulation
Assays, blends, and pseudocomponents
Nonconventional components
Pure component databanks to search for property parameters

Assay/Blend
Petro
characterization

 - Assays and blends. For more details, see Chapter 32.
Pseudo component characterization. For more details, see Chapter
32.

Pseudocomponents Pseudocomponents data. For more details, see Chapter 32.

Attr-Comps Selection Component attributes assigned to conventional components

Henry Components Selection Sets of supercritical components for which Henry’s law is used in
activity coefficient property methods

UNIFAC Groups Selection UNIFAC functional groups

Comp-Group  - Groups of components considered as a unit for tear stream
convergence
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About Databanks

Aspen Plus stores physical property parameters for a large number of components
in several databanks. In addition to the standard Aspen Plus databanks, in-house
databanks may be available at your site.

To see the available pure component databanks, and to see or change which
databanks are active for a simulation:
1. From the Data menu, click Components.

2. On the Specifications form, click the Databanks sheet.

3. Aspen Plus searches the databanks in the order listed in the Selected
Databanks list on this sheet. The default order is appropriate for most
simulations.

To change the search order for databanks in this simulation, click a databank
in the Selected Databanks list, and then click the up and down arrow keys to
move the databank higher or lower in the list.

Click here for information about changing search order globally.

4. You can choose additional databanks from the Available Databanks list and
add them to the Selected Databanks list using the right arrow button.

To remove a databank from the search, in the Selected Databanks list, click a
databank then click the left arrow button to move it to the Available
Databanks list.

This table shows the contents and use of the pure component databanks included
with Aspen Plus:

Databank Contents Use

PURE10 Pure component parameters for
mostly organic components

Primary component databank in Aspen Plus

AQUEOUS Pure component parameters for
ionic and molecular species in
aqueous solution

Simulations containing electrolytes

SOLIDS Pure component parameters for
strong electrolytes, salts, and other
solids

Simulations containing electrolytes and solids

INORGANIC Pure component parameters for
inorganic and organic components

Solids, electrolytes, and metallurgy applications

Continued
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Databank Contents Use

PURE856 Version of main pure component
databank delivered with
Aspen Plus Release 8.5-6

For upward compatibility with previous releases
of Aspen Plus

PURE93 Version of main pure component
databank delivered with
Aspen Plus Release 9.3

For upward compatibility with previous releases
of Aspen Plus

AQU92 Version of AQUEOUS delivered
with Aspen Plus Release 9.2

For upward compatibility with previous releases
of Aspen Plus

ASPENPCD Version of main pure components
databank delivered with
Aspen Plus Release 8.5-6

For upward compatibility with previous releases
of Aspen Plus.

COMBUST Pure component parameters for
combustion products, including
free radicals

For high temperature, gas phase calculations

For information on customizing the default order of the databanks, see Chapter
16.

Specifying Components from a Databank

You must:

• Ensure your simulation contains at least one component.
• Provide Aspen Plus with a list of all the components in the simulation
• Assign a component ID to each component. This ID will refer to the

component on all subsequent input forms, results forms, and reports.

To specify the components:
1. From the Data menu, click Components.

2. In the Component ID box of the Selection sheet, type an ID for the component
you want to add. Every component must have a Component ID.
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Exact match found in databank? Then Aspen Plus

Yes Fills in the Formula and Component name. Omit the remaining steps.

If you choose not to retrieve data, delete the formula or component name with the
backspace key.

No Requires you to enter the formula or component name, if you want to retrieve data
from the databank.

To specify the Formula or Component Name yourself, go to Step 3.

To use Find, click the Find button and go to Step 4.

3. This table shows what happens:

If you enter a And an exact match is Then Aspen Plus

Formula Found Fills in the Component Name. You need to specify the Component ID
if it has not already been done. Omit the remaining steps.

Formula Not found Displays the Find dialog box with any partial match results displayed.
See Step 4 for using the Find dialog box. Omit the remaining steps.

Component name Found Fills in the Formula. You need to specify the Component ID if it has not
already been done.

Component name Not found Displays the Find dialog box with any partial match results displayed.
See Step 4 for using the Find dialog box.

4. Use the Find dialog box to enter search criteria for your component.

On the Name or Formula sheet, you can search for strings contained in the
name or formula of a component. Using the Advanced sheet, any combination
of these items can be entered and used to search for a component:

If you enter a Then Aspen Plus searches for

Component name or formula Any components that include the string in any part of the component name or
formula

Match only components beginning
with this string

Any components that include the string in the beginning of the component name
or formula

Component class A component that is in the component class category

Molecular weight Components in that molecular weight range

Boiling Point Components in that boiling point range

CAS number Component with that Chemical Abstracts Service registry number

5. Click the Find Now button to display all of the components with your find
criteria. Then, select a component from the list and click Add to add it to the
components list. Click here to see an example of using Find.

6. When you finish searching for components, click Close to return to the
Selection sheet.



Aspen Plus User Guide 6-5
Version 10.1-0

Chapter 6

You can return to the Components Specifications Selection sheet at any time
while building your simulation, to add or delete components.

If you enter a Then Aspen Plus searches for

Component name or formula Any components that include the string in any part of the component name or
formula.

Match only components beginning
with this string

Any components that include the string in the beginning of the component name
or formula.

Component class A component that is in the component class category.

Molecular weight Components in that molecular weight range.

Boiling Point Components in that boiling point range.

CAS number Components with that Chemical Abstracts Service registry number.

Example of Specifying Components

In this example, the Formula and Component Name for component CH4 are
automatically retrieved from the databanks. Data for components CH4 and
C4H10 is retrieved from the databanks. Component C3 is a non-databank
component.

Example of Using the Find Dialog Box
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In this example, the advanced component Find dialog box is used to locate a
component that includes C3 in its formula and has a boiling point between 200
and 250 K.

To do this:
1. On the Components Specifications Selection sheet, select an empty

component ID field, then click Find.

2. In the Component Name or Formula box, enter C3.

3. Select the Advanced sheet where you can also search for components based on
the chemical class, molecular weight range, boiling point range and CAS
number.

4. In the Boiling Point boxes, enter from 200 to 250 K.

5. Click Find Now.

Aspen Plus searches its databanks for components that contain the
characters C3 in the name or formula and have a Boiling point between 200
and 250 K and then displays the results in the bottom half of the window.

6. To include a component from the search results in your simulation, select a
component name from the list, and click Add. From the Find dialog box, you
can continue to select component names and click the Add button to select
multiple components from the search results to be added to your simulation.
You can also modify your search criteria and click Find Now again to
generate new search results.

7. When finished, click Close to return to the Components Specifications
Selection sheet.

Click here to see the Find dialog box for this example.
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Specifying Non-Databank Components

To define a component that is not in the databanks:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, enter only the Component ID.

3. If Aspen Plus finds a match in a databank for the ID you enter, delete the
Formula or Component Name. Aspen Plus then recognizes the component as
a non-databank component.

4. You must supply all required property parameters for non-databank
components. You can supply the parameters yourself using the Properties
Data and Parameters forms.
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– or –

Combine user-input parameters and data with one or both of the following:

• Property Estimation to estimate the required parameters using the
Properties Estimation forms

• Data Regression to regress data to obtain the parameters using the
Properties Regression forms

For information on See

Physical property data requirements Chapter 8

Estimating property parameters Chapter 30

Regressing property parameters Chapter 31

Tip   Use the User Defined Component Wizard to help you enter some of the
commonly available data, such as normal boiling point and vapor pressure data.

Using the User Defined Component Wizard
You can use the User Defined Component Wizard to define the properties needed
for conventional, solid, and nonconventional components. You can modify the
parameters supplied at any time by returning to the User Defined Component
Wizard or by going to the forms where the information is saved.

Use this wizard to define components that are not in any pure component
databanks. You can define conventional components, solid components, and
nonconventional components. The wizard also helps you enter commonly
available data for the components, such as molecular weight, normal boiling
point, vapor pressure and heat capacity data.

Tip   You can also select a databank on the Components Specifications Selection
sheet and give it a different chemical formula. This special formula can be used
to identify the component in user-written subroutines. This allows property
parameters for the component to be retrieved from the databanks.

To open the User Defined Component Wizard:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, click the User Defined button.

The User Defined Component Wizard appears.
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Tip   For help on the wizard, click the What’s This button in the right hand
corner of the wizard dialog box, then click any part of the wizard.

Defining a Conventional Component

To define a conventional component, open the user defined component wizard
then:
1. Enter the Component ID. Every component in the flowsheet must have a

Component ID. This ID is used to refer to the component throughout the
simulation.

2. From the Type list, click Conventional.

3. Optionally, enter a formula for the component. The formula can identify the
component in user-written property or unit operation model subroutines. If
the formula for the component exists in an Aspen Plus databank, a warning
message appears.

4. Click Next.

5. Enter the molecular weight and normal boiling point in the respective boxes
on the Conventional Components Basic Data dialog box.

The molecular structure, molecular weight, and normal boiling point are the
most fundamental information required in group-contribution and
corresponding-states methods used in property estimation.
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Molecular weight is required in all simulations. If the Molecular structure is
later entered, the molecular weight used in the simulation can be calculated
from the atoms.

Normal boiling point is not required per se in property calculations, but is
used to estimate many other parameters such as critical temperature and
critical pressure, if they are missing.

6. Optionally enter the data shown in  the following table. This data can be
found later on the Properties Parameters Pure Component USRDEF-1 form.

Physical Property Information

Specific gravity at 60°F (SG)

Standard enthalpy of formation (DHFORM) Most simulations involve energy balance calculations therefore
enthalpy is required.

Standard enthalpy of formation of ideal gas at 25°C (DHFORM) is used
in the enthalpy calculation, but is not required unless the simulation
contains chemical reactions, because DHFORM defaults to zero.

Standard Gibbs energy of formation
(DGFORM)

Enter the standard Gibbs energy of formation of ideal gas at 25°C
(DGFORM) if either:

• The simulation contains chemical reactions.

• You use the RGibbs unit operation model.

7. If you wish to enter additional property information, such as molecular
structure, vapor pressure or ideal gas heat capacity data, click Next. The
wizard will help you enter property data, property parameters, and molecular
structure or activate property estimation.

8. If you clicked Next to enter additional property data, this dialog box appears:
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9. Click the buttons to enter additional properties or data.

This table provides information about the properties or data:

Type Description

Molecular structure Component Molecular Structure

Molecular structure is required in all group-contribution methods used to estimate
missing property parameters.

If you enter molecular structure, you should also request estimation of parameters
by selecting the Estimate All Missing Parameters From Molecular Structure check
box.

The structure can be modified later if needed, on the Properties Molecular
Structure form. For details on entering molecular structure or Property Estimation,
see Chapter 30.

Vapor pressure data Vapor pressure data used to determine extended Antoine vapor pressure
coefficients (PLXANT) from Property Estimation using the Data method.

If you enter vapor pressure data, you should also request estimation of
parameters by selecting the Estimate All Missing Parameters From Molecular
Structure check box.

The data you enter can be modified later on the Properties Data form with the
name you defined.

The data can also be used with Data Regression. For information on entering pure
component data or Data Regression, see Chapter 31.

Continued
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Type Description

Extended Antoine
vapor pressure
coefficients

Coefficients for the extended Antoine vapor pressure equation (PLXANT)

These parameters can be modified later on the Properties Parameters Pure
Components PLXANT-1 form. For more information on entering or modifying
property parameters, see Chapter 8.

Ideal gas heat
capacity data

Ideal gas heat capacity data used to determine coefficients for the ideal gas heat
capacity equation (CPIG) from Property Estimation using the Data method. (For
more information see Chapter 30.)

If you enter Ideal gas heat capacity data, you should also request estimation of
parameters by selecting the Estimate All Missing Parameters From Molecular
Structure check box.

The data you enter can be modified later on the Properties Data form with the
name you defined.

The data can also be used with Data Regression. For information on Data
Regression, or entering pure component data, see Chapter 31.

Ideal gas heat
capacity polynomial
coefficients

Coefficients for the ideal gas heat capacity equation (CPIG)

These parameters can be modified later on the Properties Parameters Pure
Components CPIG-1 form. For more information on entering or modifying property
parameters, see Chapter 8.

10. Optionally, select the Estimate All Missing Parameters From Molecular
Structure check box.

11. Click Finish to close the wizard and return to the Components Specifications
Selection sheet.

Defining a Solid Component

The steps used to define a solid component are almost the same as those for
conventional components. You must select Solid from the Type list in Step 2
above, and the types of data or parameters you can enter are pertinent to solid
components.

Normal boiling point is not required per se in property calculations, but is used to
estimate many other parameters such as critical temperature and critical
pressure if they are missing. If you have an experimental normal boiling point,
you should enter it.
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Since most simulations involve energy balance calculations, enthalpy is required.
Solid enthalpy of formation of solids (DHSFRM) is used in the enthalpy
calculations, but is not required unless the simulation contains chemical
reactions, because DHSFRM defaults to zero.

Defining a Nonconventional Component

To define a nonconventional component, open the User Defined Component
wizard, then:
1. Enter the Component ID. Every component in the flowsheet must have a

Component ID. This ID is used to refer to the component throughout the
simulation.

2. Select Nonconventional from the Type list.

3. Click Next.

4. Choose Enthalpy and Density models by selecting from the Enthalpy and
Density lists respectively. The required component attributes for the selected
models are shown below the model selections.

For more information on properties for nonconventional components, see
Chapter 7.

5. Click Finish to close the wizard and return to the Components Specifications
Selection sheet.

The nonconventional property specifications you entered are saved under the
Properties Advanced NC-Props form.
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Adding a Component

To add a component to the existing component list:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, move to the first blank row.

3. Enter a Component ID, name or formula.

Follow the next two steps if you wish to move the component within the list.

4. Click the Reorder button to open the Reorder Components dialog box.

5. Select the new component and move it up in the sequence with the up arrow
to the right of the components list.

Inserting a Component
To insert a component:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, move to the row where you want the
new component inserted.

3. Click the right mouse button and from the menu that appears, click Insert
Row.

4. Enter a Component ID, name or formula in the new row.

Renaming a Component

To rename an existing component:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, move to the Component ID box for the
component you want to rename.

3. Type over the existing ID.

Aspen Plus prompts you to either delete or rename the existing component.

4. Select Rename.
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The component is renamed on this form and on all other forms where it
appears. No data is lost.

If you select Delete, both the Component ID and its data is deleted.

Deleting a Component

To delete a component:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, click the right mouse button on the row
selector for the component you want to delete.

3. Choose Delete Row from the menu that appears.

When you delete a component, all references to the component on other
sheets are automatically deleted. For example, if you entered component
flows on a Stream form, then you deleted a component on the Components
Specifications Selection sheet. Aspen Plus automatically deletes the
component ID and flow from the Stream form.

Reordering the Component List

To reorder the list of components on the Components Specifications Selection sheet:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, click the Reorder button.

3. Click the ID of the component you wish to move.

4. Move the component in the appropriate direction, by clicking the up or down
arrows to the right of the list.

5. Repeat Steps 3 and 4 until all components are ordered as desired.

6. Click Close to return to the Specifications Selection sheet which displays the
components with the new order.

Aspen Plus retains all original data and references for the components on this
and other forms.
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Generating Electrolyte Components and
Reactions

Electrolyte systems involve ionic components and reactions that must be defined to
complete the components specification. You can use the Electrolyte Wizard to
generate ionic reactions and additional components that might be formed by the
reactions.

Before opening the Electrolyte Wizard:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, enter the component Water (H2O).
Electrolyte systems must have water present.

3. Enter the additional molecular components that define the system. Some
examples are:

System Molecular Components

Sour water system CO2, H2S, O2S (for SO2)

Brine system NACL (use Type = Conventional, do not identifyType as
Solid)

4. Click the Elec Wizard button.

5. On the Electrolytes Wizard dialog box, click Next.

Tip  For Help on the Wizard click the What’s This button in the wizard and
then click any active field in the Wizard.

Generating the List of Components
To generate the list of required components:
1. From the left pane of the Data Browser, double-click the Components folder,

then click Specifications.

2. On the Selection form, click the Elec Wizard button.

3. Click Next on the first Electrolyte wizard dialog box that appears.

4. On the Base Components and Reactions Generation Option dialog box, select
the components from which you want to generate reactions and ionic species.
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5. To move an individual component from the Available Components list, click
an individual component and then click the single right arrow.

To move all components to the Selected components list, click the double
arrow.

6. Turn the other options on or off to match your preferences.

The recommended hydrogen ion type is Hydronium ion H3O+.  You may
toggle this to use Hydrogen ion H+.

Select this option To

Include Salt Formation Include solid salts when new species are generated. Default (On) is to include salts.

Include Water Dissociation
Reaction

Include water dissociation in the list of generated reactions. Default (Off) is not to
include water dissociation reaction.

7. Click Next.

On the Generated Species and Reactions dialog box, Aspen Plus displays lists
of aqueous species, salts, and reactions.
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For reactions, arrows pointing in both directions mean ionic equilibrium or
salt precipitation. An arrow pointing in one direction means complete
dissociation. Generated solid salt components are assigned component IDs
with (S) to indicate the solid type.

8. Remove any unwanted items by selecting them and clicking Remove.
Removing any species will remove all reactions containing that species.

9. Click Next.

10. On the Simulation Approach dialog box, choose the simulation approach.

Choose this approach To have The Calculation method is

True † All calculated results displayed in terms of
the actual species present (molecular, ionic,
and solid forms of the same electrolyte will
each be shown separately).

Electrolyte reactions solved simultaneously
with phase equilibrium equations in unit
operation models

Apparent All forms of the same electrolyte show up as
a single component

Electrolyte reactions solved during property
evaluations

†  
The default true component approach is generally preferred for calculation efficiency.

Both approaches give the same results. You are also shown the name of the
Chemistry ID (GLOBAL) and the Henry-Comps ID (also GLOBAL).

11. Click Next to create the Chemistry and Henry-Comps forms and go on to the
Summary sheet.
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The Summary dialog box summarizes the modifications made by the
Electrolyte Wizard to your properties, components, databanks, and chemistry
specifications. Review or modify the generated specifications for Henry
components or for electrolyte reactions on the Summary dialog box.

Reviewing Generated Henry Components

To review or modify the Henry Components list generated by the Electrolytes
Wizard:
1. Click the Review Generated Henry-Comps List button on the Summary dialog

box.

2. On the Henry Components Global dialog box, select components and use the
right and left arrow buttons to add or remove from the Selected Components
list.

3. Click the X in the upper right corner of the dialog box when finished to close
the dialog box.

4. Note that Henry component specifications can be modified later using the
Components Henry-Comps forms.

Reviewing Generated Electrolyte Reactions

To review or modify the electrolyte reactions generated by the Electrolyte
Wizard:
1. Click the Modify/Add Reactions button on the Summary dialog box.

2. On the Modify/Add Reactions Global dialog box, the Stoichiometry sheet
displays the reactions, their type, and their stoichiometry. To modify reaction
stoichiometry for a reaction, select it from the list, and click Edit. When you
finish modifying the stoichiometry, click Close.

3. Use the Equilibrium Constants sheet to enter, review, or change the
Equilibrium constants, their concentration basis, or the temperature
approach to equilibrium. To view or modify equilibrium constant information
for other reactions, select the desired reaction from the Equilibrium Reaction
list.

4. Click the X in the upper right corner of the dialog box when finished.

Electrolyte chemistry specifications can be modified later using the Reactions
Chemistry forms.

After reviewing the information on the Summary dialog box, click Finish to
save all the changes to the appropriate forms and to return to the
Components Specifications Selection sheet.
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For more information about modeling your process with electrolytes, see
Aspen Plus Physical Property Methods and Models or the Getting Started guide.

Identifying Solid Components

To identify components as solids:
1. From the Data menu, click Components.

2. On the Specifications Selection sheet, specify the Component ID.

3. If the component is a databank component, specify the formula and
component name. For more information, see Specifying Components from a
Databank on page 6 - 1.

4. In the Type box, specify Solid for a conventional solid or Nonconventional for
a nonconventional solid.

Conventional Solids
Conventional solids are pure materials. These solids may be present in mixtures
in phase and/or chemical equilibrium, including electrolyte salts. For example,
NaCl can be a conventional solid precipitating from an electrolyte solution. These
solids are present in the MIXED substream.

Conventional solids are characterized in terms of properties, such as:

• Molecular weight
• Vapor pressure
• Critical properties

Conventional solids that do not participate in phase equilibrium calculations are
conventional inert solids. Conventional inert solids:

• Can participate in chemical equilibrium, modeled by the RGibbs unit
operation model. None of the other unit operation models handles solid
equilibrium.

• Are assigned the substream type CISOLID to distinguish them from other
conventional solids
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Nonconventional Solids
Nonconventional solids are materials characterized in terms of empirical factors
called component attributes. Component attributes represent component
composition by one or more constituents.

Nonconventional solids never participate in phase or chemical equilibrium
calculations. Aspen Plus always assigns substreams of type NC to
nonconventional solids.

Examples of nonconventional solids are coal and wood pulp.

About Component Attributes
Component attributes represent component composition in terms of one or more
sets of constituents. For example, coal is often characterized in terms of ultimate
and proximate analyses, as well as several other types of analysis.

You can assign component attributes to non-solid conventional components (Type
is Conventional).

The standard Aspen Plus property models and unit operation models do not use
these attributes in any calculations. But assigning attributes lets you keep track
of properties that do not affect material and energy balance calculations. For
example, you could assign component attributes to account for the color or odor of
a component. You can use component attributes in Fortran subroutines for
property models or unit operation calculations that you write.

The following table describes available component attributes:

Component Attribute Description Elements

PROXANAL Proximate analysis, weight % 1 Moisture (moisture-included basis)
2 Fixed carbon (dry basis)
3 Volatile Matter (dry basis)
4 Ash (dry basis)

ULTANAL Ultimate analysis, weight % 1 Ash (dry basis)
2 Carbon (dry basis)
3 Hydrogen (dry basis)
4 Nitrogen (dry basis)
5 Chlorine (dry basis)
6 Sulfur (dry basis)
7 Oxygen (dry basis)

Continued
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Component Attribute Description Elements

SULFANAL Forms of sulfur analysis,
weight % of original coal

1 Pyritic (dry basis)
2 Sulfate (dry basis)
3 Organic (dry basis)

GENANAL General constituent analysis,
weight %

1 Constituent 1
2 Constituent 2
.
.
20 Constituent 20

For information on entering component attribute values in streams, see
Chapter 9, Specifying Streams.

Assigning Attributes to Conventional Components
To assign attributes to a conventional or conventional solid component:
1. From the Data menu, click Components.

2. In the left pane of the Data Browser, click Attr-Comps.

3. On the Selection sheet, choose a Component ID from the Component list. You
may select more components by listing them below the first one.

4. Select a component attribute from the Attributes list. You may list multiple
component attributes for each component.

In most cases, the conventional components to which you assign attributes will
be solids (Type is Solid on the Components Specifications Selection sheet).

For information on entering component attribute values in streams, see
Chapter 9, Specifying Streams.

Assigning Attributes to Nonconventional Components
Attributes for nonconventional components are automatically assigned when you
select nonconventional enthalpy and density models on the Properties Advanced
NC-Props form, or use the User Defined Components wizard with a
nonconventional component.

You can assign additional component attributes to nonconventional components.
To do this:
1. From the Data menu, select Physical Properties.
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2. In the left pane of the Data Browser, double-click the Advanced folder.

3. Click NC-Props.

4. Select a component from the Component list.

5. Enter the enthalpy and density model names for that component, if this has
not already been done.

The required component attributes for the selected models will be
automatically listed at the bottom of the sheet.

6. Add component attributes to the Required Component Attributes For The
Selected Models box by selecting them from the list.

For more information on See

Property methods for nonconventional components Chapter 7, Physical Property Methods

Parameters for nonconventional components Chapter 8, Physical Property Parameters and Data

Entering component attribute values Chapter 9, Specifying Streams

Specifying Supercritical (HENRY)
Components

In the activity-coefficient approach for computing vapor-liquid equilibrium, Henry's
law is used to represent the behavior of dissolved gases or other supercritical
components.

To use Henry's law in Aspen Plus, you must define one or more sets of
supercritical (or Henry’s) components.

For Henry's law to be used during property calculations, you must also specify a
Henry Components ID on one of these sheets:

• Properties Specifications Global sheet
• Properties Specifications Flowsheet Sections sheet
• A unit operation BlockOptions Properties sheet
• A Property Analysis Properties sheet

Aspen Plus has built-in Henry’s law parameters for a large number of component
pairs. The solvents are water and other organic compounds.
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These parameters are used automatically on the Properties Parameters Binary
Interaction HENRY-1 form when you specify a property method that uses Henry
Comps. For components that do not have Henry's law parameters available, you
must enter Henry's law parameters on the Properties Parameters Binary
Interaction HENRY-1 form. See Chapter 8 for a discussion of physical property
parameter requirements.

To define a set of Henry's components:
1. From the Data menu, click Components.

2. In the left pane of the Data Browser, click Henry Comps.

3. On the Henry Components Object Manager, click New.

4. In the Create New ID dialog box, enter an ID for a new list of Henry
Components, or accept the default ID.

5. Specify the Component IDs in Selected components list.

Select the components to include as Henry components from the Available
components list and use the right arrow button to move them into the
Selected components list. The left arrow can be used to remove components
from the Selected components list. The double arrow can be used to move all
of the components in a list at one time.

Example of Specifying Henry's Components

In this example, N2, CO2, and H2S are identified as Henry’s components. BZ,
CH, and H2O are not selected as Henry components.
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Specifying UNIFAC Groups

Use the Components UNIFAC Groups Selection sheet to identify UNIFAC groups
or to introduce new groups. If you want to enter UNIFAC group parameters or
group-group interaction parameters, you must assign an ID to each group. Use the
group ID on the Properties Parameters UNIFAC Group form or UNIFAC Group
Binary form to enter group parameters.

To specify UNIFAC groups:
1. From the Data menu, choose Components.

2. In the left pane of the Data Browser, click UNIFAC Groups.

3. On the UNIFAC Groups Selection sheet, type a name for the group in the
Group ID box. Every group needs a name that can be referenced on other
forms.

4. Select a number from the Group number list. As you scroll, a brief description
of each group appears in the description area.

If you want to define a new UNIFAC group, type in a number between 4000
and 5000 in the Group number box.

Defining Component Groups

You can specify a group of components to be converged in a tear stream.

A component group consists of either a:

• List of components
• Range of components from the Components Specifications Selection sheet
• Combination of component lists and ranges

To define a component group:
1. From the Data menu, click Components.

2. In the left pane of the Data Browser, click Comp-Group.

3. In the Component Group Object Manager, click New.

4. In the Create New ID dialog box, enter an ID for the new Component Group
or accept the default.

5. On the Component List sheet, choose a substream from the Substream
list.
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5. Specify the components to be included in the component group.

Select the components to include from the Available components list and use
the right arrow button to move them into the Selected components list. The
left arrow can be used to remove components from the Selected components
list. The double arrows can be used to move all of the components in a list at
one time.

Alternatively, you can click the Component Range sheet, and enter a range of
components that represent your component group.

7. If you want to create a component group containing components from more
than one substream, repeat steps 5 and 6.

Using a component group can aid tear stream convergence when you use the
NEWTON, BROYDEN, or SQP convergence methods and your flowsheet has all
of the following:

• Recycles
• A large number of components
• Some components known to have zero or constant flow rates

A component group reduces the problem matrix size and the number of
numerical derivative perturbations (if performed). This makes convergence faster
and more stable.

To use a component group for a convergence method, you must specify the
Component Group ID in one of the following sheets:

• Convergence Convergence Input Tear Streams sheet
• Convergence Conv-Options Defaults Tear Convergence sheet

❖     ❖     ❖     ❖ 
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7 Physical Property Methods

Choosing the appropriate property method is often the key decision in
determining the accuracy of your simulation results. This chapter provides
guidelines for choosing appropriate property methods and models including:

• What is a property method
• Available property methods
• Choosing a property method
• Creating new property methods
• Specifying the global property method
• Specifying a property method for a flowsheet section
• Specifying a local property method
• Defining supercritical components
• Specifying properties for the free-water phase
• Special method for K-value of water in the organic phase
• Specifying electrolyte calculations
• Modifying property methods
• Property methods for nonconventional components
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What Is a Property Method?

A property method is a collection of methods and models that Aspen Plus uses to
compute thermodynamic and transport properties.

The thermodynamic properties are:

• Fugacity coefficient (K-values)
• Enthalpy
• Entropy
• Gibbs free energy
• Volume

The transport properties are:

• Viscosity
• Thermal conductivity
• Diffusion coefficient
• Surface tension

Aspen Plus includes a large number of built-in property methods that are
sufficient for most applications. However, you can create new property methods
to suit your simulation needs.

Available Property Methods

You must select one or more Property Methods to model the properties of specific
systems in your flowsheet. Each property method has a unique approach to
representing K-values.

The following tables list all of the property methods available in Aspen Plus.

You can modify these existing methods or create new methods. For more
information, see Modifying Property Methods on page 7-18.
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Ideal Property Methods

Ideal Property Method K-Value Method

IDEAL Ideal Gas/Raoult's law/Henry's law

SYSOP0 Release 8 version of Ideal Gas/Raoult's law

Equation-of-State Property Methods

Equation-of-State Property Method K-Value Method

BWR-LS BWR Lee-Starling

LK-PLOCK Lee-Kesler-Plöcker

PENG-ROB Peng-Robinson

PR-BM Peng-Robinson
with Boston-Mathias alpha function

PRWS Peng-Robinson
with Wong-Sandler mixing rules

PRMHV2 Peng-Robinson
with modified Huron-Vidal mixing rules

PSRK Predictive Redlich-Kwong-Soave

RKSWS Redlich-Kwong-Soave
with Wong-Sandler mixing rules

RKSMHV2 Redlich-Kwong-Soave
with modified Huron-Vidal mixing rules

RK-ASPEN Redlich-Kwong-ASPEN

RK-SOAVE Redlich-Kwong-Soave

RKS-BM Redlich-Kwong-Soave
with Boston-Mathias alpha function

SR-POLAR Schwartzentruber-Renon
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Activity Coefficient Property Methods

Activity Coefficient
Property Method

Liquid Phase Activity
Coefficient Method

Vapor Phase Fugacity
Coefficient Method

B-PITZER Bromley-Pitzer Redlich-Kwong-Soave

ELECNRTL Electrolyte NRTL Redlich-Kwong

ENRTL-HF Electrolyte NRTL HF Hexamerization model

ENRTL-HG Electrolyte NRTL Redlich-Kwong

NRTL NRTL Ideal gas

NRTL-HOC NRTL Hayden-O'Connell

NRTL-NTH NRTL Nothnagel

NRTL-RK NRTL Redlich-Kwong

NRTL-2 NRTL (using dataset 2) Ideal gas

PITZER Pitzer Redlich-Kwong-Soave

PITZ-HG Pitzer Redlich-Kwong-Soave

UNIFAC UNIFAC Redlich-Kwong

UNIF-DMD Dortmund-modified UNIFAC Redlich-Kwong-Soave

UNIF-HOC UNIFAC Hayden-O'Connell

UNIF-LBY Lyngby-modified UNIFAC Ideal gas

UNIF-LL UNIFAC for liquid-liquid systems Redlich-Kwong

UNIQUAC UNIQUAC Ideal gas

UNIQ-HOC UNIQUAC Hayden-O'Connell

UNIQ-NTH UNIQUAC Nothnagel

UNIQ-RK UNIQUAC Redlich-Kwong

UNIQ-2 UNIQUAC (using dataset 2) Ideal gas

VANLAAR Van Laar Ideal gas

VANL-HOC Van Laar Hayden-O'Connell

VANL-NTH Van Laar Nothnagel

VANL-RK Van Laar Redlich-Kwong

VANL-2 Van Laar (using dataset 2) Ideal gas

WILSON Wilson Ideal gas

WILS-HOC Wilson Hayden-O'Connell

WILS-NTH Wilson Nothnagel

WILS-RK Wilson Redlich-Kwong

WILS-2 Wilson (using dataset 2) Ideal gas

Continued
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Activity Coefficient
Property Method

Liquid Phase Activity
Coefficient Method

Vapor Phase Fugacity
Coefficient Method

WILS-HF Wilson HF Hexamerization model

WILS-GLR Wilson (ideal gas and liquid
enthalpy reference state)

Ideal gas

WILS-LR Wilson (liquid enthalpy reference
state)

Ideal gas

WILS-VOL Wilson with volume term Redlich-Kwong

Property Methods for Special Systems

Property Methods for Special
Systems

K-Value Method System

AMINES Kent-Eisenberg amines model H2S, CO2, in MEA, DEA,  DIPA, DGA
solution

APISOUR API sour water model Sour water with NH3, H2S, CO2

BK-10 Braun K-10 Petroleum

SOLIDS Ideal Gas/Raoult's law/Henry's law/solid
activity coefficients

Pyrometallurgical

CHAO-SEA Chao-Seader corresponding states model Petroleum

GRAYSON Grayson-Streed corresponding states model Petroleum

STEAM-TA ASME steam table correlations Water/steam

STEAMNBS NBS/NRC steam table equation of state Water/steam

Choosing a Property Method

Use the tables starting on page 7-6 and the figures on page 7-10 to select the best
property method for your simulation. For more information, see also Chapter 8 for
detailed descriptions of the data requirements for each property method. Many
methods contain extensive built-in binary parameters, so they are essentially
predictive.
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Recommended Property Methods for Different
Applications

Use these tables as guidelines for selecting the best property method for your
simulation.

Oil and Gas Production

Application Recommended Property Methods

Reservoir systems PR-BM, RKS-BM

Platform separation PR-BM, RKS-BM

Transportation of oil and gas by pipeline PR-BM, RKS-BM

Refinery

Application Recommended Property Methods

Low pressure applications
(up to several atm)

Vacuum tower, atmospheric crude tower

BK10, CHAO-SEA, GRAYSON

Medium pressure applications
(up to several tens of atm)

Coker main fractionator,
FCC main fractionator

CHAO-SEA, GRAYSON, PENG-ROB, RK-SOAVE

Hydrogen-rich applications
Reformer, Hydrofiner

GRAYSON, PENG-ROB, RK-SOAVE

Lube oil unit, De-asphalting unit PENG-ROB, RK-SOAVE

Gas Processing

Application Recommended Property Methods

Hydrocarbon separations
Demethanizer
C3-splitter

PR-BM, RKS-BM, PENG-ROB, RK-SOAVE

Cryogenic gas processing
Air separation

PR-BM, RKS-BM, PENG-ROB, RK-SOAVE

Gas dehydration with glycols PRWS, RKSWS, PRMHV2, RKSMHV2, PSRK, SR-POLAR

Acid gas absorption with
Methanol (RECTISOL)
NMP (PURISOL)

PRWS, RKSWS, PRMHV2, RKSMHV2, PSRK, SR-POLAR

Continued
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Application Recommended Property Method

Acid gas absorption with
Water
Ammonia
Amines
Amines + methanol (AMISOL)
Caustic
Lime
Hot carbonate

ELECNRTL

Claus process PRWS, RKSWS, PRMHV2, RKSMHV2, PSRK, SR-POLAR

Petrochemicals

Application Recommended Property Methods

Ethylene plant
Primary fractionator

Light hydrocarbons
Separation train
Quench tower

CHAO-SEA, GRAYSON

PENG-ROB, RK-SOAVE

Aromatics
BTX extraction

WILSON, NRTL, UNIQUAC and their variances †

Substituted hydrocarbons
VCM plant
Acrylonitrile plant

PENG-ROB, RK-SOAVE

Ether production
MTBE, ETBE, TAME

WILSON, NRTL, UNIQUAC and their variances †

Ethylbenzene and styrene plants PENG-ROB, RK-SOAVE
–or–
WILSON, NRTL, UNIQUAC and their variances †

Terephthalic acid WILSON, NRTL, UNIQUAC and their variances †

(with dimerization in acetic acid section)

† See the figures on pages 7-10 through 7-12 for recommendations based on pressure and vapor phase
association.

Chemicals

Application Recommended Property Methods

Azeotropic separations
Alcohol separation

WILSON, NRTL, UNIQUAC and their variances†

Carboxylic acids
Acetic acid plant

WILS-HOC, NRTL-HOC, UNIQ-HOC

Phenol plant WILSON, NRTL, UNIQUAC and their variances†

Liquid phase reactions
Esterification

WILSON, NRTL, UNIQUAC and their variances†

Continued
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Application Recommended Property Methods

Ammonia plant PENG-ROB, RK-SOAVE

Fluorochemicals WILS-HF

Inorganic Chemicals
Caustic
Acids
Phosphoric acid
Sulphuric acid
Nitric acid
Hydrochloric acid

ELECNRTL

Hydrofluoric acid ENRTL-HF

†
See the figures on pages 7-10 through 7-12 for recommendations based on pressure and vapor phase
association

Coal Processing

Application Recommended Property Methods

Size reduction crushing, grinding SOLIDS

Separation and cleaning sieving,

cyclones, precipitation, washing

SOLIDS

Combustion PR-BM, RKS-BM (combustion databank)

Acid gas absorption with
Methanol (RECTISOL)
NMP (PURISOL)

PRWS, RKSWS, PRMHV2, RKSMHV2, PSRK, SR-POLAR

Acid gas absorption with
Water
Ammonia
Amines
Amines + methanol (AMISOL)
Caustic
Lime
Hot carbonate

ELECNRTL

Coal gasification and liquefaction See Synthetic Fuels table.

Power Generation

Application Recommended Property Methods

Combustion
Coal
Oil

PR-BM, RKS-BM (combustion databank)

Steam cycles
Compressors
Turbines

STEAMNBS, STEAM-TA

Acid gas absorption See gas processing.
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Synthetic Fuel

Application Recommended Property Methods

Synthesis gas PR-BM, RKS-BM

Coal gasification PR-BM, RKS-BM

Coal liquefaction PR-BM, RKS-BM, BWR-LS

Environmental

Application Recommended Property Methods

Solvent recovery WILSON, NRTL, UNIQUAC  and their variances †

(Substituted) hydrocarbon stripping WILSON, NRTL, UNIQUAC  and their variances †

Acid gas stripping from
Methanol (RECTISOL)
NMP (PURISOL)

PRWS, RKSWS, PRMHV2, RKSMHV2, PSRK, SR-POLAR

Acid gas stripping from:
Water
Ammonia
Amines
Amines + methanol (AMISOL)
Caustic
Lime
Hot carbonate

ELECNRTL

Acids
Stripping
 Neutralization

ELECNRTL

† See the figures on pages 7-10 through 7-12 for recommendations based on pressure and vapor phase
association.

Water and Steam

Application Recommended Property Methods

Steam systems
Coolant

STEAMNBS, STEAM–TA

Mineral and Metallurgical Processes

Application Recommended Property Methods

Mechanical processing:
Crushing
Grinding
Sieving
Washing

SOLIDS

Hydrometallurgy
Mineral leaching

ELECNRTL

Pyrometallurgy
Smelter
Converter

SOLIDS
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Guidelines for Choosing a Property Method
The following diagrams show the process for choosing a property method.

P olar
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E lectro lyte
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Vacuum

E LE C N RTL
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P EN G -R O B , R K -SO AV E ,
LK -P LO C K , P R -B M ,
R K S-BM

P seudo &
R ea l

N onpolar

R eal or P seudocom ponen ts

E lectro lyte

P ressu re

P ola rity

*

> 1atm

* See the figure  on page 7-11.

Guidelines for Choosing a Property Method
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R K SW S , P R M H V2,
R K SM H V 2

U N IFA C , U N IF -LB Y,
U N IF -D M D

U N IF -LL

N RT L, U N IQ U A C ,
and their va riances

W ILS O N , N RTL , U N IQ U AC ,
and their variances

Pressu re

Inte raction pa ram eters availab le

L iqu id-L iqu id

Y

Y

N

N

Y

N

Y

N

* See the figure on page 7-12 .

Guidelines for Choosing a Property Method for Polar Non-Electrolyte
Systems
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Guidelines for Choosing an Activity Coefficient Property
Method

Vapor phase association

D egrees of polym erization

D im ers

W ILS -H F

W ILS -N T H , W ILS -H O C
N RT L-N T H , N RT L-H O C
U N IQ -N TH , U N IQ -H O C
U N IF-H O C

W ILS O N , W ILS -R K ,
W ILS -LR , W ILS-G LR ,
N RT L , N RTL-R K , N RT L-2
U N IQ U A C , U N IQ -R K ,
U N IQ -2, U N IFA C , U N IF -LL,
U N IF -LB Y, U N IF -D M D

W ILSO N
N RT L
U N IQ U AC
U N IFAC

N

Y

VAP ?

H exam ers

D P?

General Guidelines for Choosing an Activity Coefficient Property Method

Specifying the Global Property Method
Aspen Plus uses the global property method for all property calculations, unless
you specify a different property method for a specific flowsheet section, unit
operation block, or property analysis.

To specify the global property method:
1. From the Data menu, click Properties.

2. On the Global sheet, in the Property Method list box, specify the property
method.

3. You can also use the Process Type list box to help you select an appropriate
property method. In the Process Type list box, select the type of process you
want to model. Each process type has a list of recommended property
methods. For more information on process types, see Chapter 2.

4. In the Base Method list box, select a base property method.



Aspen Plus User Guide 7-13
Version 10.1-0

Chapter 7

5. If you are using an activity coefficient property method and want to use
Henry's law for supercritical components, specify the Henry component list
ID in the Henry Components list box. For more information on Henry's
components, see Defining Supercritical Components on page 7-15.

6. If you have a petroleum application that requires free water calculations,
specify the property method for the free water phase in the Free-Water
Method list box and water solubility option in the Water Solubility list box.
For more information, see Using Free Water Calculations on page 7-16.

7. For electrolyte applications, you must select an electrolytic property method,
then select the Chemistry ID in the Chemistry ID list box. You can also
specify the electrolyte computation method in the Use True-Components
check box.

Specifying a Property Method for a Flowsheet Section
Use flowsheet sections to simplify the assignment of property methods when you
are using more than one property method in a simulation. For example, you could
divide a flowsheet into high pressure and low pressure sections, and assign an
appropriate property method to each section.

See Chapter 3 for more information on flowsheet sections, including how to
create a flowsheet section.

To specify a property method for a flowsheet section:
1. From the Data menu, click Properties

2. On the Flowsheet Sections sheet, select a flowsheet section from the
Flowsheet Section ID list box.

3. Specify the property method in the Property Method list box.

4. You can also use the Process Type list box to help you select an appropriate
property method. In the Process Type list box, select the type of process you
want to model. Each process type has a list of recommended property
methods. For more information on process types, see Chapter 2.

5. In the Base Method list box, select a base property method.

6. If you are using an activity coefficient property method and want to use
Henry's Law for supercritical components, specify the Henry component list
ID in the Henry Components list box. For more information on Henry's
components, see Defining Supercritical Components on page 7-15.

7. For petroleum applications, you may want free water calculations. Specify the
free water property method in the Free-Water Method list box and water
solubility option in the Water Solubility list box. For more information, see
Using Free Water Calculations on page 7-16.
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8. For electrolyte applications, you must select an electrolytic property method,
then select the Chemistry ID in the Chemistry ID list box. You can also
specify the electrolyte computation method in the Use True-Components
check box.

Specifying a Local Property Method
You can override the global property method by specifying a local property
method on:

• The BlockOptions Properties sheet, for a unit operation block
• The Properties sheet, for a Properties Analysis

The specifications you enter on the Properties sheet apply only to that unit
operation block or property analysis.

For the following unit operation models, you can specify different property
methods for streams or sections in the block:

Model Sheet Allows you to specify property methods for

Decanter Decanter Properties Phase Property Liquid1 and liquid2 phases

RadFrac Radfrac Properties Property Sections Column segments, decanters,
thermosyphon reboiler

RGibbs Rgibbs Setup Products Each phase

MultiFrac Multifrac Properties Property Sections Column segments

PetroFrac Petrofrac Properties Property Sections
Petrofrac Stripper Properties Property
Sections

Column segments for main column
Column segments for stripper

HeatX Heatx BlockOptions Properties Hot and cold sides of the exchanger

MHeatX Mheatx BlockOptions Properties Each stream in the exchanger

RPlug Rplug BlockOptions Properties Reactant and external coolant streams

Use the Properties Specifications Referenced sheet to enter additional property
methods for use in the unit operation blocks or in property analysis calculations.

When performing an interactive property analysis, you can select any property
method that has been specified on the Properties Specifications Referenced
sheets.
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Defining Supercritical Components

Activity coefficient property methods handle supercritical components present in
the liquid phase by the asymmetric convention for activity coefficient normalization
(Henry's law).

To use Henry's law for supercritical components:
1. Select an appropriate property method. These property methods allow

Henry's law:

B-PITZER NRTL-2 UNIQUAC VANL-2

IDEAL PITZER UNIQ-HOC WILSON

ELECNRTL PITZ-HG UNIQ-NTH WILS-HF

ENRTL-HF SOLIDS UNIQ-RK WILS-HOC

ENRTL-HG UNIFAC UNIQ-2 WILS-NTH

NRTL UNIF-DMD VANLAAR WILS-RK

NRTL-HOC UNIF-HOC VANL-HOC WILS-2

NRTL-NTH UNIF-LBY VANL-NTH WILS-GLR

NRTL-RK UNIF-LL VANL-RK WILS-LR

2. Define a Henry's component group using the Henry Comps forms. For more
information, see Chapter 6.

3. Enter the ID of the Henry's component group on the Properties Specifications
Global sheet (Use the Flowsheet Sections sheet for flowsheet sections
specifications) or BlockOptions Properties sheet (local specification for unit
operation models).

For more information on Henry's law, see Aspen Plus Physical Property
Methods and Models.

Equation-of-state property methods do not require special treatment for
supercritical components.
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Using Free Water Calculations

For water-hydrocarbon applications, two liquid phases often coexist with a vapor
phase. Aspen Plus has two approaches for modeling these types of vapor-liquid-
liquid equilibrium simulations:

• Rigorous three-phase calculations
• Calculations with a free water approximation. When you use free water

approximation, Aspen Plus assumes the water phase is pure liquid water
(free water).

Free water calculations are:

• Normally adequate for water-hydrocarbon systems, where the hydrocarbon
solubility in the water phase is generally negligible.

• Always faster than rigorous three-phase calculations, and require minimal
physical property data.

For more information on requesting free water calculations, see Chapter 5.

Note   You can also specify free water calculations on a local basis in individual
streams and blocks. For more information on free-water calculations. see
Aspen Plus Physical Property Methods and Models.

Specifying Properties for the Free Water Phase
When you use the free water approximation, you must specify the property
method to be used for the free water phase. This property method calculates all
thermodynamic and transport properties for the free-water phase.

To choose a property method:
1. Go to the Properties Specifications Global sheet or Flowsheet Sections sheet,

or the BlockOptions Properties sheets for a unit operation model.

2. In the Free-Water Method list box, select one:

Property Method Description Merits

STEAM-TA 1967 ASME steam table correlations (default) -

STEAMNBS NBS/NRC steam table correlations More accurate than the ASME steam table

IDEAL or
SYSOP0

For systems at low or moderate pressures More efficient calculations than
STEAM-TA or STEAMNBS
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Special Method for K-Value of Water in the Organic
Phase

The global property method calculates the K-value of water unless you specify
another method.

In free water calculations, you can use a special method to calculate the K-value
of water in the organic phase:

v
w

l
ww

wK
ϕ
ϕγ *,

=

Where:

γw
= Activity coefficient of water in the organic phase

ϕw

*,l = Fugacity coefficient of pure liquid water calculated using
the free-water phase property method

ϕw

v = Fugacity coefficient of water in the vapor phase mixture

To select a calculation method for γw and ϕw

v:
1. Go to the Properties Specifications Global or Flowsheet Sections sheet, or the

BlockOptions Properties sheet for a unit operation model.

2. In the Water Solubility list box, select one:

Water Solubility Option Calculates γw from†† Calculates ϕw

v from

0

sol
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w
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Free-water property method
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w
x

1=γ
Primary property method

2 sol
wwsol
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www xx
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1

where),( γγ Primary property method

3† The K-value of water is calculated by the primary property method

Note  Xw
sol

is solubility of water in the organic phase, calculated using the
water-solubility correlation. (WATSOL).
†  

Water solubility option 3 is not recommended unless binary interaction parameters regressed from
liquid-liquid equilibrium data are available.

††
Xw

sol

is solubility of water in the organic phase, calculated using the water-solubility correlation.
(WATSOL).
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Specifying Electrolyte Calculations
To model an electrolyte system, you must:

• Use an electrolyte property method. ELECNRTL is recommended. Other
property methods are PITZER, B-PITZER, ENRTL-HF, ENRTL-HG AND
PITZ-HG.

• Define the solution chemistry on the Reactions Chemistry Stoichiometry
sheet.

• Select the solution chemistry ID to be used with the electrolyte property
method in the Chemistry ID list box on the Properties Specifications Global
sheet or the Flowsheet Sections sheet or the BlockOptions Properties sheet of
a unit operation model.

• Specify either the true or apparent component simulation approach using the
Use True Components check box.

Use the button on the Components Specifications Selection sheet to open the
Electrolytes Wizard which can set up all of these specifications for you. For
information on how to use the Electrolyte Wizard, see Chapter 6.

Modifying Property Methods

Property methods are defined by calculation paths (routes) and physical property
equations (models), which determine how properties are calculated.

Built-in property methods are sufficient for most applications. However, you can
modify a property method to include, for example:

• A route that calculates liquid fugacity coefficients without the Poynting
correction

• A route that calculates liquid enthalpy without heat of mixing
• A different equation-of-state model for all vapor phase property calculations
• A different set of parameters (for example, dataset 2) for an activity

coefficient model
• A route that calculates liquid molar volume using the Rackett model, instead

of a cubic equation of state

For more information on property models and model option codes, and on routes
and how to create them, see Aspen Plus Physical Property Methods and Models.



Aspen Plus User Guide 7-19
Version 10.1-0

Chapter 7

Modifying a Built-in Property Method
You can make the above common modifications to a property method on the
Properties Specifications Global sheet or the Flowsheet Section sheet:
1. From the Data menu, click Properties.

2. On the Global or the Flowsheet Sections sheet, select the property method
you want to modify in the Base Method list box.

3. Check the Modify Property Models check box.

4. When prompted, enter a new name for your modified property method and
click OK. Although it is not required, it is highly recommended that you
specify a new name for the modified property method.

You can make these modifications:

In this box To do this

Vapor EOS Select an equation of state model for all vapor phase properties calculations

Liquid gamma Select an activity coefficient model

Data set Specify parameter data set number for the EOS or liquid gamma model

Liquid enthalpy Select a route to calculate liquid mixture enthalpy

Liquid volume Select a route to calculate liquid mixture volume

Poynting correction Specify whether or not the Poynting correction is used in calculating liquid frugacity
coefficients. When selected, the Poynting correction is included.

Heat of mixing Specify whether or not heat of mixing is included in liquid mixture enthalpy. When
selected, heat of mixing is included.

Making Advanced Modifications to a Property Method
For additional and advanced modifications, use the Properties Property Methods
form:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Property Methods
folder.

The Object Manager appears.

3. Select the Property Method you want to modify and click Edit.

– or –

To create a new property method, click New, then specify the new property
method.



7-20 Aspen Plus User Guide
Version 10.1-0

Physical
Property
Methods

4. Use the Routes sheet to specify property routes and the Models sheet to
specify property models.

The Routes sheet displays the base property method, the properties and route ID
used to calculate each property. For convenience, properties are categorized as
follows:

• Pure thermodynamic
• Mixture thermodynamic
• Pure transport
• Mixture transport

To modify a route in the property method, select a desired route in the Route ID
box. You can also:

Click this button To do this

Create Create a new route for the selected property

Edit Modify a selected route

View View the structure of a selected route. The structure shows exactly how the route is
calculated and by what methods and models.

The Models sheet displays the property models used for calculation of the
properties in the property method. To modify a property model, select the desired
model in the Model Name column.

This table describes the different boxes on the Models sheet:

Use this box To specify

Model name The model you want to use to calculate each property

Data set The data set number for the parameters for the model

For a given model:

Use this button To Get

Affected properties A list of properties affected by the model. Models such as equation of state
are used to calculate more than one property.

Option codes Model option codes. Option codes are used to specify special calculation options.
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Property Methods for Nonconventional
Components

The only properties calculated for nonconventional components are enthalpy and
density. The folllowing tables list the models available. See Aspen Plus Physical
Property Methods and Models, Chapter 3, for detailed descriptions of these models.

Nonconventional Property Models

This table shows the general models:

Property Model Attribute Requirements

ENTHALPY ENTHGEN GENANAL

DENSITY DNSTYGEN GENANAL

This table shows the special models for coal and coal-derived materials:

Property Model Attribute Requirements

ENTHALPY HCOALGEN
HCJ1BOIE
HCOAL-R8
HBOIE-R8

ULTANAL, PROXANAL, SULFANAL
ULTANAL, PROXANAL, SULFANAL
ULTANAL, PROXANAL, SULFANAL
ULTANAL, PROXANAL, SULFANAL

DENSITY DCOALIGT
DCHARIGT

ULTANAL, SULFANAL
ULTANAL, SULFANAL

The tabular models for nonconventional components are:

Property Model

ENTHALPY ENTHLTAB

DENSITY DNSTYTAB

Specifying the Models for Nonconventional
Components

To specify the models used to calculate physical properties for nonconventional
components:
1. From the Data menu, click Properties.
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2. Double-click the Advanced folder.

3. Select the NC-Props form.

4. Select a component in the Component list box of the Property Methods sheet.

5. Specify the models for enthalpy and density.

Aspen Plus automatically fills in the required component attributes for the
models you specified.

❖     ❖     ❖     ❖ 
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8 Physical Property
Parameters and Data

This chapter explains how to evaluate property parameter requirements,
determine parameters available from databanks, and enter additional
parameters and data.

Topics include:

• About parameters and data
• Determining property parameter requirements
• Retrieving parameters from databanks
• Entering property parameters
• Using tabular data and polynomial coefficients
• Using property data packages

About Parameters and Data

When beginning any new simulation, it is important to check that you have
correctly represented the physical properties of your system. After you select the
property methods for a simulation as described in the previous chapter, you must
determine property parameter requirements and ensure that all required
parameters are available.
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In order to understand this and subsequent chapters, it is important to
distinguish between the terms Parameters and Data:

Item Definition Example

Parameters The constants used in the many
different physical property models, or
equations, used by Aspen Plus to
predict physical properties

These can be scalar constants such as
molecular weight (MW) and critical temperature (TC),
or they can be temperature-dependent property correlation
parameters such as the coefficients for the
extended Antoine vapor pressure equation (PLXANT).

Data Raw experimental property data that
can be used for estimation or
regression of parameters

Vapor pressure vs. Temperature data could be used to
estimate or regress the extended Antoine
parameters (PLXANT).

Determining Property Parameter
Requirements

Depending on the type of simulation, your model will require different parameters.
The following sections  describe the parameter requirements for some basic property
calculations, that is, for:

• Mass and energy balance simulations
• Henry's law
• Thermodynamic reference state

Most equation-of-state and activity coefficient models require binary parameters
for meaningful results. To determine parameter requirements based on your
chosen property methods, see the Property Method Tables in Aspen Plus Physical
Property Methods and Models for each property method you select.

Parameter Requirements for Mass and Energy Balance
Simulations

For simulations that involve both mass and energy balance calculations, you
must enter or retrieve from the databanks these required parameters:
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Enter or retrieve
this parameter

For On this type of
Properties Parameters form

MW Molecular weight Pure Component Scalar

PLXANT Extended Antoine vapor pressure
model

Pure Component T-Dependent

CPIG or CPIGDP Ideal gas heat capacity model Pure Component T-Dependent

DHVLWT or
DHVLDP

Heat of vaporization model Pure Component T-Dependent

This table gives further information:

If you These parameters are required Enter them on this type of
Properties Parameters form

Use the standard liquid volume
basis for any flowsheet or unit
operation model specification

Standard liquid volume parameters
(VLSTD)

Pure Component Scalar

Request free-water calculations Parameters for the water solubility
model (WATSOL)

Pure Component T-Dependent

Tip   If you deselect the Perform Heat Balance Calculations option on the Setup
Simulation Options Calculations sheet, Aspen Plus does not calculate enthalpies,
entropies, or Gibbs free energies. It does not require the parameters used to
compute these properties.

Parameter Requirements for Henry's Law
If you use Henry's law for supercritical components (or dissolved-gas
components), Henry's constant model parameters (HENRY) are required for all
dissolved-gas components with the solvents. You must list the supercritical
components on the Components Henry Comps Selection sheet.

If You require these parameters

More than one solvent is in the mixture Henry's constant parameters for each
dissolved-gas solvent pair.

Henry's constants are not available for all
solvents

Henry's constants for the major solvents.
Aspen Plus uses a rigorous defaulting procedure
when Henry's constants are missing
for a minor solvent component.

Enter Henry's constant model parameters on the Input sheet of the HENRY-1
object on the Properties Parameters Binary Interaction HENRY-1 form.
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Parameter Requirements for Thermodynamic
Reference State

The reference state for thermodynamic properties is the constituent elements in
an ideal gas state at 25° C and 1 atm. To calculate enthalpies, entropies, and
Gibbs free energies, Aspen Plus uses:

• Standard heat of formation (DHFORM)
• Standard Gibbs free energy of formation (DGFORM)

For systems that do not involve chemical reaction, you may allow DHFORM and
DGFORM to default to zero.

Values of Must be available for all components

DHFORM Participating in chemical reactions

DGFORM Involved in equilibrium reactions modeled by the RGibbs reactor model

Reference State for Conventional Solid Components

Conventional solid components may require:

• Standard solid heat of formation (DHSFRM)
• Standard solid Gibbs free energy of formation (DGSFRM)

Enter them on the Properties Parameters Pure Component Scalar Input sheet.

Reference State for Ionic Species

The reference state for ionic species is infinite dilution in water. To calculate
enthalpy, entropy, and Gibbs free energy of ions, Aspen Plus uses:

• Standard heat of formation in water at infinite dilution (DHAQFM)
• Standard Gibbs free energy of formation in water at infinite dilution

(DGAQFM)
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Retrieving Parameters from Databanks

For many components, Aspen Plus databanks store all required parameter values.
This chapter explains how to retrieve these built-in parameters from Aspen Plus
databanks:

• Pure component parameters
• Equation-of-state binary parameters
• Activity coefficient binary parameters
• Henry’s Law constants
• Electrolyte and binary pair parameters

Retrieving Pure Component Parameters
For many components, Aspen Plus retrieves pure component parameters
automatically from its pure component databanks. Use the Components
Specifications Databanks sheet to specify the databanks to search and their
search order. Parameters missing from the first selected databank will be
searched for in subsequent selected databanks.

To enter your own parameter values, use the Properties Parameters Pure
Component Scalar Input and T-Dependent Input sheets. See Entering Pure
Component Constants on page 8-11.

Since built-in pure component databanks reside with the simulation engine, the
available parameters do not appear automatically on any Parameters Pure
Component Input sheets.

User entered parameters override values retrieved from the Aspen Plus
databanks.

To generate a report of all available pure component parameters that will be
used in the simulation for the components and property methods specified:
1. From the Tools menu, click Retrieve Parameters Results.

2. On the Retrieve Parameter Results dialog box, click OK to generate a report.

3. On the next Retrieve Parameter Results dialog box, click OK to view the
results.

The Data Browser automatically opens at the Properties Parameters Results
folder.

4. In the left pane of the Data Browser, choose the Pure Component form from
the Results folder.
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The Parameters Results Pure Components form contains a sheet for scalar
parameters and a sheet for T-Dependent parameters. On each sheet you can
choose to view the actual parameter values, or the status. For the status of
parameter results, the following status is possible:

Status Indicates the parameter is

Available Available in the databank, entered on the Paramters Input sheet, estimated, or
regressed

Default A system default value

Missing Missing

In addition to retrieving parameter results with the method described above, you
can also generate a detailed parameter report in the Aspen Plus report file. For
details on this and other report options see Chapter 12.

Retrieving Equation-of-State Binary Parameters
For many component systems, binary parameters are available for these models:

Model Parameter name

Standard Redlich-Kwong-Soave RKSKIJ

Standard Peng-Robinson PRKIJ

Lee-Kesler-Plöcker LKPKIJ

BWR-Lee-Starling BWRKV, BWRKT

Hayden-O'Connell HOCETA

Aspen Plus retrieves any databank values and uses them automatically. Whether
you enter these parameters yourself or retrieve them from a databank, you can
view them from the appropriate Properties Parameters Binary Interaction Input
sheet.  Aspen Plus creates one form for each binary parameter.

If you do not want to retrieve built-in equation-of-state binary parameters,
remove the databank name from the Selected Databanks list on the Databanks
sheet of the Properties Parameters Binary Interaction form for your equation-of-
state model. Use the Input sheet to enter your own binary parameter values. For
more information see Entering Scalar Binary Parameters on page 8-16.
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Retrieving Activity Coefficient Binary Parameters
For many component pairs, binary parameters are available for the following
property methods for vapor-liquid applications:

Property method Parameter name

NRTL NRTL

NRTL-HOC NRTL

NRTL-RK NRTL

UNIQUAC UNIQ

UNIQ-HOC UNIQ

UNIQ-RK UNIQ

WILSON WILSON

WILS-HOC WILSON

WILS-GLR WILSON

WILS-LR WILSON

WILS-RK WILSON

For liquid-liquid applications, binary parameters are available for the following
property methods:

Property method Parameter name

NRTL NRTL

NRTL-HOC NRTL

NRTL-RK NRTL

UNIQUAC UNIQ

UNIQ-HOC UNIQ

UNIQ-RK UNIQ

AspenTech developed these parameters using data from the Dortmund
Databank. See Aspen Plus Physical Property Data for details.

Whenever you select these property methods, Aspen Plus retrieves these
parameters automatically and displays them on the Input sheet of the Properties
Parameters Binary Interaction forms. Aspen Plus creates a form for each binary
parameter.
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If you do not want to retrieve built-in binary parameters, remove the databank
name from the Selected Databanks list on the Databanks sheet of the Properties
Parameters Binary Interaction form. Use the Input sheet to enter your own
binary parameter values.

For more information, see Entering Temperature-Dependent Binary Parameters
on page 8-17.

For binary parameters retrieved from a databank, use Help to obtain information
about the quality of the parameters—for example, sum of squares error and
average and maximum deviations of the fit.

Retrieving Henry’s Law Constants
Henry's law constants are available for a large number of solutes in solvents. The
solvents are water and many organic components.

If you use an activity coefficient property method and define a set of Henry's
components, Aspen Plus retrieves the Henry's constants automatically and
displays them on the Input sheet of the Properties Parameters Binary
Interaction HENRY-1 form.

If you do not want to retrieve built-in Henry's law constants, remove both the
BINARY and HENRY databanks from the Selected Databanks list on the
Databanks sheet of the HENRY-1 form.

Retrieving Electrolyte Binary and Pair Parameters
Binary and pair parameters of the Electrolyte NRTL model are available for
many industrially important electrolyte systems.

Aspen Plus retrieves the binary parameters and displays them on the Properties
Parameters Binary Interaction forms. For pair parameters, Aspen Plus displays
them on the Properties Parameters Electrolyte Pair forms.

If you do not want to retrieve built-in parameters, remove the databank name
from the Selected Databanks list on the Databanks sheet of the applicable form.

See Aspen Plus Physical Property Data, Chapter 2, for details about electrolyte
systems, the sources of data used, and the application range.
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Entering Property Parameters

If any parameters required by your simulation are missing from the databanks, or
if you do not want to use databank values, you can:

• Enter any parameters or data directly.
• Estimate parameters using Property Estimation. For more information, see

Chapter 30.
• Regress parameters from experimental data using Data Regression. For more

information, see Chapter 31.

This section explains how to enter the following parameters directly:

• 
• Pure component constants
• Pure component correlation parameters
• Parameters for nonconventional components
• Scalar binary parameters
• Temperature-dependent binary parameters
• Binary parameters from Dechema
• Electrolyte pair parameters
• Ternary parameters

Forms for Entering Property Parameters
The table below shows where to enter the different types of property parameters:

Use the Input sheet of this Properties
Parameters form

To enter

Pure Component Scalar Scalar pure component parameters, such as critical temperature (TC) or molecular
weight (MW)

Pure Component T-Dependent Temperature-dependent pure component property correlation parameters, such as
PLXANT for the extended Antoine vapor pressure model

Pure Component Nonconventional Unary parameters for nonconventional components

Binary Interaction Scalar binary parameters, such as the RKSKIJ binary parameters
for the Redlich-Kwong-Soave equation-of-state model

Temperature-dependent binary parameters (that is, parameters
defined with more than one element) such as the
NRTL binary parameters or Henry's law constants

Electrolyte Pair Electrolyte-molecule and electrolyte-electrolyte pair parameters
required by the electrolyte NRTL model, such as the
GMELCC parameters

Continued
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Use the Input sheet of this Properties
Parameters form

To enter

Electrolyte Ternary Electrolyte ternary parameters required by the Pitzer model,
such as the cation1-cation2-common anion parameters
and anion1-anion2-common cation parameters (GMPTPS)

UNIFAC Group Area and volume parameters for the UNIFAC functional groups

UNIFAC Group Binary Scalar group-group interaction parameters for the original
UNIFAC model (GMUFB)

T-Dependent group-group interaction parameters for the
modified UNIFAC models, such as the Dortmund-modified
UNIFAC and the Lyngby-modified UNIFAC models

How to Enter Property Parameters
The general procedure for entering all property parameters is as follows. For
details on entering the specific types of parameter, see the appropriate sections
later in this chapter.

To enter property parameters:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the folder for the type of parameters you want to enter (Pure
Component, Binary Interaction, Electrolyte Pair, Electrolyte Ternary,
UNIFAC Group, or UNIFAC Group Binary). Descriptions for these parameter
types are in the above table.

Aspen Plus automatically creates parameter sets for any binary interaction,
electrolyte pair, and parameters required by the property methods specified
on the Properties Specifications form. The Object Manager for the appropriate
parameter type displays the IDs for these parameter sets.

4. On the Object Manager for the parameter type you choose, you can

• Enter parameters for an existing parameter set by selecting the
parameter and clicking Edit.
– or –

• Create a new parameter set. In the Object Manager, click New. If
prompted, select the appropriate parameter type and parameter name,
and click OK.

5. Use the Parameter input sheet to:

• Enter parameters that are not in the Aspen Plus databanks
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• Override defaults or databank values by entering parameter values
You can enter parameter values in any units. After you specify a parameter
name, Aspen Plus automatically fills in the default units.

If you change the units of measurement for the parameter after you enter the
parameter value, Aspen Plus does not convert the displayed value.

Tip   When defining non-databank components using the Components
Specifications Selection sheet, you can use the User Defined Components Wizard.
The wizard guides you through entering the basic pure component parameters
required.

For more detailed information on the User Defined Components Wizard, see
Chapter 6.

Entering Pure Component Constants
To enter pure component constants:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the Pure Component folder.

4. In the Parameters Pure Component Object Manager, you can create new
parameter IDs, or modify existing IDs.

5. To create a new parameter set, on the Object Manager click New.

6. In the New Pure Component Parameters dialog box, the default parameter
type is Scalar. Enter an ID or accept the default ID and click OK.

7. To modify an existing parameter ID, on the Object Manager select the name
of the parameter set, and click Edit.

8. On the Input sheet for pure component scalar parameters, define the matrix
of components and parameters for which you are entering data values, and
specify the appropriate units.
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Example of Entering Pure Component Constants

Enter critical temperature (TC) and critical pressure (PC) of 410.2 K and 40.7
atm for component C1. Enter critical pressure of 36.2 atm for component C2.

Entering Pure Component Correlation Parameters
To enter coefficients for temperature-dependent pure component property
correlations:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the Pure Component folder.

4. In the Parameters Pure Component Object Manager, you can create new
parameter IDs, or modify existing IDs.

5. To create a new parameter set, on the Object Manager click New.



Aspen Plus User Guide 8-13
Version 10.1-0

Chapter 8

The New Pure Component Parameters dialog box appears:

6. In the New Pure Component Parameters dialog box, select T-dependent
correlation, and choose the appropriate parameter name from the list.

7. Click OK.

8. To modify an existing parameter ID, on the Object Manager select the name
of the parameter set, and click Edit.

9. On the Input sheet, choose a component from the Component list. For the
chosen temperature dependent parameter, use this sheet to enter values for
all components for which you have parameters.

10. Specify the appropriate units and enter the coefficients of each parameter as
sequential elements. For a more detailed description of models and
parameters, see Aspen Plus Physical Property Methods and Models.

You cannot enter more than one set of values for the same parameter on the
same form.

Example for Entering Ideal Gas Heat Capacity Coefficients

For component CLP, enter the coefficients for the Ideal Gas Heat Capacity
Polynomial model (CPIG):

C
P 

IG  = –2001.2 + 358.9T – 0.515T2 + 4.41 x 10–4T3 –1.58 x 10–7 T4

CP

IG has units of J/kmol-K. T is in units of K.
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Entering Parameters for Nonconventional Components
To enter parameter values for nonconventional components:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the Pure Component folder.

4. In the Parameters Pure Component Object Manager, you can create new
parameter IDs, or modify existing IDs.

5. To create a new parameter set, on the Object Manager click New.
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The New Pure Component Parameters dialog box appears:

6. In the New Pure Component Parameters dialog box, select Nonconventional.

7. Enter an ID or accept the default ID, then click OK.

8. To modify an existing parameter ID, on the Object Manager select the name
of the parameter set, and click Edit.

9. On the Input sheet, choose a parameter from the Parameter list.

10. Enter components, parameters, and units.

When you use the general enthalpy and density models shown in this table
Aspen Plus requires at least the first element of the heat capacity polynomial
(HCGEN) and density polynomial (DENGEN), for each constituent of each
nonconventional component. The heat of formation (DHFGEN) is required
when reactions occur involving nonconventional components:

General Models

Property Model Attribute Requirements

ENTHALPY ENTHGEN GENANAL

DENSITY DNSTYGEN GENANAL
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Special Models for Coal and Coal-Derived Materials

Property Model Attribute Requirements

ENTHALPY HCOALGEN
HCJ1BOIE
HCOAL-R8
HBOIE-R8

ULTANAL, PROXANAL, SULFANAL
ULTANAL, PROXANAL, SULFANAL
ULTANAL, PROXANAL, SULFANAL
ULTANAL, PROXANAL, SULFANAL

DENSITY DCOALIGT
DCHARIGT

ULTANAL, SULFANAL
ULTANAL, SULFANAL

Alternatively, you can enter tabular data directly for enthalpy and density.
Polynomial TABPOLY models are not available for nonconventional
components.

Property Model

ENTHALPY ENTHLTAB

DENSITY DNSTYTAB

For more information on using tabular data and polynomial coefficients see
Using Tabular Data and Polynomial Coefficients on page 8-24.

Entering Scalar Binary Parameters
To enter scalar binary parameters:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the Binary Interaction folder to open the Object Manager containing the
binary parameter sets used by your specified property methods.

4. On the Object Manager, select the scalar parameter of interest and click Edit.

5. Define the ij matrix of components for which you are entering binary
parameter values.

6. Enter the parameter values.
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Example for Entering Redlich-Kwong-Soave Binary Parameters

Binary parameters for the Redlich-Kwong-Soave equation of state, RKSKIJ, are
symmetric (that is, kij = kji). Enter the following values for the binary parameters
in the three-component system C1-C2-C3:

Component Pair RKSKIJ

C1-C2 0.097

C1-C3 0

C2-C3 -0.018

Note   You will not see the RKSKIJ-1 parameter in the Binary Interaction
Object Manager unless you have previously chosen the RK-SOAVE property
method. (See Chapter 7 for specifying property methods.)

Entering Temperature-Dependent Binary Parameters
To enter temperature-dependent binary parameters:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the Binary Interaction folder to open the Object Manager containing the
binary parameter sets used by your specified property methods.
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4. On the Object Manager, select the temperature-dependent parameter of
interest (for example, NRTL-1) and click Edit.

5. On the Input sheet, enter component pairs in the Component i and
Component j boxes.

6. Specify the units for the binary parameters.

7. Enter the coefficients of the parameters as sequential elements for each
component pair.

Example for Entering NRTL Binary Parameters

The NRTL binary parameters aij and bij are asymmetric, that is, aij ≠ aji and bij ≠
bji. The binary parameter cij and dij are symmetric; eij and fij  default to zero. Enter
the following NRTL binary parameters for the components C1-C2. The units for
the binary parameters are in Kelvins.

a12 = 0

a21 = 0

b12 = -74.18

b21 = 270.8

c12 = 0.2982

Note   You will not see the NRTL-1 parameters in the Binary Interaction Object
Manager, unless you have previously chosen an NRTL-based property method.
(For information on specifying property methods, see Chapter 7.)
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Entering Binary Parameters from DECHEMA
The DECHEMA Chemistry Data Series contains a large number of binary
parameters for the Wilson, NRTL, and UNIQUAC models. These binary
parameters are not compatible with the form of the equations used in
Aspen Plus. However, you can enter them directly, without any conversion, using
the Dechema button on the Properties Parameters Binary Interaction Input
sheet for temperature dependent parameters.

To enter binary parameters from DECHEMA:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the Binary Interaction folder to open the Object Manager containing the
binary parameter sets used by your specified property methods.

4. On the Object Manager, select NRTL-1, WILSON-1, or UNIQ-1 and choose
Edit.

5. On the Input sheet, enter component pairs in the Component i and
Component j boxes.

6. With the appropriate component pair selected, click the Dechema button.

7. In the Dechema Binary Parameters dialog box, enter the binary parameter
values. You can also specify whether the parameters came from the VLE or
LLE collection.

8. Click OK.

Aspen Plus converts the binary parameters you enter and displays the
converted values on the Input sheet.

Aspen Plus databanks contain both parameters developed by Aspen
Technology, Inc. and those obtained from the DECHEMA Chemistry Data
Series (databank name = VLE-LIT). You will seldom need to enter binary
parameters from the DECHEMA Chemistry Data Series.

Example of Entering NRTL Binary Parameters from DECHEMA

Enter the following binary parameters for ethanol (i) and water (j), as reported in
the DECHEMA Chemistry Data Series, Vol. I, Part 1A, p. 129:

aij = -517.9603 cal/mol

aji = 1459.309 cal/mol

αij = 0.0878
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Estimating Binary Parameters for Activity Coefficient
Models

You can request the estimation of missing binary parameters for the Wilson,
NRTL, and UNIQUAC models, using the Properties Parameters Binary
Interaction form. For convenience, Aspen Plus provides this capability in
addition to the Property Constant Estimation System (PCES). For more
information about PCES, see Chapter 30.

To estimate binary parameters:
1. Go to the Properties Parameters Binary Interaction Object Manager.

2. Select the WILSON-1, NRTL-1 or UNIQ-1 binary parameter form of interest
and choose Edit.

3. On the Input sheet, check the Estimate All Missing Parameters by UNIFAC
check box.

Entering Electrolyte Pair Parameters
Use the Properties Parameters Electrolyte Pair form to enter values for
molecule-electrolyte and electrolyte-electrolyte pair parameters for the
Electrolyte NRTL model.

To enter electrolyte pair parameters:
1. From the Data menu, click Properties.
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2. In the left pane of the Data Browser, double-click the Parameters folder.

3. Click the Electrolyte Pair folder.

4. On the Electrolyte Pair Object Manager, select a parameter name, and click
Edit.

5. On the Input sheet, define the molecule-electrolyte or electrolyte-electrolyte
pairs for which you are entering values.

6. Enter the parameter values for the specified pairs.

Example of Entering Electrolyte NRTL Pair Parameters

Enter the following electrolyte NRTL pair parameters (GMELCC) for the brine
system:

τH2O,NaCl = 8.572

 τNaCl,H2O = -4.435

NaCl dissociates completely into Na+ and Cl-.
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Entering Ternary Parameters
Use the Properties Parameters Electrolyte Ternary form to enter values for the
Pitzer ternary parameters when using the Pitzer electrolyte activity coefficient
model.

For example, you can enter cation1-cation2-common anion parameters and
anion1-anion2-common cation parameters (GMPTPS).

To enter electrolyte pair parameters:
1. From the Data menu, click Properties.

1. In the left pane of the Data Browser, double-click the Parameters folder.

2. Click the Electrolyte Ternary folder.

3. In the Electrolyte Ternary Object Manager, you can create new parameter
IDs, or modify existing IDs.

4. To create a new parameter set, on the Object Manager click New.

5. In the Create New ID dialog box, enter an ID in the Enter ID box, or accept
the default ID.

6. Click OK.

7. To modify an existing parameter ID, on the Object Manager select the name
of the parameter set, and click Edit.

8. Select an electrolyte ternary parameter from the Parameter list.
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9. With Cation selected in the View list, enter the cation1-cation2-common anion
parameters by listing two cations, the common aion(s), and the respective
parameter values. Enter all cation1-cation2-common anion parameters with
the Cation view selected.

10. Select Anion from the View list.

11. Enter the anion1-anion2-common cation parameters by listing two anions, the
common cation(s), and the respective parameter values. With the Anion view
selected, continue to list all anion1-anion2-common cation parameters.

For more information on using the electrolyte features with Aspen Plus, see
Chapter 6.

Example for Entering Electrolyte Pitzer Ternary Parameters

Enter the following Pitzer ternary parameters (GMPTPS) for the NaCl/CaSO4
system:

  i     j   k   ψijk

Na+  Ca+2   Cl- -0.014
Na+  Ca+2 SO4-2 -0.023
 Cl- SO4-2  Na+ 0 .0014
 Cl- SO4-2  Ca+2    0.0

Cation view:
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Anion view:

Using Tabular Data and Polynomial
Coefficients

In addition to the standard Aspen Plus physical property methods and models, you
can represent some properties through:

• Direct use and interpolation of user-supplied tabular data
• Calculation from a general polynomial model

This section describes:

• Entering tabular data
• Entering polynomial coefficients for general polynomial model
• Adjusting reference states for tabular data and polynomials
• Adjusting tabular data or polynomials for the effect of pressure

This table shows the Tabpoly properties:

Property Model Form†

Density for non-conventional components Normal
Enthalpy for non-conventional components Normal
Enthalpy of fusion Normal

Continued
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Property Model Form

Enthalpy of sublimation Normal

Enthalpy of vaporization Normal

Henry's constant Logarithmic

Ideal gas enthalpy Normal

Ideal gas heat capacity Normal

Liquid diffusion coefficient Normal

Liquid enthalpy Normal

Liquid enthalpy departure Normal

Liquid entropy Normal

Liquid entropy departure Normal

Liquid fugacity coefficient for a component in a mixture Logarithmic

Liquid Gibbs free energy Normal

Liquid Gibbs free energy departure Normal

Liquid heat capacity Normal

Liquid-Liquid K-value Logarithmic

Liquid thermal conductivity Normal

Liquid viscosity Logarithmic

Liquid volume Normal

Pure component liquid fugacity coefficient Logarithmic

Pure component vapor fugacity coefficient Logarithmic

Solid enthalpy Normal

Solid enthalpy departure Normal

Solid entropy Normal

Solid entropy departure Normal

Solid fugacity coefficient Logarithmic

Solid Gibbs free energy Normal

Solid Gibbs free energy departure Normal

Solid heat capacity Normal

Solid thermal conductivity Normal

Solid vapor pressure Logarithmic

Solid volume Normal

Surface tension Normal

Vapor diffusion coefficient Normal

Continued
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Property Model Form

Vapor enthalpy Normal

Vapor enthalpy departure Normal

Vapor entropy Normal

Vapor entropy departure Normal

Vapor fugacity coefficient for a component in a mixture Logarithmic

Vapor Gibbs free energy Normal

Vapor Gibbs free energy departure Normal

Vapor heat capacity Normal

Vapor-Liquid K-value Logarithmic

Vapor pressure Logarithmic

Vapor thermal conductivity Normal

Vapor viscosity Normal

Vapor volume Normal

† If the model form is logarithmic, the tabular model uses the logarithmic transformation of the property
to interpolate and extrapolate. The polynomial model is the logarithmic form of the equation.

How Aspen Plus Uses Your Tabular Data and
Polynomial Coefficients

Aspen Plus calculates the property for the component, using the tabular data and
polynomial coefficients you enter. If you do not provide data for all components,
Aspen Plus uses the property models of the ideal property method (IDEAL), for
the components without data. For most properties, Aspen Plus calculates
mixture properties using mole fraction average ideal mixing.

Aspen Plus uses your tabular data directly—Aspen Plus does not fit a polynomial
equation to the data. When necessary, Aspen Plus uses a quadratic interpolation
method to determine the property value at a given temperature. You should
provide tabular data at small temperature intervals.

When the temperature is outside the lowest or highest temperature data that you
entered, Aspen Plus calculates the property by linear extrapolation. If the model
form is logarithmic, Aspen Plus uses the logarithmic transformation of the
property to interpolate and extrapolate. For polynomial models when
temperature is outside the lower and upper limits of the correlation, Aspen Plus
also calculates the property by linear extrapolation.
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If you enter Then

Enthalpy or heat capacity data You can use the Data Generation Options on the Specifications sheet
to generate entropy and Gibbs free energy.

Vapor enthalpy data Also enter ideal gas enthalpy data to ensure consistency.

Enthalpy, entropy, and Gibbs free energy Make sure they are consistent (G = H – TS).

To enter experimental data for use with Property Estimation or Data Regression,
use the Properties Data forms. For information on entering data for use in
estimation or regression, see Chapters 30 and 31.

Entering Tabular Data
To enter tabular data:
1. From the Data menu, click Properties.

2. From the left pane of the Data Browser, go to the Properties Advanced
Tabpoly Object Manager.

3. Click New to create a new object.

4. Enter an ID or accept the default ID, and then click OK.

5. On the Specifications sheet, choose the property for which you are entering
data in the Property list. You can enter data for only one property on each
Tabpoly form. Use as many forms as needed to enter your data.

6. In the For Property Method list, choose the property method for which the
Tabpoly property is to be used. Specify All to use the data for all property
methods in the simulation.

7. On the Data sheet, choose the component for which you have data, from the
Component list box.

8. Select data type tabular Data, then enter the tabular data (property versus
temperature) for the component.

You must enter the temperature-dependent tabular data in order of
ascending temperature points. Aspen Plus determines the units for the
temperature and the property data from the Units-Set you specify in the
Units list box on the Data Browser toolbar.

Example of Entering Vapor Pressure Data for Component CLP

This example assumes that the Units list box on the Data Browser toolbar is
referencing a new Units-Set defined with temperature units of C and pressure
units of mmHg.
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Enter the following tabular data:

Vapor pressure (mmHg) Temperature (C)

70 0

177 20

390 40

760 59.4

2358 100

8200 160
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Entering Polynomial Coefficients for the General
Polynomial Model

To enter polynomial coefficients for a general polynomial model:
1. From the Data menu, click Properties.

2. In the left pane of the Data Browser, double-click the Advanced folder.

3. Click the Tabpoly folder.

4. On the Tabpoly Object Manager, click New to create a new object.

5. Enter an ID or accept the default ID, and then click OK.

6. On the Specifications sheet, specify the property for which you are entering
polynomial coefficients in the Property list box. You can enter polynomial
coefficients for only one property on each form. Use as many forms as needed
to enter your coefficients.

7. In the For Property Method list box, choose the property method for which
the Tabpoly property is to be used. Specify All to use the data for all property
methods in the simulation.

8. On the Data sheet, choose the component for which you have coefficients,
from the Component list.

9. Select the data type: Polynomial Coefficient, then enter the general
polynomial coefficients for the selected component.

The polynomial model is of the form:
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or

See the Tabpoly Properties table on page 8-24 to determine whether the
property you want to enter uses the normal or logarithmic form.

The coefficients a2 through a8 default to zero. The lower temperature limit of
the correlation (Min. temperature) defaults to 0 K. The upper temperature
limit (Max. temperature) defaults to 1000 K. When the temperature is outside
the limits, Aspen Plus calculates the property by linear extrapolation.

The Units-Set you specify in the Units list box on the Data Browser toolbar
determines the units for the coefficient values. If a5, a6, a7, or a8 is non-zero,
Aspen Plus assumes absolute temperature units for all parameters.
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Adjusting Reference States for Tabular Data and
Polynomials

Aspen Plus can adjust the reference state of the enthalpy, entropy, and Gibbs
free energy data that you entered. To specify this:
1. On the Tabpoly Specifications sheet, deselect the Do Not Adjust Reference

State check box for your Tabular data or your Polynomial data.

2. Specify the basis (Mole or Mass) for your reference value and for the data, in
the Basis list box.

3. On the Reference Points sheet, select the component for which you want to
adjust the reference state, in the Component list box.

4. In the Reference Points boxes enter a reference Temperature and a reference
value for Enthalpy, Entropy, or Gibbs free energy.

5. If you want to enter reference values and have Aspen Plus generate entropy
and Gibbs free energy data from the enthalpy or heat capacity data that you
enter, you must enter reference values for two of the three properties. The
reference values are at the same temperature.

6. To use the Aspen Plus default reference state, do not enter any data on the
Reference Points sheet. However, you must supply these parameter values for
(or they must be available in the databanks):

• DHFORM, DGFORM, PLXANT
• DHVLWT (or DHVLDP)
The Aspen Plus thermodynamic reference state is the component’s
constituent elements in an ideal gas state at 25°C and 1 atm.

If a simulation has Then

No chemical reactions You can select the reference states arbitrarily.

Chemical reactions You must select reference states that include DHFORM
for all components undergoing reaction.

Equilibrium reactions You must select reference states that include DGFORM
for all components undergoing reaction.

Adjusting Tabular Data or Polynomials for the Effect of
Pressure

Aspen Plus adjusts vapor-liquid K-values, Gibbs free energies, and entropies for
the effect of pressure using the following relationships:



Aspen Plus User Guide 8-31
Version 10.1-0

Chapter 8






−=






−=






=

P

P
nRTPTgPTg

P

P
nRPTsPTs

PTK
P

P
PTK

ref
ref

ref
ref

ref
ref

1),(),(

1),(),(

),(),(

Where:

P ref = Reference pressure (the pressure at which the data was
obtained.)

P = Actual system pressure

T = Temperature

K(T,Pref) = K-value at T and the reference pressure

s(T,Pref) = Entropy at T and the reference pressure

g(T,Pref) = Gibbs free energy at T and the reference pressure

Requesting Pressure Adjustment

To request pressure adjustment:
1. Go to the Reference Points sheet of the Tabpoly form.

2. Choose the component for which you want to specify the reference pressure,
from the Component list box.

3. In the Pressure box, enter the reference pressure.

For K-values, Aspen Plus makes no adjustment for the pressure effect, unless
you supply the reference pressure. You should always enter a reference pressure,
unless the pressure range of the simulation matches that of the data.

If you use the Aspen Plus thermodynamic reference state for entropy and Gibbs
free energy, an adjustment for the pressure effect is always performed using Pref

= 101325 N/m2. If you do not use the Aspen Plus reference state, Aspen Plus
adjusts for the pressure effect only if you supply the reference pressure.
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Using Property Data Packages

This section describes the Property Data Packages available in Aspen Plus.

You can use these data packages to model many important industrial processes.
Theses data packages have been developed using publicly available literature
data. They will be updated as new data becomes available. For your particular
process, you may need to add or remove components and provide additional
interaction parameters.

• Ammonia-water
• Ethylene
• Flue gas treatment
• Formaldehyde-methanol-water
• Glycol dehydration of natural gas
• Mineral solubilities in water using the Pitzer model
• Gas treating processes using amines: MDEA, DEA, DGA, AMP and MEA
• Methyl-amine

Using a Data Package
To use a data package:
1. From the File menu, click Import.

2. In the Import dialog box, click the Look In Favorites button.

3. From the list of favorite folders, select Data Packages.

4. Select the data package that you want and click Open.

Ammonia-Water Data Package
Use this data package for ammonia and water. This data package uses the
Electrolyte NRTL model.

This data package is applicable from 5 - 250 C with pressure up to 100 bar.
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Ethylene Data Package
Use this data package to model Ethylene processes. This data package uses the
SR-POLAR equation of state model because of its versatility in representing both
hydrocarbons and polar components such as water.

Pure component parameters were evaluated using experimental data for vapor
pressure, liquid heat capacity and liquid density.

Binary parameters were evaluated from experimental VLE and LLE data.

This data package should provide a very good starting point for building the
Ethylene process model. Simulation results can be improved by regressing
missing binary parameters or updating the existing parameters with the new
ones based on latest experimental data.

Using Electrolyte Amines Data Packages
Aspen Plus provides special data packages (inserts) for amines systems:  MDEA,
DEA, MEA, DGA and AMP (2-amino-2-methyl-1-propanol, C4H11NO-1).

These packages allow you to accurately model amines gas treating processes.

These inserts use the electrolyte capabilities, but also take into consideration
kinetic reactions of CO2 in the liquid phase. The reaction kinetics can be used in
either the RADFRAC or RATEFRAC distillation models. This modeling approach
is fundamentally sound and has been validated through industrial applications.
These data packages give more accurate results than those that do not consider
kinetics reactions.

The following table shows the range of applications:

System Insert Name Temperature Amines Concentration

AMP KEAMP 40-100 C 2.47 to 4.44 molal

MDEA KEMDEA 25 - 120 C Up to 50 weight %

DEA KEDEA Up to 140 C Up to 30 weight %

DGA KEDGA Up to 100 C Up to 65 weight %

MEA KEMEA Up to 120 C Up to 50 weight %
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Using an Amines Data Package

To use an amines insert:
1. From the File menu, click Import.

2. In the Import dialog box, click the Look In Favorites button.

3. From the list of favorite folders, select Data Packages.

4. Select the desired data package and click Open.

5. In the Parameter Values dialog box, enter the component IDs you are using
for the amine, CO2 and H2S by first selecting the Parameter then clicking the
Edit Value button.

Make sure that you use the true component approach on the Properties
Specifications Global sheet or the Block Options Properties sheet of a unit
operation model. This is required for all the amines data packages that use
kinetic reactions.

6. If you are using RADFRAC or RATEFRAC, specify one of the following
Reaction IDs on the Reactions form for the model:

Reaction ID For modeling When using this data package

 MDEA-CO2 CO2 absorption KEMDEA

 MDEA-ACID CO2/H2S absorption KEMDEA

 MEA-CO2 CO2 absorption KEMEA

 MEA-ACID CO2/H2S absorption KEMEA

 DEA-CO2 CO2 absorption KEDEA

 DEA-ACID CO2/H2S  absorption KEDEA

Flue Gas Treatment Data Package
Use this data package to model flue-gas purification process. The data package
uses the Electrolyte NRTL model.

The apparent components are:

H2O, N2, O2, CO2, CO, SO2, SO3, NO, NO2, HCL, HF, HNO3, HNO2, H2SO4,
H2SEO3, HGCL2, HG2CL2, HG, C, SE, SEO2, HG(OH)2, CASO4*2W, CAF2,
CAO, CA(OH)2

The Henry-components are:

CO CO2 SO2 HCL O2 N2 NO HG

Valid temperature range from: 273.15 K to  373.15 K
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Formaldehyde-Methanol-Water Data Package
Use this data package to model Formaldehyde-Methanol-Water system. This
system is highly non-ideal because the three components form multiple
complexes.

The vapor phase is modeled using the Hayden-O'Connell model. This model
properly accounts for the strong association in the vapor phase.

The liquid phase is modeled using the UNIFAC model with special group-group
interaction parameters determined from regression of experimental data. The
complexes such as methylene glycol and hemiformal are formed using the
Chemistry reactions.

Valid temperature range: 0 to 100 C

Mole fraction of Formaldehyde: 0 - 0.6

Pressure: 0 - 3 bar

Glycol Dehydration Data Package
Use this data package to model natural gas dehydration processes using glycols
(Ethylene glycol (EG): C2H6O2, Di-ethylene glycol  (DEG): C4H10O3, or Tri-
ethylene glycol (TEG): C6H14O4)

The data package uses the Schwartzentruber-Renon equation-of-state (SR-
POLAR) model.

The components included in this package are:

EG, DEG, TEG, WATER,  METHANOL, CO2, N2, H2S, METHANE, ETHANE,
PROPANE, N-BUTANE, N-PENTANE, N-HEXANE, N-HEPTANE, N-OCTANE,
N-NONANE, N-DECANE, BENZENE, TOLUENE, O-XYLENE, ISO-BUTANE,
ISO-PENTANE, ETHYLENE, PROPYLENE

The experimental data used to develop the data package cover very wide range of
temperatures and pressures.

Pitzer Data Packages
There are four data packages for calculating mineral solubilities in water using
the Pitzer electrolyte model:
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1. PITZ_1: for prediction of mineral solubilities in water at 25 C. The system is
Na-K-Mg-Ca-H-Cl-SO4-OH-HCO3-CO3-CO2-H2O.

2. PITZ_2: for prediction of mineral solubilities in water for systems:

Na-K-Ca-Ba-Cl-H2O and Na-Ca-Cl-SO4-H2O.

The apparent components are:

H2O, NACL,  KCL, CACL2,  ACL2*4H2O, CACL2*6H2O, BACL2,
ACL2*2H2O

Valid temperature range: up to 200 C

Valid pressure: equilibrium to 1 atmosphere

3. PITZ_3: for Na-K-Ca-Cl-SO4-NO3-H2O system

The apparent components are:

H2O, NA2SO4, NACL, NA2SO4*10H2O, NA2CA(SO4)2,
NA4CA(SO4)3*2H2O, NANO3, K2SO4, KCL, K2CA(SO4)2*H2O, KNO3,
CACL2, CASO4, CACL2, CACL2*6H2O, CASO4*2H2O, 2(CASO4)**H2O,
CACL2*4H2O,CA(NO3)2, CA(NO3)2*4H2O

Valid temperature range: 0 - 250 C

4. PITZ_4 for H2O- NaCl- Na2SO4- KCl- K2SO4- CaCl2- CaSO4- MgCl2-
MgSO4- CaCl2*6H2O- MgCl2*6H2O- MgCl2*8H2O- MgCl2*12H2O-
KMgCl3*6H2O- Mg2CaCl6*12H2O- Na2SO4*10H2O- MgSO4*6H2O-
MgSO4*7H2O- K2Mg(SO4)2*6H2O

Valid temperature range : -60 to 25 C

Methyl-amine Data Package
Use this data package to model methyl-amines process. This system is highly
non-ideal. The components included are: ammonia, water, methanol, methyl-
amine, dimethylamine and trimethyl-amine.

The property model used for representing VLE data is the SR-POLAR equation of
state. High pressure VLE data for NH3-H2O and Methanol-Water were used in
the regression. This model is particularly good for high pressure column. The
results may be improved by adding additional binary parameters for the EOS
based on new VLE data.

Pure component parameters were evaluated using liquid Density, Heat Capacity
and Vapor pressure data.
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Using Other Electrolyte Data Packages
The following tables show electrolyte data packages that are available in the
ELECINS sub-directory.

This table shows electrolyte data packages, available in the ELECINS sub-
directory, that use the ELECNRTL property method:

Property Method ELECNRTL

Filename Electrolyte System

h2ohc.bkp H2O - HCL (as Henry-comps)

ehno3.bkp H2O - HNO3

enaoh.bkp H2O - NAOH

eso4br.bkp H2O - H2SO4 - HBR

ehbr.bkp H2O - HBR

ehi.bkp H2O - HI

eh2so4.bkp H2O - H2SO4

ehclmg.bkp H2O - HCL - MGCL2

enaohs.bkp H2O - NAOH - SO2

eso4cl.bkp H2O - H2SO4 - HCL

ecauts.bkp H2O - NAOH - NACL - NA2SO4 -NA2SO4.10H2O -NA2SO4.NAOH - NA2SO4.NAOH.NACL

ekoh.bkp H2O - KOH

ecaust.bkp H2O - NAOH - NACL - NA2SO4

ehcl.bkp H2O - HCL (as solvent)

ehclle.bkp H2O - HCL (as solvent, recommend for LLE)

edea.bkp H2O - DEA - H2S - CO2

ehotde.bkp H2O - DEA - K2CO3 - H2S - CO2

emea.bkp H2O - MEA - H2S - CO2

ecl2.bkp H2O - CL2 - HCL

enh3co.bkp H2O - NH3 - CO2

enh3so.bkp H2O - NH3 - SO2

esouro.bkp H2O - NH3 - H2S - CO2 - NAOH

edga.bkp H2O - DGA - H2S - CO2

enh3h2.bkp H2O - NH3 - H2S

eamp.bkp H2O - AMP - H2S - CO2

ehotca.bkp H2O - K2CO3 - CO2

Continued



8-38 Aspen Plus User Guide
Version 10.1

Physical
Property
Parameters
and Data

Filename Electrolyte System

enh3hc.bkp H2O - NH3 - HCN

ebrine.bkp H2O - CO2 - H2S - NACL

ebrinx.bkp H2O - CO2 - H2S - NACL  (extended Temperature range)

eclscr.bkp H2O - CL2 - CO2 - HCL - NAOH - NACL - NA2CO3

ekohx.bkp H2O - KOH (high concentration)

ehf.bkp H2O - HF

ehotcb.bkp H2O - K2CO3 - CO2 - KHCO3

emdea.bkp H2O - MDEA - CO2 - H2S

enh3po.bkp H2O - NH3 - H3PO4 - H2S

esour.bkp H2O - NH3 - H2S - CO2

This table shows electrolyte data packages, available in the ELECINS sub-
directory, that use the SYSOP15M property method:

Property Method SYSOP15M

Filename Electrolyte System

brine.bkp H2O - CO2 - H2S - NACL

caust.bkp H2O - NAOH - NACL - NA2SO4

causts.bkp H2O - NAOH - NACL - NA2SO4 -NA2SO4.10H2O -NA2SO4.NAOH - NA2SO4.NAOH.NACL

dea.bkp H2O - DEA - H2S - CO2

dga.bkp H2O - DGA - H2S - CO2

h2ohbr.bkp H2O - HBR

h2ohcl.bkp H2O - HCL

h2ohf.bkp H2O - HF

h2ohi.bkp H2O - HI

hotca.bkp H2O - K2CO3 - CO2

hotcb.bkp H2O - K2CO3 - CO2 - KHCO3

hotdea.bkp H2O - DEA - K2CO3 - H2S - CO2

mcl2.bkp H2O - CL2

mdea.bkp H2O - MDEA - H2S - CO2

mea.bkp H2O - MEA - H2S - CO2

mh2so4.bkp H2O - H2SO4

mhbr.bkp H2O - HBR

Continued
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Filename Electrolyte System

mhcl.bkp H2O - HCL

mhcl1.bkp H2O - HCL

mhclmg.bkp H2O - HCL - MGCL2

mhf.bkp H2O - HF

mhf2.bkp H2O - HF (to 100% HF)

mhno3.bkp H2O - HNO3

mnaoh.bkp H2O - NAOH

mnaoh1.bkp H2O - NAOH

mso4br.bkp H2O - H2SO4 - HBR

mso4cl.bkp H2O - H2SO4 - HCL

naohso.bkp H2O - NAOH - SO2

nh3co2.bkp H2O - NH3 - CO2

nh3h2s.bkp H2O - NH3 - H2S

nh3hcn.bkp H2O - HCN

nh3po4.bkp H2O - NH3 - H2S - H3PO4

nh3so2.bkp H2O - NH3 - SO2

sour.bkp H2O - NH3 - H2S - CO2

souroh.bkp H2O - NH3 - H2S - CO2 - NAOH

This table shows electrolyte data packages, available in the ELECINS sub-
directory, that use the SYSOP16 property method:

Property Method SYSOP16

Filename Electrolyte System

pnh3co.bkp H2O - NH3 - CO2

pnh3h2.bkp H2O - NH3

pnh3so.bkp H2O - NH3 - SO2

psour.bkp H2O - NH3 - H2S - CO2

❖     ❖     ❖     ❖ 
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9 Specifying Streams

Streams connect unit operation blocks in a flowsheet and carry material and
energy flow from one block to another. Streams can be:

• Feed streams to the flowsheet
• Internal (interconnecting) streams within the flowsheet
• Product streams from the flowsheet
• Pseudo-product streams representing flows internal to a block

Use the Stream forms to enter data for the feed streams and to give initial
estimates for any internal streams that are tear (recycle) streams.

This chapter includes information about:

• Specifying material streams
• Analyzing stream properties interactively
• Specifying stream classes and substreams
• About particle size distributions
• Accessing stream libraries
• Specifying work streams
• Specifying heat streams
• Using pseudoproduct streams

Specifying Material Streams

For all material process feed streams, you must specify:

• Flow rate
• Composition
• Thermodynamic condition

You can provide initial guesses of these variables for tear (recycle) streams.
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Entering Specifications for Streams
To enter specifications for a stream:
1. Double-click the stream in the flowsheet.

– or –

From the Data menu, click Streams. In the Streams Object Manager, select
the stream and click Edit.

2. On the Specifications sheet, specify any two of three State Variables to set the
thermodynamic condition of your stream. For example, you could specify
temperature and pressure, or temperature and vapor fraction. For the
available options, see Possible Stream Thermodynamic Condition
Specifications on page 9-3.

3. Specify the stream composition using flow rates or flow fractions or flow
concentrations of each component in the Composition frame. See Entering
Stream Composition on page 9-4.

Perform Steps 4 through 6 only if the stream contains solids substreams.

4. If you want to specify solids substreams, use the Substream field to display
different substreams.

5. Specify temperature, pressure, and composition for each solids substream.
You must specify the same pressure for each substream.

6. If any components in the stream have component attributes, or any
substreams have particle size distributions, you must specify values for them.
For more information, see Specifying Particle Size Distribution

To specify the particle size distribution for a solid substream:
1. Double-click the stream in the flowsheet

– or –

From the Data menu, click Streams. In the Streams Object Manager select
the stream and click the Edit button.

2. On the Stream Input form, click the Stream PSD sheet.

3. Enter the weight fractions for the particle sizes. The total should be 1.0.

For more information about particle size distribution in Aspen Plus, and how
to define your own particle size ranges, see Defining New Substreams on page
9 - 20.

7. Specifying Component Attribute Values on page 9-7 and Specifying Particle
Size Distribution on page9-7.
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Possible Stream Thermodynamic Condition
Specifications

This table describes possible stream thermodynamic condition specifications:

Phases Free Water State Specification Stream Properties Calculated by

Vapor only No Temperature, Pressure Vapor phase thermodynamic
calculations

Solid only No Temperature, Pressure Solid phase thermodynamic
calculations

Liquid only No Temperature, Pressure Liquid phase thermodynamic
calculations

Liquid-freewater Yes Temperature, Pressure Liquid phase thermodynamic
calculations with free water
considered

Vapor-liquid or vapor-
liquid-liquid

No Temperature, Pressure TP flash

Vapor-liquid or vapor-
liquid-liquid

No Temperature, Molar
Vapor fraction

TV flash

Vapor-liquid or vapor-
liquid-liquid

No Pressure, Molar Vapor
fraction

PV flash

Vapor-liquid-freewater Yes Temperature, Pressure TP flash with free water
considered

Vapor-liquid-freewater Yes Temperature, Molar
Vapor fraction

TV flash with free water
considered

Vapor-liquid-freewater Yes Pressure, Molar Vapor
fraction

PV flash with free water
considered

Aspen Plus calculates unspecified temperature, pressure, or molar vapor
fraction, as well as the stream enthalpy, entropy, and density.

Mass-Balance-Only Calculations

If you are performing a mass-balance-only simulation:
1. Double-click the stream in the flowsheet

– or –

From the Data menu, click Streams. In the Streams Object Manager select
the stream and click the Edit button.
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2. Ensure the Calculate Stream Properties check box on the Stream Input Flash
Options sheet is clear.

3. Enter values for two of the following: Temperature, Pressure, and Vapor
fraction as State Variables on the Stream Input Specifications sheet.

For more information on checking mass balances around blocks, click here. See
Chapter 5.

Aspen Plus does not calculate stream properties in mass-balance-only
simulations.

Entering Stream Composition
You can specify the stream composition in terms of component flows, fractions, or
concentrations.

For Enter values on this basis

Component flows or fractions† Mole, mass, or standard liquid volume

Concentrations Mole or mass

†
For nonconventional components, you can enter only mass flows and fractions.

If you specify component fractions, you must specify the total mole, mass, or
standard liquid volume flow. Component fractions must sum to 1.0 or 100.0.

You can enter both component flows and total flow. Aspen Plus normalizes the
component flows to match the total flow.

If you specify component concentrations, you must enter a component ID for the
solvent and the total flow. The stream must be single phase. You can select
Vapor-Only or Liquid-Only in the Valid Phases list on the Stream Input Flash
Options sheet, and temperature and pressure as State Variables on the Stream
Input Specifications sheet. Or you can specify the stream at its bubble point
(Vapor Fraction is 0).

If you use the standard liquid volume basis for component flows, fractions or
total stream flow, you need to enter the standard liquid volume of a component
(VLSTD) on the Properties Parameters Pure Component Input form. For more
information, see Chapter 8. The values for VLSTD in the databanks are from the
API databook. The standard liquid volume is not used to calculate densities in
Aspen Plus.



Aspen Plus User Guide 9-5
Version 10.1-0

Chapter 9

The standard liquid volume flow (Stdvol-Flow) can be very different from the
volumetric flow rate of a stream. The standard liquid volume is defined at
approximately 60ºF and 1 atm. The difference increases as the conditions diverge
from 60ºF and 1 atm. If the stream is a vapor or has a significant amount of
vapor, the volumetric flow rate of a stream is extremely different from the
standard liquid volume flow. You can enter standard vapor volume flows as mole-
flow. Select the appropriate units (for example scfm).

To report the Std.liq. Volume Flow or Std.liq.Volume Fraction in the stream
report, select the appropriate options on the Setup ReportOptions Stream sheet.
You can also calculate these Property Sets:

• VLSTDMX (standard liquid volume of a mixture)
• VLSTD (standard liquid volume of a component)

StdVol-Flow and StdVol-Frac are accessible variables that can be used in design
specifications and Fortran blocks.

The Stream Input Specifications sheet displays the total of the component flows,
fractions, or concentrations entered for the stream. Use this value to check your
input.

Example for Specifying a Process Feed Stream

A process feed stream (FEED) contains 2 lbmol/hr of hydrogen (H2) and
3 lbmol/hr of methane (CH4), at 100F and 14.7 psia. Aspen Plus performs a
two-phase flash to determine stream properties and phase conditions.



9-6 Aspen Plus User Manual
Version 10.1-0

Specifying
Streams

Example for Specifying a Stream with Two Liquid Phases

A process feed stream contains 5 lbmol/hr of C1, 5 lbmol/hr of C2, and
10 lbmol/hr of H2O. Two partially miscible liquid phases are anticipated. The
vapor-liquid-liquid equilibrium is treated rigorously. Aspen Plus performs a
three-phase flash to determine phase condition.
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Specifying Particle Size Distribution

To specify the particle size distribution for a solid substream:
2. Double-click the stream in the flowsheet

– or –

From the Data menu, click Streams. In the Streams Object Manager select
the stream and click the Edit button.

4. On the Stream Input form, click the Stream PSD sheet.

5. Enter the weight fractions for the particle sizes. The total should be 1.0.

For more information about particle size distribution in Aspen Plus, and how
to define your own particle size ranges, see Defining New Substreams on page
9 - 20.

Specifying Component Attribute Values
Use the Stream Input Component Attr. sheet to specify values of component
attributes. You must specify values for each attribute defined on the Components
Attr-Comps selection sheet or Properties Advanced NC-Props PropertyMethods
sheet (see  Chapter 5).

To specify values of component attributes for a stream:
1. On the Stream Input form, click the Component Attr. sheet.

2. Enter values for each attribute listed.

Example of Specifying the GENANAL Component Attributes for a
Nonconventional Substream

On the Stream Input Component Attr. sheet, the elements of the GENANAL
component attribute are specified for the NCPSD substream.
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On the Properties Advanced NC-Props form, the GENANAL component attribute
is defined as required for the selected Nonconventional Component Property
models.
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About Stream Property Analysis

You can calculate and display stream properties interactively as you create your
simulation model. You do not have to complete the flowsheet definition or input
specifications first.

For example, you can flash a feed stream as soon as you define it, to check your
property model. As you develop a flowsheet model interactively, you can check
the phase behavior of intermediate streams to help you determine feasible
specifications.

The following table shows the types of stream analysis you can perform:

Stream Analysis Types

Type Description

Point Stream properties for the total stream and each of the phases present.
Properties include temperature, pressure, phase fractions, flow rate,
heat capacity, density, and transport properties.

Component Flow Component flow rates for the total stream and each of the phases present.
Mole, mass, and standard volume fractions are available.

Composition Component fractions for the total stream and each of the phases present.
Mole, mass, and standard volume fractions are available.
Partial pressure is also available.

Petroleum Point properties, plus API gravity, specific gravity, Watson K factor, and
kinematic viscosity

Dist-Curve† Petroleum distillation curves (TBP, D86, D160, and vacuum)

Bubble/Dew†† Bubble point temperature and dew point temperature versus pressure curves

PV Curve†† Vapor fraction versus pressure curves at stream temperature

TV Curve†† Vapor fraction versus temperature curves at stream pressure

PT-Envelope†† Pressure-temperature envelope curves For more information, see Generating PT-Envelopes
on page 9-13.

†
Plots can be generated from this analysis.

††
These analyses automatically display plots of the curves.

You can also perform stream property analyses using property tables. The
Analysis commands automate many of the steps required to generate a property
table, and define built-in plots appropriate for the analysis.

Use the Property Table forms when you need flexibility not provided by the
Analysis commands.
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Analyzing Stream Properties

To calculate and display stream properties interactively:
1. Make sure your Setup, Components, and Properties specifications are

complete.

2. Make sure the specifications or results for the stream you want to analyze are
complete. Either the Stream Input Specifications sheet for the stream must
be complete or the stream must have results that were calculated in the
current session.

3. Click the stream to select it.

4. On the Tools menu, point to Analysis, then Stream, then choose the type of
calculation you want to perform.

This command will be inactive if the conditions in Steps 1 and 2 are not
satisfied.

5. Make any selections and specifications you want in the appropriate dialog
box.

If you selected Bubble/Dew or PV curve, you must specify a pressure range. If
you selected TV curve, you must specify a temperature range.

6. Click Go.

7. Print or view results and plots that appear when calculations are complete.

8. Close the form and plot when you are sure you are finished with the results.
The results are not saved. You must redo the calculations if you want to
look at them again, once you close the form.

Example of Generating Point Analysis of a Stream

Stream 1 is a 50-50 mixture of ethane and heptane.
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Example of Generating PV Curve

Stream 1 is a 50-50 mixture of ethane and heptane.
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Stream Temperature is 270 F.
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Generating PT-Envelopes

Pressure-temperature (PT) envelopes are generated by following curves of constant
vapor fraction, through the critical point and back out the complementary branch.
(The complementary branch for Vapor fraction = 0.75 is 0.25.) These plots are
parametric, consisting of one curve for each vapor fraction and its complementary
branch.

You can generate PT-Envelopes from any property method, except electrolyte
property methods. But PT-Envelopes generated from activity coefficient-based
and other non-equation-of-state property methods will not pass through the
critical point. Instead there will be separate curves for each vapor fraction and its
complementary branch.

For more information about PT-envelopes, see Chapter 27.

Creating a PT-Envelope from a Stream
To create a PT-Envelope from a stream:
1. Make sure your Setup, Components, and Properties specifications are

complete.

2. Make sure the specifications or results for the stream you want to analyze are
complete. Either the Stream Input Specifications sheet for the stream must
be complete or the stream must have results that were calculated in the
current session.

3. Click the stream to select it.

4. From the Tools menu, point to Analysis, then Stream. This command will be
inactive if the conditions in Steps 1 and 2 are not satisfied.

5. Choose PT-Envelope.

6. Select the vapor fraction branches.

The Dew/Bubble point curves correspond to vapor fractions of 0 and 1.0.
Additional vapor fractions can be specified. The complementary vapor fraction
is automatically calculated for each vapor fraction specified.

7. Click Go to create the PT-Envelope table and plot. For more information on
customizing the plot, see Chapter 13.
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8. Close the form and plot when you are sure you are finished with the results.
The results are not saved. You must redo the calculations if you want to
look at them again, once you close the form. To save the input and the table of
results, click the Save as Form button before closing the PT-Envelope
Analysis form and the a form with the input and results will be saved in the
Property Analysis folder.

Example of Creating a PT Envelope

For example, a table of values and a plot for a P-T envelope is generated for
vapor fractions of 0.0, 0.2, 0.4, 0.6, 0.8, and 1.0 for a 50-50 mixture of ethane and
heptane in stream 2.
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About Stream Classes

You do not need to specify stream classes if:

• Your simulation does not involve solids
• The only solids are electrolytes salts defined using Chemistry forms or the

Electrolytes Expert System

Stream classes define structures for simulation streams when solids are present.
Solids are:

• Carried in substreams
• Characterized as either conventional or nonconventional components. For

more information, see Chapter 6.
• May have a particle size distribution (PSD)

A stream class defines a stream structure in terms of:

• Number of substreams
• Type of component carried in each substream (conventional or

nonconventional)
• Whether the substream carries particle size distribution information

Use this Setup StreamClass
sheet

To

Flowsheet Assign a new Stream Class to a flowsheet section,
and define the substreams in a stream class

Streams Assign streams to a stream class,
and define the substreams in a stream class

Use the Stream Input PSD sheet to define the particle size distribution weight
fractions for a substream.

The following sections describe how you can:For help on using Stream Classes,
click one of the following topics:

• Use predefined stream classes
• Create your own stream classes
• Assign stream classes globally
• Assign stream classes to flowsheet sections
• Assign stream classes to individual streams



Aspen Plus User Guide 9-17
Version 10.1-0

Chapter 9

Using Predefined Stream Classes
These stream classes are predefined in Aspen Plus and should be sufficient for
most applications:

Use this stream class When

CONVEN The simulation does not involve solids, or the only solids are electrolytes salts.

MIXCISLD Conventional solids are present, but there is no particle size distribution.

MIXNC Nonconventional solids are present, but there is no particle size distribution.

MIXCINC Both conventional and nonconventional solids are present, but there is no particle size
distribution.

MIXCIPSD Conventional solids are present, with a particle size distribution.

MIXNCPSD Nonconventional solids are present, with a particle size distribution.

All unit operation models (except Extract) can handle stream classes with solid
substreams:

These models Require

All except Mixer and ClChng All inlet and outlet streams belonging to the same stream class

CFuge, Filter, SWash, CCD At least one solids substream

Crusher, Screen, FabFl, Cyclone,
VScrub, ESP, HyCyc

At least one solids substream with a particle size distribution

Crystallizer At least one solids substream with a particle size distribution, if particle sizes are
calculated

You can also assign stream classes globally, or to flowsheet sections or individual
streams.

Creating or Modifying Stream Classes
You need to create or modify a stream class to:

• Add new substreams to a stream class
• Create a stream class with PSD attributes for both CISOLID and NC type

substreams
• Use two or more particle size distribution definitions in a simulation

The number and types of substreams, together with their attributes, define a
stream class. A stream class can have any number of substreams but the first
substream for each Stream Class must be of type MIXED.
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Each substream:

• Must be assigned a type (MIXED, CISOLID, or NC)
• Can be assigned a particle size distribution (PSD)

You can create a new stream class by listing all its substreams, or you can modify
the substreams in an existing stream class. You cannot modify a MIXED type
substream.

Use the Define StreamClass button on the Flowsheet or Streams sheet of the
Setup StreamClass form, to assign a new stream class to the structure of a
stream by listing its constituent substreams or to modify the substreams in an
existing stream class.

To create or modify a substream:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser, select the Setup Stream Class form.

3. On the Flowsheet sheet, click the Define StreamClass button.

4. On the Define StreamClass dialog box, select <new> from the list in the
Stream Class field.

–or–

Use the list in the StreamClass box to select the name of the Stream Class to
be modified.

5. Select the substreams to include in the stream class from the Available
substreams list and use the right arrow button to move them into the
Selected substreams list. The left arrow can be used to remove substreams
from the Selected substream list. The double arrow can be used to move all of
the substreams in a list at one time.

6. Use the up and down arrow buttons to rearrange the list. Note that the first
substream must be of type MIXED.

7. When finished, on the Define StreamClass dialog box, click Close.

Specifying a Global Stream Class
You can specify the default stream class globallyfor all streams in a simulation.
You can override the global default for a flowsheet section or for an individual
stream.

The default stream class is the stream class for flowsheet section GLOBAL. The
default stream class is established by the Application Type you choose when
creating a new run. You can change this default on the Setup Specifications
Global sheet.
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To specify the default stream class using the Setup Specifications Global sheet:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser, click the Specifications folder.

3. On the Global sheet, select a stream class in the Stream Class field.

Specifying Stream Classes for Flowsheet Sections
When using more than one stream class in a simulation, divide the flowsheet into
sections and specify a stream class for each section.

A stream that connects blocks from different sections keeps the stream class of
the section where it originates.

For example, a flowsheet might have an upstream section that involves solids
and a downstream section that does not (after all solids have been removed). You
can assign stream class MIXCISLD to the upstream section and CONVEN to the
downstream section.

You must use the Mixer and ClChng models to transition between flowsheet
sections that are assigned different stream classes.

To assign a Stream Class to a flowsheet section:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the StreamClass form.

3. Click the Flowsheet sheet.

4. Use the list to select the name of the Stream Class associated with a given
flowsheet section.

Specifying Stream Classes for Individual Streams
You can override the global or section stream class by specifying a stream class
for one or more individual streams. To do this, use the StreamClass Streams
sheet.

To assign streams to a Stream Class:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, click the StreamClass form.

3. Click the Streams sheet.
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4. Select the streams to include in the stream class from the Available streams
list and use the right arrow button to move them into the Selected streams
list.

Use the left arrow button to remove streams from the stream class. Use the
double arrow button to move all of the streams in a list at one time.

Streams that are left in the Available streams list will have the stream class
for the flowsheet section (from the Flowsheet sheet).

Defining New Substreams

You need to define a new substream if:

• A simulation has more than one CISOLID or NC substream.
• You want to add a new PSD definition to a substream.

To create a new substream:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser, select the Substreams folder.

3. On the Substreams sheet, enter a new substream name in the Substream
field.

4. In the Type field, select a substream type.

Use this type For

MIXED Conventional components that reach vapor-liquid-solid phase equilibrium

CISOLID
(conventional inert solids)

Conventional components that appear in the solid phase but do not  participate in phase
equilibrium

NC (nonconventional) Nonconventional components

5. If the substream type is CISOLID or NC, select a PSD in the Attribute field if
desired.

6. Assign the substream to one or more stream classes. For more information,
see Creating or Modifying Stream Classes on page 9-17.
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About Particle Size Distributions

In Aspen Plus, particle size distribution is represented by the weight fractions per
particle size interval, given the number of intervals and the size range for each
interval.

The built-in Aspen Plus particle size distribution has 10 predefined size
intervals. You can modify the built-in particle size distribution by changing the
number of intervals or the size ranges for the intervals.

In some simulations you may want to have two or more particle size distribution
definitions, with different size ranges. This is useful if different sections of your
flowsheet have very different particle sizes.

For help on particle size distributions, click one of these topics:

• Specifying particle size distribution
• Changing particle size distribution intervals
• Creating new particle size distributions

Use the Setup Substreams form to create particle size distribution for a
substream. You can specify the number of discrete intervals into which the
particle size distribution is to be divided, and to specify the upper and lower size
limits for each interval.

Changing Particle Size Distribution Intervals
To specify the number of intervals for the particle size distribution:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser window, select the Substreams folder.

3. In the Substreams Object Manager on the PSD sheet, select the name of the
attribute set you want to modify and click Edit.

4. Type the number of intervals for the particle size distribution. You can also
select the size units.

5. Type the limits for the particle size in all of the intervals.

The Lower limit is automatically updated with the value of the Upper limit
for the previous interval and vice versa.
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Creating New Particle Size Distributions
You can create one or more new particle size distribution attributes, in addition
to the built-in PSD:
1. From the Data menu, click Setup.

2. In the left pane of the Data Browser, select the Substreams folder.

3. In the Substreams Object Manager, on the PSD sheet, click New.

4. In the Create New ID dialog box, enter a PSD ID or accept the default ID.

5. On the PSD sheet, in the Interval Number column, enter the number of
discrete intervals in the particle size distribution. You can also select the size
units.

6. In the Lower Limit column, specify the lower size limit for each interval.

Aspen Plus fills in the corresponding upper limit value automatically.

7. In the Upper Limit column, specify the upper size limit for the last interval.

8. You must assign the new PSD attribute to a substream class, on the Setup
Substreams Substreams sheet.

For more information on defining a new substream, see Defining New
Substreams on page 9-20 and Creating or Modifying Stream Classes on page 9 - 17.

Specifying Heat Streams

In Aspen Plus, material and energy balance reports consider only energy flows
represented by streams. Any duty or power not represented by a heat or work stream
appears on the report as an imbalance.

Any model that Can have

Calculates heat duty Outlet heat streams

Allows duty input specifications Inlet heat streams

You can use an inlet heat stream to supply a heat duty specification to a unit
operation block:

To display the Specifications sheet for the heat stream:
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1. Double-click the stream in the flowsheet to select it.

– or –

From the Data menu, click Streams. In the Streams Object Manager, select
the stream and click Edit.

2. On the Specifications sheet, specify the heat duty.

If the heat duty is Then heat is

Positive Supplied to the block

Negative Removed from the block

3. In the destination block of the heat stream, leave the corresponding duty field
blank. If you specify both an inlet heat stream and the heat duty in the
destination block, the block specification is used.

Specifying Work Streams

In Aspen Plus, material and energy balance reports consider only energy flows
represented by streams. Any duty or power not represented by a heat or work stream
appears on the report as an imbalance.

Any model that Can have

Allows power input specifications Inlet work streams

Calculates power requirements Outlet work streams

To use an inlet work stream to supply a power specification to a pump or
compressor block:
1. Double-click the stream in the flowsheet to select it.

– or –

From the Data menu, click Streams. In the Streams Object Manager, select
the stream and click Edit.

2. On the Specifications sheet, specify the power.

If the power is Then work is

Negative Supplied to a block

Positive Removed from a block
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3. In the destination block of the work stream, leave the corresponding power
field blank. If you specify both an inlet work stream and the power in the
destination block, the block specification is used.

Example of a Heat Stream to the Reboiler of a Column

Stream QREB supplies 1 MMBtu/hr of external heat duty to a RADFRAC block.
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Using PseudoProduct Streams
You can define pseudoproduct streams to represent column internal flows,
compositions, and thermodynamic conditions for these unit operations models:

• PetroFrac
• RadFrac
• MultiFrac
• RateFrac
• Extract
• CCD

You can use pseudoproduct streams to represent interconnecting streams in:

• PetroFrac
• MultiFrac
• RateFrac

The stream report includes pseudoproduct streams. Mass balance calculations for
the block do not include the flow rates associated with pseudo-streams. The
presence of pseudo-streams does not affect block results.

Pseudoproduct streams from one block may be an inlet to another block. Using a
pseudo-stream as a block inlet results in an imbalance in the overall flowsheet
material and energy balance report.

To define a pseudoproduct stream:
1. When creating the stream select a port labeled Pseudo Streams.

2. For each block that is connected to a pseudostream, complete the
PseudoStream sheet(s) when specifying the block.

About Stream Libraries

Stream libraries store information about the composition and condition of material
streams. If a stream is defined in a library, you can retrieve information from the
library instead of entering data on the Streams forms. You must specify the stream
library in the Run Settings dialog box before you run the simulation.

Use stream libraries to:

• Retrieve feed streams used frequently
• Transfer stream information from a previous simulation
• Initialize tear streams
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A stream library can contain multiple cases. Each case usually represents the
results of a previous simulation. When you retrieve results from a stream library,
you specify the:

• Case(s) from which to retrieve results
• Streams in the current run that the stream library will fill in
• Substreams and components to be retrieved
• Component name translation, when the component IDs in the simulation are

different from those in the library

For more information on creating stream libraries, see Chapter 35.

Accessing Stream Libraries
To specify that a run retrieves information about stream composition and
conditions from a stream library:
1. From the Data menu, point to Flowsheeting Options, then Stream Library.

2. On the Specifications sheet, specify the case for the streams you want to
retrieve.

3. If you are retrieving information for a single stream, enter the name of the
stream from the library in the Stream Name in Library box.

4. If you specified the Stream Name in Library in Step 3, use the Include
Stream option and enter the name of the stream in the current simulation.
Otherwise select one of these options in the Streams field:

Option To retrieve all streams
with matching

All Streams Stream ID

Include Streams ID from a list you specify

5. In the Substreams and Components fields, specify the substreams and
components you want to retrieve from the streams library.

– or –

Retrieve all substreams and components by leaving the fields blank.

6. In the State Variables field, specify the stream state variables that you want
to retrieve from the stream library.

7. In the Component Mapping for Current Case section of the form, specify the
mapping between the component ID in the current simulation and the
component ID in the stream library. In the column on the left, enter the
component ID from the current simulation. In the column on the right, enter
the corresponding component IDs in the stream library.
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– or –

On the Defaults sheet, define a default component mapping. Aspen Plus uses
this mapping as the default for all cases.

8. Repeat Steps 2 through 8 for each case.

❖     ❖     ❖     ❖ 
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10 Unit Operation Models

The unit operation models are used to represent actual pieces of equipment, such
as distillation columns or heat exchangers, commonly found in processing plants.
To run a flowsheet simulation you must specify at least one unit operation model.

You choose unit operation models for flowsheet blocks when you define your
simulation flowsheet (see Chapter 4).

Aspen Plus has a wide range of unit operation models to choose from. This
chapter explains how to:

• Select the right unit operation model
• Enter model specifications
• Override global specifications at the block level
• Request heating/cooling curve calculations

Choosing the Right Unit Operation Model

This chapter provides a brief description of each model. For more detailed information,
see the Aspen Plus reference manual Unit Operation Models.

Select appropriate unit operation models from the following table:
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Unit Operation Models

Type Model Description

Mixers/Splitters Mixer
FSplit
SSplit

Stream mixer
Stream splitter
Substream splitter

Separators Flash2
Flash3
Decanter
Sep
Sep2

Two-outlet flash
Three-outlet flash
Liquid-liquid decanter
Multi outlet component separator
Two-outlet component separator

Heat Exchangers Heater
HeatX
MheatX
HxFlux
Hetran †

Aerotran †

HTRIIST

Heater/cooler
Two-stream heat exchanger
Multistream heat exchanger
Interface to BJAC Shell & Tube heat exchanger program
Interface to BJAC air cooled heat exchanger program
Interface to the Aspen Aerotran program
Interface to the IST program

Columns DSTWU
Distl
RadFrac
Extract
MultiFrac
SCFrac
PetroFrac
RateFrac †

BatchFrac†

Shortcut distillation design
Shortcut distillation rating
Rigorous distillation
Rigorous liquid-liquid extractor
Rigorous distillation for complex columns
Shortcut distillation for petroleum
Rigorous distillation for petroleum
Rate-based distillation
Rigorous batch distillation

Reactors RStoic
RYield
REquil
RGibbs
RCSTR
RPlug
RBatch

Stoichiometric reactor
Yield reactor
Equilibrium reactor
Equilibrium reactor
Continuous-stirred tank reactor
Plug flow reactor
Batch reactor

Pressure Changers Pump
Compr
MCompr
Pipeline
Pipe
Valve

Pump/hydraulic turbine
Compressor/turbine
Multistage compressor/turbine
Multi segment pipeline pressure drop
Single segment pipeline pressure drop
Rigorous valve pressure drop

Continued
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Unit Operation Models (continued)

Type Model Description

Manipulators Mult
Dupl
ClChng

Stream multiplier
Stream duplicator
Stream class changer

Solids Crystallizer
Crusher
Screen
FabFl
Cyclone
VScrub
ESP
HyCyc
CFuge
Filter
SWash
CCD

Mixed suspension mixed product removal crystallizer
Solids crusher
Solids separator
Fabric filter
Cyclone separator
Venturi scrubber
Electrostatic precipitator
Hydrocyclone
Centrifuge filter
Rotary vacuum filter
Single-stage solids washer
Counter-current decanter

User models User
User2

User-supplied unit operation model
User-supplied unit operation model

† RateFrac, BatchFrac, Hetran, and Aerotran require a separate license and can be used only by
customers who have purchased the right to use them through specific license agreements with Aspen
Technology, Inc.

Mixers and Splitters

This section describes the models that can be used to mix or split flowsheet
streams.

The Mixer unit operation model combines streams. FSplit and SSplit combine
feed streams and then split the resulting stream, based on your specifications.

Mixer
Mixer combines material streams (or heat streams or work streams) into one
outlet stream. If material streams are mixed, you can use an optional water
decant stream to decant free water from the outlet. You can specify an outlet
pressure or pressure drop for material streams. The mixer model determines the
combined outlet stream temperature and phase condition by performing an
adiabatic phase equilibrium flash calculation on the composite feed streams.
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Mixer can be used to model mixing tees, or other types of stream mixing
operations.

FSplit
FSplit combines material streams (or heat streams or work streams) and divides
the resulting stream into two or more outlet streams. All outlets have the same
composition and properties.

Use FSplit to model flow splitters and purges or vents. You must provide
specifications for all but one outlet stream. FSplit calculates the flowrate of the
unspecified stream.

SSplit
SSplit combines material streams and divides the resulting stream into two or
more outlet streams. SSplit allows specification of streams with various
substreams.

You must specify the splits of each substream, for all but one outlet stream.
SSplit calculates the flowrate of each substream in the unspecified outlet stream.
For more information about substreams, see Chapter 9.

For example, you can use SSplit to perfectly separate a stream containing both
liquid and solid phases into two streams each containing only one pure phase.
You can also use SSplit to model other solid stream splitters, bleed valves, purges
or vents.

Separators

The Separator Blocks, Sep and Sep2, combine feed streams and then split the
resulting stream, based on your specifications. When the details of the separation
are unknown or unimportant, you can use Sep and Sep2 instead of rigorous
separation models (such as distillation or absorption models) to save computational
time.

The flash models, Flash2 and Flash3, determine the thermal and phase
conditions of a mixture with one or more inlet streams. You can generate heating
or cooling curve tables for these models.
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The flash models represent single stage separators such as knock-out drums.
They perform a phase equilibrium flash calculation based on your specifications.
Adiabatic, isothermal and isobaric flashes, and dew or bubble points, are among
the calculations these models perform.

In general, to fix the thermodynamic condition of inlet streams, you must specify
a combination of any two of:

• Temperature
• Pressure
• Heat duty
• Molar vapor fraction

This table shows you what to set the molar vapor fraction as:

To Determine Set the Molar Vapor Fraction

The dew point of a mixture 1

The bubble point of a mixture 0

The combination of heat duty and molar vapor fraction is not allowed in the flash
models.

Flash2
Flash2 performs rigorous 2 (vapor-liquid) or 3 (vapor-liquid-liquid) phase
equilibrium calculations. Flash2 produces one vapor outlet stream, one liquid
outlet stream, and an optional water decant stream.

You can use Flash2 to model flashes, evaporators, knock-out drums, and any
other single-stage separators, with sufficient vapor disengagement space.
Optionally, you can specify a percentage of the liquid phase to be entrained in the
vapor stream.

Flash3
Flash3 performs rigorous 3 phase vapor-liquid-liquid equilibrium calculations, to
produce one vapor outlet stream and two liquid outlet streams.

You can use Flash3 to model any single-stage separator with sufficient vapor-
liquid disengagement space as well as two liquid phase settling space. You can
specify entrainment of each liquid phase in the vapor stream.
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The vapor outlet stream can have a flow rate of zero for a decanter with no vapor-
liquid disengagement. If you do not know whether there is a vapor phase, use the
Flash3 model instead of the Decanter model.

Decanter
Decanter models knock-out drums, decanters, and other single-stage separators
with sufficient residence time for separation of two liquid phases but without a
vapor phase.

Decanter determines the thermal and phase conditions of a mixture with one or
more inlet streams, at the specified temperature or heat duty.

Decanter can calculate liquid-liquid distribution coefficients from:

• Physical property method
• User supplied distribution correlation
• User supplied Fortran subroutine

For information about writing Fortran subroutines, see Aspen Plus User Models.

Since the Decanter model assumes implicitly that there is no vapor phase
formation, use Flash3 if you suspect any vapor phase formation.

Sep
Sep combines inlet streams and separates  the resulting stream into two or more
streams, according to splits you specify for each component. You can specify the
splits for each component in each substream.

You can use the Sep model to represent component separation operations such as
a distillation column when fractionation achieved or desired by the column is
known but the details of the column energy balance are unknown or
unimportant.
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Sep2
Sep2 combines inlet streams and separates the resulting stream into two outlet
streams. Sep2 is similar to Sep, but offers a wider variety of specifications, such
as component purity or recovery. These specifications make it even easier to
represent component separation operations such as a distillation column when
fractionation achieved or desired by the column is known but the details of the
separation are unknown or unimportant.

Heat Exchangers

All heat exchangers determine the thermal and phase conditions of a mixture with
one or more inlet streams. The heat exchanger models simulate the performance of
heaters or two or multi stream heat exchangers. You can generate heating or
cooling curve tables for all models described in this section.

Heater
Heater performs these types of single phase or multiphase calculations:

• Bubble or dew point calculations
• Add or remove any amount of user specified heat duty
• Match degrees of superheating or subcooling
• Determine heating or cooling duty required to achieve a certain vapor fraction

Heater produces one outlet stream, with an optional water decant stream. The
heat duty specification may be provided by a heat stream from another block.

You can use Heater to model:

• Heaters or coolers (one side of a heat exchanger)
• Valves when you know the pressure drop
• Pumps and compressors whenever you do not need work-related results

You can also use Heater to set or change the thermodynamic condition of a
stream.



10-8 Aspen Plus User Guide
Version 10.1-0

Unit Operation
Models

HeatX
HeatX can perform shortcut or detailed rating calculations for most types of
two-stream heat exchangers. The main difference between the two calculation
methods is the procedure for the calculation of the overall heat transfer
coefficient.

The shortcut method always uses a user specified (or default) value for the
overall heat transfer coefficient.

The detailed method uses rigorous heat transfer correlations for film coefficients
and combines the resistances due to shell and tube side films with the wall
resistance to calculate the overall heat transfer coefficient. You need to know the
geometry to use the detailed method.

You must specify the hot and cold inlet streams and one of these performance
specifications for your heat exchanger:

• Outlet temperature or temperature change of the hot or cold stream
• Molar vapor fraction of the hot or cold stream
• Degree of superheating (subcooling) of cold (hot) stream
• Heat exchanger duty
• Surface heat transfer area
• Temperature approach at the hot or cold stream outlet

Shortcut Method for HeatX

For the shortcut method you may specify a pressure drop for each side of the heat
exchanger. The HeatX model determines the outlet stream conditions based on
heat and material balances and uses a constant value for the heat transfer
coefficient to estimate the surface area requirement. You may also provide phase
specific heat transfer coefficients.

Detailed Method for HeatX

HeatX can also perform detailed rating calculations by modeling a wide variety of
shell and tube heat exchanger types rigorously, including:

• Countercurrent and co-current
• Segmental baffle TEMA E, F, G, H, J, and X shells
• Rod baffle TEMA E and F shells
• Bare and low-finned tubes

HeatX can perform a full zone analysis with heat transfer and pressure drop
estimation for single and two-phase streams. For rigorous heat transfer and
pressure drop calculations, you must supply the exchanger geometry.
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HeatX has correlations to estimate sensible heat, nucleate boiling, and
condensation film coefficients.

HeatX cannot:

• Perform design calculations (use Hetran or Aerotran)
• Perform mechanical vibration analysis
• Estimate fouling factors
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Example of Specification for a Shell and Tube Heat Exchanger

Use the detailed calculation type to rate the performance of countercurrent shell
and tube heat exchanger, where the hot fluid is on the shell side.

Specify the shell TEMA type, diameter, and orientation.



Aspen Plus User Guide 10-11
Version 10.1-0

Chapter 10

Specify tube side data.

Specify baffle type, spacing and dimensions:
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Specify the shell and tube side nozzle diameters:

MHeatX
MHeatX represents heat transfer between multiple hot and cold streams, as in
an LNG exchanger. It can also model two-stream heat exchangers. You can
decant free water from any outlet stream. An MHeatX block is divided into
multiple heaters connected by heat streams. This configuration usually leads to
faster flowsheet convergence.

MHeatX does not use or calculate heat transfer coefficients, but it can calculate
the overall UA for the exchanger and perform a detailed zone analysis.

HxFlux
HxFlux is used to perform heat transfer calculations between a heat sink and a
heat source, using convective heat transfer.  The driving force for the convective
heat transfer is calculated as a function of log-mean temperature difference or
LMTD.

You can specify variables among the inlet and outlet stream temperatures, duty,
heat transfer coefficient, and heat transfer area. HxFlux calculates the unknown
variable and determines the log mean temperature differences, using either the
rigorous or the approximate method.
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Hetran
Hetran is the interface to the Aspen Hetran program for designing and
simulating shell and tube heat exchangers. Use Hetran to simulate shell and
tube heat exchangers with a wide variety of configurations.

To use Hetran:
1. Place the block in the flowsheet.

2. Connect inlet and outlet streams.

3. Specify the name of the B-JAC input file for that exchanger and a few
optional parameters.

Information related to the heat exchanger configuration and geometry are
entered through the Hetran program interface. The exchanger specification is
then saved in the Hetran input file format.

You do not have to enter information about the exchanger's physical
characteristics for the blocks or through input language. That information is
retrieved from the B-JAC input file that you specify.

Aerotran
Aerotran is the interface to the Aspen Aerotran program for designing and
simulating air-cooled heat exchangers.

Aerotran can be used to simulate air-cooled heat exchangers with a wide variety
of configurations. It can also be used to model economizers and the convection
section of fired heaters.

To use Aerotran:
1. Place the block in the flowsheet.

2. Connect the inlet and outlet streams.

3. Specify the name of the B-JAC input file for that exchanger and a few
optional parameters.
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Information related to the air cooler configuration and geometry are entered
through the Aerotran program interface. The air cooler specification is saved in
the Aerotran input file format. You do not have to enter information about the air
cooler's physical characteristics. That information is retrieved from the B-JAC
input file that you specify.

HTRIIST
HTRIIST is the interface to the IST program from the Heat Transfer Research
Institute (HTRI) for designing and simulating shell and tube heat exchangers.
Use HTRIIST to simulate shell and tube heat exchangers with a wide variety of
configurations.

To use HTRIIST:
1. Place the block in the flowsheet.

2. Connect inlet and outlet streams.

3. Specify the name of the IST input file for that exchanger and a few optional
parameters.

Information related to the heat exchanger configuration and geometry are
entered through the IST program interface. The exchanger specification is then
saved in the IST input file format.

You do not have to enter information about the exchanger's physical
characteristics for the blocks or through input language. That information is
retrieved from the IST input file that you specify.

Columns

The models for shortcut distillation are DSTWU, Distl, and SCFrac.

DSTWU and Distl:

• Are for single columns
• Can perform free-water calculations in the condenser
• Allow you to use water decant streams to decant free water from the

condenser

SCFrac performs shortcut distillation calculations for petroleum refining units,
such as crude units and vacuum towers.
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Aspen Plus provides four rigorous multistage separation models:

Model Purpose

RadFrac General vapor-liquid multistage separation

MultiFrac General systems of interlinked multistage distillation units

PetroFrac Petroleum refining fractionation units

RateFrac Rate-based non-equilibrium separation

Extract is a rigorous model for simulating liquid-liquid extractors. It is
appropriate only for rating calculations.

DSTWU
DSTWU performs a Winn-Underwood-Gilliland shortcut design calculation for a
single-feed, two-product distillation column, with a partial or total condenser. For
the specified recovery of the light and heavy key components, DSTWU estimates
the minimum for either:

• Reflux ratio
• Number of theoretical stages

DSTWU estimates one of the following requirements:

• Reflux ratio given the number of theoretical stages
• Number of theoretical stages given the reflux ratio

DSTWU also estimates:

• Optimum feed stage location
• Condenser and reboiler duties

DSTWU can produce tables and plots of reflux ratio versus number of stages.

Distl
Distl is a shortcut multicomponent distillation rating model. This model uses the
Edmister approach to separate an inlet stream into two products. You must
specify:

• Number of theoretical stages
• Reflux ratio
• Overhead product rate

Distl estimates the condenser and reboiler duties. You can specify a partial or a
total condenser.
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SCFrac
SCFrac models petroleum refining towers, such as crude units and vacuum
towers. SCFrac performs shortcut distillation calculations for columns with a
single feed, one optional stripping steam stream, and any number of products.

SCFrac models an n-product refining tower with n–1 sections.

Based on your product specifications and fractionation indices, SCFrac estimates:

• Product composition and flows
• Number of stages per section
• Heating or cooling duty for each section

SCFrac does not handle solids.

RadFrac
RadFrac is a rigorous model for simulating all types of multistage vapor-liquid
fractionation operations. In addition to ordinary distillation, it can simulate:

• Absorption
• Reboiled absorption
• Stripping
• Reboiled stripping
• Extractive and azeotropic distillation

RadFrac is suitable for:

• Three-phase systems
• Narrow-boiling and wide-boiling systems
• Systems exhibiting strong liquid phase nonideality

RadFrac can detect and handle a free-water phase or other second liquid phase
anywhere in the column. You can decant free water from the condenser.

RadFrac can handle solids on every stage.

RadFrac can model columns where chemical reactions are occurring. Reactions
can have fixed conversions, or they can be:

• Equilibrium
• Rate-controlled
• Electrolytic

RadFrac can model columns where two liquid phases exist and different chemical
reactions occur in the two liquid phases. RadFrac can also model salt
precipitation.

RadFrac can operate in rating mode or design mode.
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Rating Mode

In rating mode RadFrac calculates:

• Temperature
• Flow rate
• Mole fraction profiles

These profiles are based on specified column parameters, such as reflux ratio,
product rates, and heat duties.

All rating mode flow specifications can be in mole, mass, or standard liquid
volume units.

You can specify component or stage efficiencies.

RadFrac accepts both Murphree and vaporization efficiencies. You can
manipulate Murphree efficiencies to match plant performance.

Design Mode

In design mode, you can specify temperatures, flow rates, purities, recoveries, or
stream properties anywhere in the column. Examples of stream properties are
volume flow and viscosity. You can specify all flow, flow ratio, composition, and
recovery specifications in mole, mass, or standard liquid volume units.

RadFrac has extensive capabilities for sizing and rating trays and packings. You
can choose from several common tray types, and random and structured
packings.

Example of Specifying a Reactive 3-phase Distillation Column

The following example shows the specifications for a reactive 3-phase distillation
column without a bottoms product and a reflux ratio of 45.  The column has 18
equilibrium stages and a total condenser and a kettle reboiler.



10-18 Aspen Plus User Guide
Version 10.1-0

Unit Operation
Models

All stages from the condenser (stage 1) through stage 18 are checked for presence
of an aqueous second liquid phase.

A liquid decanter is specified on equilibrium stage 10 which returns 30% of total
liquid flow.
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The reactions occur only in the reboiler. The reaction rate and stoichiometry are
referenced from a Reaction ID defined in the Reactions folder.

The total liquid holdup (reaction volume) is 1 m3.
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MultiFrac
MultiFrac is a rigorous model for simulating general systems of interlinked
multistage fractionation units. MultiFrac models a complex configuration
consisting of:

• Any number of columns, each with any number of stages
• Any number of connections between columns or within columns
• Arbitrary flow splitting and mixing of connecting streams

MultiFrac can handle operations with:

• Side strippers
• Pumparounds
• Bypasses
• External heat exchangers
• Single-stage flashes
• Feed furnaces

Typical MultiFrac applications include:

• Heat-integrated columns, such as Petlyuk towers
• Air separation column systems
• Absorber/stripper combinations
• Ethylene plant primary fractionators

You can also use MultiFrac for petroleum refining fractionation units, such as
atmospheric crude units and vacuum units. But for these applications PetroFrac
is more convenient to use. Use MultiFrac only when the configuration is beyond
the capabilities of PetroFrac.
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MultiFrac can detect a free-water phase in the condenser or anywhere in the
column. It can decant the free-water phase on any stage.

Although MultiFrac assumes equilibrium stage calculations, you can specify
either Murphree or vaporization efficiencies. You can use MultiFrac for sizing
and rating trays and packings. MultiFrac can model both random and structured
packings.

PetroFrac
PetroFrac is a rigorous model designed for simulating complex vapor-liquid
fractionation operations in the petroleum refining industry. Typical operations
include:

• Preflash tower
• Atmospheric crude unit
• Vacuum unit
• FCC main fractionator
• Delayed coker main fractionator
• Vacuum lube fractionator

You can also use PetroFrac to model the primary fractionator in the quench
section of an ethylene plant.

PetroFrac can model the feed furnace together with the fractionation towers and
strippers in an integrated fashion. With this feature, you can easily analyze the
effect of furnace operating parameters on tower performance.

PetroFrac can detect a free-water phase in the condenser or anywhere in the
column. It can decant the free-water phase on any stage.

Although PetroFrac assumes equilibrium stage calculations, you can specify
either Murphree or vaporization efficiencies.

You can use PetroFrac to size and rate columns consisting of trays and/or
packings. PetroFrac can model both random and structured packings.

Example of Specifying an Atmospheric Crude Oil Tower

This example illustrates the specifications for an atmospheric crude oil tower
consisting of 25 equilibrium stages (including a total condenser) in the main
column, 2 pumparounds, and three side strippers. The top distillate rate is set at
19,000 BPD.



10-22 Aspen Plus User Guide
Version 10.1-0

Unit Operation
Models

The column feed passes through a furnace which operates at 3.2 atm and the
overflash stream is specified to be 4% of the column feed by volume.

The first pumparound rate is 7,205 BPD and is a partial stream drawn from
stage 3 and is returned to stage 2 at 90 C.
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The first sidestripper has 2 equilibrium stages and strips light ends from the
7,200 BPD of Kerosene product stream which is drawn from stage of the main
column. The stripped vapors are returned to main column on stage 8. The
reboiler duty is 1.2 MMkcal/hr.

The main column is to be sized based on 2-pass Koch Flexitray trays on stages 2
through 21.
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RateFrac
RateFrac is a rate-based model for non-equilibrium separation. It simulates
actual tray and packed columns, rather than idealized representations.

RateFrac:

• Explicitly accounts for the interphase mass and heat transfer processes.
• Simulates single and interlinked columns involving vapor-liquid fractionation

operations such as absorption, distillation, and stripping.

Use RateFrac for

• Systems with both a vapor and a liquid phase. RateFrac can detect a
free-water phase only in the condenser.

• Nonreactive systems
• Reactive systems
• Electrolyte systems

RateFrac does not use empirical factors, such as efficiencies and the Height
Equivalent of a Theoretical Plate (HETP). RateFrac treats separation as a mass
and heat transfer rate process, instead of an equilibrium process. The degree of
separation achieved between the contacting phases depends on the extent of
mass and heat transfer between phases. The transfer rates between phases are
strongly affected by the extent to which the phases are not in equilibrium.
RateFrac assumes that thermodynamic equilibrium prevails only at the
vapor-liquid interface separating the contacting phases.
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Batch Distillation - BatchFrac
BatchFrac is the unit operation model for batch distillation. It is a a rigorous
model for simulating multistage batch distillation columns.

BatchFrac uses a robust and efficient algorithm to solve the unsteady-state heat
and material balance equations that describe the behavior of batch distillation
processes. Rigorous heat balances, material balances, and phase equilibrium
relationships are applied at each stage.

BatchFrac can handle a wide variety of batch distillation problems, including
these systems:

• Narrow-boiling
• Wide-boiling
• Highly non-ideal
• Three-phase
• Reactive

BatchFrac can detect the presence of a free-water phase in the condenser, or of
any second liquid phase anywhere in the column. BatchFrac has complete
flexibility in handling interstage decanters.

Use BatchFrac to simulate batch distillation columns with equilibrium-controlled
reactions or rate-controlled reactions. These reactions can occur on any stage,
including the reboiler and condenser.

BatchFrac assumes:

• Equilibrium stages are used. (However, you can specify vaporization
efficiencies.)

• There is constant liquid holdup and no vapor holdup.
• Column hydraulics are not modeled.

Extract
Extract is a rigorous model for simulating liquid-liquid extractors. It is
appropriate only for rating calculations.

Extract can have multiple feeds, heater/coolers, and sidestreams. To calculate
distribution coefficients, use one of the following:

• An activity coefficient model
• An equation of state capable of representing two liquid phases
• A built-in temperature-dependent polynomial
• A Fortran subroutine

Extract accepts specifications for component or stage efficiencies.



10-26 Aspen Plus User Guide
Version 10.1-0

Unit Operation
Models

Reactors

Chemical reactions occur under diverse conditions in many different types of
equipment.

Aspen Plus provides seven models for chemical reactor simulations:

Model Purpose

RStoic Conversion reactor with known stoichiometry

RYield Yield reactor with known product yields

REquil Two-phase chemical equilibrium reactor (stoichiometric)

RGibbs Multiphase chemical equilibrium reactor (non-stoichiometric)

RCSTR Continuous stirred tank reactor with known kinetics

RPlug Plug flow reactor with known kinetics

RBatch Batch or semi-batch reactor with known kinetics

RStoic, RYield, RGibbs, and RCSTR can have any number of material feed
streams, which are mixed internally. Heats of reaction are not required for any
reactor model. Aspen Plus calculates heats of reaction using heats of formation.

For RCSTR, RPlug, and RBatch, you must provide reaction kinetics information
using:

• The built-in power law model
• The built-in generalized Langmuir-Hinschelwood-Hougen-Watson (LHHW)

model
• A user-written Fortran subroutine (For more information, see Aspen Plus

User Models)

RStoic
RStoic models a reactor when:

• Reaction kinetics are unknown or unimportant.
• Stoichiometry is known.
• You can specify the extent of reaction or conversion.

Rstoic can handle reactions that occur independently in a series of reactors. It
can also perform product selectivity and heat of reaction calculations.
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RYield
RYield models a reactor by specifying reaction yields of each component. This
model is useful when:

• Reaction stoichiometry and kinetics are unknown.
• Yield distribution data or correlations are available.

REquil
REquil models reactors when some or all reactions reach equilibrium. REquil can
calculate single-phase chemical equilibrium, or simultaneous phase and chemical
equilibria. REquil calculates equilibrium by solving stoichiometric chemical and
phase equilibrium equations.

RGibbs
RGibbs models single-phase chemical equilibrium, or simultaneous phase and
chemical equilibria. You must specify the reactor temperature and pressure, or
pressure and enthalpy. RGibbs minimizes Gibbs free energy, subject to atom
balance constraints. This model does not require reaction stoichiometry. RGibbs
can determine phase equilibrium without chemical reaction, particularly for
multiple liquid phases. Any number of liquid phases are allowed.

You can model solids in RGibbs either as single condensed species and/or as solid
solution phases.

You can also assign components to be in particular phases in equilibrium. You
can use different property models for each liquid or solid solution phase. This
capability makes RGibbs particularly useful for:

• Pyrometallurgical applications
• Modeling ceramics and alloys

RGibbs accepts restricted equilibria specifications. You can restrict equilibrium
by specifying:

• Fixed moles of any product
• Percentage of a feed component that does not react
• Temperature approach to equilibrium for the entire system
• Temperature approaches for individual reactions
• Fixed extents of reaction
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RCSTR
RCSTR rigorously models a continuous-stirred tank reactor. You can use this
model when:

• Reaction kinetics are known.
• The contents of the reactor have the same properties as the outlet stream.

RCSTR can model equilibrium reactions simultaneously with rate-based
reactions.

RCSTR computes one of the following for the reactor:

• Heat duty given the temperature
• Temperature given the heat duty

RPlug
RPlug rigorously models plug flow reactors. A cooling stream around the reactor
is optional. You can also use RPlug to model reactors with cocurrent and
countercurrent coolant streams. RPlug handles rate-based kinetic reactions only.

RBatch
RBatch rigorously models batch or semi-batch reactors. Holding tanks are used
to interface the batch reactor with the steady-state streams of an Aspen Plus
simulation.

For semi-batch reactors, you can specify a continuous vent and any number of
continuous or delayed feeds. RBatch handles rate-based kinetic reactions only.

Pressure Changers

Pump and compressor models change pressures when energy-related information,
such as power requirement, is needed or known. Free water can be decanted from
the Pump or Compr products, or from the MCompr intercoolers. For pressure
changes only use other models, such as Heater or Valve.
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Pipeline calculates the pressure drop and heat transfer in a pipe segment or a
pipeline. Pipeline can model any number of segments to describe the pipe
geometry.

Pipe calculates the pressure drop and heat transfer for a single pipe segment
with fittings.

Valve rigorously models the pressure drop in control valves.

Pump
Pump simulates a pump or hydraulic turbine. This model calculates either the
power requirement or the power produced, given an outlet pressure specification.
Pump can calculate the outlet pressure, given a power specification.

Compr
Compr simulates a:

• Polytropic compressor
• Polytropic positive displacement compressor
• Isentropic compressor
• Isentropic turbine

Compr calculates either the power requirement given an outlet pressure
specification, or the outlet pressure given a power specification.

MCompr
MCompr simulates a:

• Multistage polytropic compressor
• Polytropic positive displacement compressor
• Isentropic compressor
• Isentropic turbine

MCompr has an intercooler between each compression stage. An aftercooler
following the last compression stage is optional. The coolers can have liquid
knockout outlet streams. You can introduce feed streams between stages. A
variety of specification options are available for both the compression and cooling
stages.
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Pipeline
Pipeline calculates the pressure drop and heat transfer in a pipe segment or a
pipeline. Pipeline can model any number of segments to describe the pipe
geometry.

Pipeline handles a single inlet and outlet material stream. Pipeline assumes the
flow is one-dimensional, steady-state, and fully developed (no entrance effects are
modeled).

Pipeline can perform one- or two-phase calculations.

If the inlet pressure is known, Pipeline calculates the outlet pressure. If the
outlet pressure is known, Pipeline calculates the inlet pressure and updates the
inlet stream.

Pipe
Pipe calculates the pressure drop and heat transfer in a single pipe segment or
annular space. Multi-phase, one-dimensional, steady-state and fully developed
pipeline flow with fittings can be modeled.

Valve
Valve calculates the pressure drop or valve coefficient (Cv) for a control valve.
Multi-phase, adiabatic flow in ball, globe and butterfly valves can be modeled.

Manipulators

Stream manipulators modify or change stream variables for convenience. They do
not represent real unit operations.
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Mult
Mult multiplies streams by a factor you specify. The heat and material balances
are not maintained. The outlet stream has the same composition and properties
as the inlet.

Dupl
Dupl copies the inlet stream to any number of outlet streams. This model does
not satisfy material and energy balances. Dupl is useful for simultaneously
processing a given stream in different types of units.

ClChng
ClChng changes the class of streams between blocks and flowsheet sections. It
copies substreams from the inlet stream to the corresponding substreams of the
outlet stream.

Solids
This table shows the solids models are what they do:

This model Models

CCD Multistage solids washers that recover dissolved components from
an entrained liquid of a solids stream

CFuge The separation of liquids from solids

Crystallizer A mixed suspension, mixed product removal (MSMPR) crystallizer.

Crusher Breaking solid particles in a crusher

Cyclone Solids separation from a gas stream

ESP Solids separation from a gas stream

FabFl Solids separation from a gas stream

Filter The separation of liquids from solids

Continued
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This Model Models

HyCyc The separation of liquids from solids

Screen Separating solid particles in a screen

SWash Solids washers that recover dissolved components from
an entrained liquid of a solids stream

Vscrub Solids separation from a gas stream

Crystallizer
Crystallizer models a mixed suspension, mixed product removal (MSMPR)
crystallizer. It performs mass and energy balance calculations. You have the
option of determining the crystal size distribution.

Crystallizer assumes that the product magma leaves the crystallizer in
equilibrium. The mother liquor in the product magma is saturated.

The feed to Crystallizer mixes with recirculated magma and passes through a
heat exchanger before it enters the crystallizer. The product stream from
Crystallizer contains liquids and solids. You can pass this stream through a
hydrocyclone, filter, or other fluid-solid separator to separate the phases.
Crystallizer can have an outlet vapor stream.

Crusher
Crusher simulates the breaking of solid particles.

Crusher models the wet or dry continuous operation of:

• Gyratory jaw crushers
• Single-roll crushers
• Multiple-roll crushers
• Cage mill impact breakers

Crusher assumes the feed is homogeneous. The breaking process creates
fragments in the outlet solids stream with the same composition as in the feed
stream.

Crusher does not account for heat produced by the breaking process.
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Screen
Screen simulates the separation of various sizes of solid particles in a mixture.
Each of the two outlet streams contain particles of a more uniform size.

Screen calculates the separation efficiency of the screen from the sizes of screen
openings you specify.

FabFl
FabFl simulates baghouse fabric filter units.

A baghouse has a number of cells. Each cell contains a vertically-mounted,
cylindrical fabric filter bag. The filter bags work in parallel to separate solid
particles from a gas stream. Use FabFl to rate or size baghouses.

Cyclone
Cyclone simulates cyclone separators. Cyclone separators remove solid particles
from a gas stream using the centrifugal force of a gas vortex.

Use Cyclone to size or rate cyclone separators.

VScrub
VScrub simulates venturi scrubbers.

Venturi scrubbers remove solid particles from a gas stream by direct contact with
an atomized liquid stream.

Use VScrub to rate or size venturi scrubbers.

ESP
ESP simulates dry electrostatic precipitators.
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Dry electrostatic precipitators separate solids from a gaseous stream.
Electrostatic precipitators have vertically mounted collecting plates with
discharge wires. The wires are parallel and positioned midway between the
plates. The corona discharge of the high-voltage wire electrodes first charges the
solid particles in the inlet gas stream. Then the electrostatic field of the collecting
plate electrodes removes the solids from the gas stream.

Use ESP to size or rate electrostatic precipitators.

HyCyc
HyCyc simulates hydrocyclones. Hydrocyclones separate solids from the inlet
liquid stream by the centrifugal force of a liquid vortex. Use HyCyc to rate or size
hydrocyclones.

CFuge
CFuge simulates centrifuge filters. Centrifuge filters separate liquids and solids
by the centrifugal force of a rotating basket. CFuge assumes the separation
efficiency of the solids equals 1, so the outlet filtrate stream contains no residual
solids. Use CFuge to rate or size centrifuge filters.

Filter
Filter simulates continuous rotary vacuum filters. Filter assumes the separation
efficiency of the solids equals 1, so the outlet filtrate stream contains no residual
solids. Use Filter to rate or size rotary vacuum filters.

SWash
SWash models the separation of solid particles from an entrained liquid of a
solids stream.

SWash does not consider a vapor phase.
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CCD
CCD simulates a counter-current decanter or a multistage washer. CCD
calculates the outlet flow rates and compositions from:

• Pressure
• Mixing efficiency
• Number of stages
• The liquid-to-solid mass ratio of each stage

CCD can calculate the heat duty from a temperature profile. CCD does not
consider a vapor phase.

User Models

User and User2 allow you to write your own unit operation models.

These models can simulate any unit operation model. You must write a Fortran
subroutine to calculate the values of outlet streams, based on the inlet streams
and parameters you specify.

See Aspen Plus User Models for detailed information about writing your own unit
operation models.

Specifying Unit Operation Models

For each unit operation block, you must enter specifications on Block forms. To
access these forms:
1. Select the block on the graphical flowsheet.

2. Click the right mouse button on the block.

3. From the popup menu that appears, click Input.

4. Select the appropriate form and sheet.
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Overriding Global Specifications for a
Block

You can use the BlockOptions form for a block to override global values for the
following parameters:

Option Specify globally on sheet Specify locally on Block sheet

Physical Property Method, Henry’s
Components

Properties Specifications Global BlockOptions Properties

Simulation Diagnostic Message Level Setup Specifications Diagnostics BlockOptions Diagnostics

Physical Property Diagnostic Message
Level

Setup Specifications Diagnostics BlockOptions Diagnostics

Stream Diagnostic Message Level Setup Specifications Diagnostics BlockOptions Diagnostics

Heat Balance Calculations Setup Simulation Options Calculations BlockOptions Simulation
Options

Use Results from Previous
Convergence Pass

Setup Simulation Options Calculations BlockOptions Simulation
Options

Valid Phases Setup Specifications Global Input Specifications

Example of Replacing a Global Properties Specification

Use the NRTL Method with Henry1 (Henry's Components) instead of the global
values in Base Method and Henry’s Components specified on the Properties
Specifications Global sheet.
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Requesting Heating/Cooling Curve
Calculations

Many unit operation models can generate heating/cooling curves.

These curves calculate the following at intermediate points between the inlet and
outlet conditions of a block, including phase transition points (bubble and dew
points):

• Temperature
• Pressure
• Vapor fraction
• Heat duty
• Optional additional properties

To request heating/cooling curves for a block:
1. From the Data Browser tree for the block, select the Hcurves folder.

2. In the Hcurves Object Manager, click New.

3. In the Create New ID dialog box, enter an ID or accept the default ID. The ID
must be an integer.
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4. Select an independent variable:

• Heat Duty
• Temperature
• Vapor Fraction
The selected variable is varied to generate the intermediate points.

5. To define the intermediate points, specify one of the following:

What to specify Where

Number of points Number of Data Points

Size of the increment between points Increment Size

List of values for the independent variable List of Values

If you specify Number of Data Points, the intermediate points will be equally
spaced between the inlet and outlet.

6. Select the pressure profile option in the Pressure Profile frame. Specify
Pressure Drop, if needed for the selected Pressure Profile option.

All of the pressure profiles are either constant or linear from the first
pressure point to the last pressure point. This table shows the points used for
each option:

Pressure Profile Option First Point Last Point

Constant Outlet pressure Outlet pressure

Linear Inlet pressure - Pressure drop Outlet pressure

Linear2 Inlet pressure Inlet pressure - Pressure drop

Linear3 Outlet pressure + Pressure drop Outlet pressure

Outlet Outlet pressure Outlet pressure

Inlet Inlet pressure Inlet pressure

Mid-point (Outlet pressure + Inlet pressure)/2 (Outlet pressure + Inlet pressure)/2

You can request additional properties to be calculated on the Additional
Properties sheet. Any number of the Property Sets in the Properties Prop-
Sets folder are available.

7. Select a Property set and click the left arrow to move the Property Set
between the Available Property Sets list and the Selected Property Sets list.
To move all of the property sets at once from one list to the other, click the
appropriate double arrow.
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If you will be using this heating/cooling curve for heat exchanger design,
select the built-in property set HXDESIGN. HXDESIGN calculates all of the
properties needed by design programs from HTRI, HTFS, and B-JAC.
Aspen Plus includes an interface program, HTXINT, for transferring
heating/cooling curve results to these programs. For information on how to
use HTXINT, see Chapter 39.

Example of Requesting a Heating Curve

Generate a heating curve that includes heat exchanger design properties. Points
are generated every ten degrees.
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A table of data is generated after the simulation has been run.
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A plot can be generated from the results.

❖     ❖     ❖     ❖ 
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11 Running Your Simulation

This chapter describes how to run your simulation including:

• Running the simulation interactively
• Reinitializing simulation calculations
• Viewing the run status of the simulation
• Checking simulation history
• Running the simulation on the Aspen Plus host computer
• Running a simulation in batch (background) mode
• Running Aspen Plus in standalone (text only) mode
• Specifying run settings and user databanks

When your problem specifications are complete, you are ready to run the
simulation. The status of your specifications is shown at all times in the status
bar of the main window and the Data Browser. You can run your simulation if
the status is any of these:

• Input Complete
• Input Changed
• Ready to Execute Block

You can run your simulation in these ways:

Type of Run Information

Interactive When you run interactively you control the simulation completely. You can
step through the simulation, stop at any point, view any intermediate results,
and make changes.

Batch (background) mode When you run batch you cannot control the simulation. Batch simulations are
useful for long simulations or when you want to run several simulations (case
studies) simultaneously.

Standalone Aspen Plus (text only) mode Standalone runs are similar to batch runs, but are made outside of the user
interface.
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Running the Simulation Interactively

You can interactively control the simulation execution by using:

• The Run buttons on the Simulation Run toolbar  
• The Run menu

You have the same flexibility in controlling the simulation whether the
simulation engine is on your local computer or on a remote computer.

You can modify any input specifications at any time before or after a simulation,
or when a simulation is paused.

You can view the progress of the simulation and control using the Control Panel.

The Control Panel consists of:

• A message window showing the progress of the simulation by displaying the
most recent messages from the calculations

• A status area showing the hierarchy and order of simulation blocks and
convergence loops executed

• A toolbar which you can use to control the simulation

Commands for Controlling Simulations
You can control the simulation by using the commands on the Run menu, the
Simulation Run toolbar, or the Control Panel:
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To Do this

Start or continue calculations
Click the Start button  on the toolbar.
– or –
From the Run menu, click Run.

Pause simulation calculations
Click the Stop button  on the toolbar.
– or –
Click anywhere while the cursor is a stop sign.

Step through the flowsheet one block at a time
Click the Step button  on the toolbar.
– or –
From the Run menu, click Step.

Set stop points in the simulation From the Run menu, click Stop Points.
– or –
On the Control Panel, select the block, click with the right mouse
button, and select Stop Point Before or Stop Point After.

Change the next block to be executed From the Run menu, click Move To.
– or –
On the Control Panel, select the block, click with the right
mouse button, and select Move To.

Update results From the Run menu, click Load Results to load
all results from the simulation engine if Interactive Load
Results is:

Off and you stopped the simulation

On and you want to load all results at one time

For more information, see Changing Run Settings and User
Databanks on page 11-11.

Check simulation results
Click the Check Results button  on the toolbar.
– or –
From the Run menu, click Check Results
– or –
In the left pane of the Data Browser, click the Results Summary form.

Display block or stream results 1. On the flowsheet, click the block or stream.
2. Then click with the right mouse button on the block or
stream.
3. From the popup menu that appears, click Results.

Purge simulation results
Click the Reinitialize button   on the toolbar.
– or –
From the Run menu, click Reinitialize.
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Changing Interactive Simulation Speed
When running interactively you can usually increase the speed of the
calculations by selecting the Express Run option. For more information, see
Changing Run Settings and User Databanks on page 11-11.

When the Express Run option is on, you cannot monitor the progress of the
simulation while it is running. However, once the simulation is complete or
stopped, you can check the Simulation History to see the progress and diagnostic
messages.

Reinitializing Simulation Calculations
When you change your simulation specifications, by default, Aspen Plus uses any
previously generated results as a starting point the next time you run the
simulation. You can override this default by reinitializing the entire simulation,
or specific blocks in the flowsheet, before rerunning the simulation.

To reinitialize before rerunning a simulation:
1. From the Run menu, click Reinitialize.

2. Choose the items you want to reinitialize in the Reinitialize dialog box.

Tip   You can also do this from the Control Panel.  Select the block or item, click
with the right mouse button and click Reinitialize.

You may need to reinitialize if a block or the flowsheet:

• Fails to converge for no apparent reason, after you changed the block or
specifications that affect its inlet streams

• Has multiple solutions and you can obtain the one you want only by starting
from your specified initial block or stream estimates

Viewing the Status of the Simulation
You can view the progress of a simulation in:

• The Status Bar
• Control Panel Status Messages
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Viewing Simulation Status Using the Status Bar

The main window status bar shows the progress of a running simulation and the
current status of the simulation when it is not running. Status messages appear
on the right side of the status bar.

This table shows the meaning of the status messages:

Status message Meaning

Flowsheet Not Complete Flowsheet connectivity is incomplete. To find out why,
click the Next button in the toolbar.

Required Input Not Complete Input specifications for the run are incomplete.
Click Next on the toolbar to find out how to complete
the input specifications, and to go to sheets that are incomplete.

Required Input Complete The required input specifications for the run are complete.
You can run the simulation or enter optional specifications.

Ready to Execute Block The simulation is paused because you clicked the Stop
or Step buttons, or a stop point you set was encountered.
Click the Step or Run buttons to continue calculations.

Results Present The run has completed normally, and results are present.

Results With Warnings Results for the run are present.
Warning messages were generated during the calculations.
See the Control Panel for messages.

Results With Errors Results for the run are present.
Error messages were generated during the calculations.
See the Control Panel for messages.

Input Changed Results for the run are present, but you have changed
the input since the results were generated.
The results may be inconsistent with the current input.

Viewing Simulation Status Using the Control Panel
Status Messages

The Control Panel message area contains progress, diagnostic, warning, and
error messages generated during calculations.

This table shows the message and the information that follows it:

Control Panel Message Information Displayed Following the Message

Processing input specifications Flowsheet analysis for tear streams and calculation sequence.
Errors associated with input specifications.

Calculations begin Identification of each block as it is calculated.
Iteration-by-iteration status of convergence blocks, and of
column convergence. Errors during simulation calculations.

Continued



11-6 Aspen Plus User Guide
Version 10.1-0

Running Your
Simulation

Control Panel Message Information Displayed Following the Message

Generating results Errors during the generation of results (heating and cooling
curves, stream properties, property tables and any block
calculations that were not needed during the simulation
calculations).

Problem specifications modified New flowsheet analysis for tear streams and calculation
sequence, caused by flowsheet modifications. Errors
associated with modified input specifications.

Checking the Status of Calculations
Use the Results Summary sheet to check the status of calculations. To do this:

1. On the Simulation Run toolbar, click the Check Results button .

– or –

From the Run menu, click Check Results.

2. Click the Results Summary sheet.

The Results Summary sheet appears. This sheet indicates whether the
calculations were completed normally and shows error or warning messages
resulting from the calculations.

To see error and warning messages for a specific object, click the Status

button  on the Data Browser toolbar when the forms for that object are
displayed.

For more information on checking the completion status of a run, click here.
see Chapter 12.

Checking the Simulation History
Aspen Plus keeps a detailed history of your simulation run in a file that you can
view with your text editor. Input specifications, warning messages, error
messages, and block-by-block convergence information are available.

This table shows your options:

To Do this

View the history of the current run From the View menu, click History.
Save history to a file Use the save command for your text editor.
Return to Aspen Plus Use the exit command for your text editor.

Aspen Plus displays all results in the simulation history in SI units.
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Running the Simulation on the
Aspen Plus Host Computer

If your network configuration and your Aspen Plus license permits, you can run the
Aspen Plus user interface on one computer and run the simulation engine on a
different computer (the remote Aspen Plus host).

You may be required to connect to a remote Aspen Plus host when you start
Aspen Plus. For more information on connecting to a host computer, see
Chapter 1.

To change the Aspen Plus host computer after you have started Aspen Plus:
1. From the Run menu, click Connect to Engine.

2. In the Connect to Engine dialog box, enter the Server Type.

If you choose your Local PC Host as the Aspen Plus host computer, you do not
need to enter any more information into the dialog box.

3. For all Aspen Plus host computers except the PC, enter the following
information in the dialog box:

In this field Enter this information

Node Name Node name of the computer the Aspen Plus simulation will run on

User Name Your Logon name on the host computer

Password Password for your account on the host computer

Working Directory Working directory on the host computer for Aspen Plus runs

Aspen Plus creates files for the run in the Working Directory. Specify the
directory as you would in an operating system command. For example:

To specify an OpenVMS subdirectory named SIMULATION, enter
[.SIMULATION]. The default Working Directory is your home directory for
that particular operating system.

4. Click OK.

5. When the network connection is established, a message box appears saying
Connection Established.

If the Connection Established box does not appear, see your on-site
Aspen Plus system administrator for more information on network protocols
and Aspen Plus host computers.
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Communicating with a Remote Aspen Plus Host
Computer

You can use several commands to communicate with a remote Aspen Plus host
computer simulation engine:

To Do This

Check the status of a batch run From the Run menu, select Batch, then Jobstat,
and select the ID of the run you want information on.

Retrieve results from a batch run From the Run menu, point to Batch, then Load Results,
and select the ID of the run for which you want to retrieve results.

Running a Simulation Batch
(Background)

There are times when you may not want to run the simulation interactively. For
example, when you use a Sensitivity block or an Optimization block, or if the
simulation is lengthy. In these cases you can submit a batch run.

Tip   To avoid inconsistent input and results, do not change the input
specifications for a run after you have submitted a batch run, until you have read
back the results.

To start a batch run:
1. On the Run menu, select Batch, then Submit.

2. Use the check box to specify whether or not you want to delete the temporary
files Aspen Plus generates after the run finishes.

3. You can specify Command Line Qualifiers, for the operating system (such as
batch queue name), and for Aspen Plus (such as user databank filenames).
You also can specify a working directory on the remote host in the Batch
Submit dialog box. The default directory is your home directory on the remote
host computer.

4. Click the Settings button if you want to change any run settings.

5. Click OK.

Aspen Plus submits the batch run.

To check the status of the batch run:
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Ì From the Run menu, point to Batch, then Jobstat.

After the batch run is finished, you can load the results into the user interface.
To load the results into the interface:
1. From the Run menu, point to Batch, then Load Results.

2. Select the ID of the run for which you want to retrieve results.

Running Aspen Plus Standalone

You can use the Aspen Plus user interface to develop the simulation model for a
run and view the results, but run the Aspen Plus simulation engine separately
from the user interface. You might want to do this to achieve maximum
performance for large flowsheets.

To run the Aspen Plus simulation engine standalone:
1. Complete the input specifications for the run in the user interface. When the

status indicator in the main window toolbar says  Required Input Complete or
Input Changed, you can run the simulation.

2. From the File menu, click Export.

3. In the Save As Type field, select Input File (.inp). Enter the Run ID for the
filename.

4. If you are running the simulation engine on a remote computer, transfer the
file runid.inp  to the remote computer.

5. From the operating system prompt, enter the command:

aspen runid

6. If you are running the simulation engine on a remote computer, transfer the
file runid.sum  from the remote computer to the local computer when the run
is complete.

7. When the run is complete, from the File menu, click Import and in the Files
Of Type box, select Summary file (.sum).

8. From the file list, select the Run ID and click OK.

9. You can now review the results and modify the input in the user interface, as
if you had made the run from within the user interface.
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Editing the Input File for Standalone Runs
You can edit the input file outside the interface. The following instructions
ensure that:

• Any changes you make in the input file are reflected in the user interface.
• Your graphical flowsheet will be restored when you return to the user

interface.

To edit the Aspen Plus input file outside of the interface:
1. Complete the input specifications for the run in the user interface. When the

status indicator in the main window toolbar says  Required Input Complete or
Input Changed, you can run the simulation.

2. From the File menu, click Export.

3. In the Save As Type field, select Input Files with Graphics (.inp). Enter the
Run ID for the filename.

4. If you are running the simulation engine on a remote computer, transfer the
file runid.inp  to the remote computer.

5. Edit your input file to make the changes.

6. Use the aspen command option to create a backup file:

aspen runid /mmbackup

7. If you are running the simulation engine on a remote computer, transfer the
files runid.sum  and runid.bkp  to the local computer.

8. When the run is complete, start the Aspen Plus user interface.

9. From the File menu, click Open, and select Backup files (.bkp). Then select
the Run ID from the file list.

10. Click OK.

11. From the File menu, click Import, and in the Files Of Type field, select
Summary file (.sum).

12. Select the Run ID from the file list, and click OK.
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Changing Run Settings and User
Databanks

To display the Run Settings dialog box:
1. From the Run menu, click Settings.

2. On the Engine Files Tab, you can specify filenames for:

Item Information

User physical property databanks The property databanks are called USRPP1A, USRPP1B
USRPP2A, USRPP2B and USRPP2C. For more information,
see Aspen Plus Physical Properties Data.

User insert libraries and stream
libraries

In Aspen Plus, when referring to insert libraries or stream
libraries, you must use the file extension .ILB for insert
libraries, and .SLB for stream libraries.

Link Options The Dynamic Linking Options File (DLOPT) contains
directives for dynamic linking. For more information, see
Aspen Plus User Models.

Run Definition The User defaults file is used to override system defaults files
and specify default command options.

A user cost databank The  user cost databank is used to update the cost indices.

These filenames apply when you run the simulation interactively or in batch.

3. On the Options tab, use the Express Run option to achieve maximum
simulation speed when running the Aspen Plus simulation engine on a PC, or
when running interactively on other platforms. The Express Run option:

• Turns off the Animation option
• Sets the Control Panel message levels to 0
• Turns off interactively loading results
• Enables you to use History from the View menu to examine the progress

of a simulation

Interactively Load Results
By default, Aspen Plus results are loaded into the user interface only when you
want to examine them.
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To change whether Interactively Load Results is on or off:
1. From the Tools menu, click Options.

2. On the Run tab, check or clear Interactively Load Results.

Have Interactively
Load Results

If Then

On You want Aspen Plus to load only the
results you are interested in.

(You can still load all results by using
Load Results from the Run menu.)

Aspen Plus speeds up the processing time by
only loading particular results. This is useful if
you run a simulation several times, but are
only interested in the results on one particular
form.

Off You want all results to be loaded
automatically at the end of a run

Aspen Plus loads all simulation results into
the user interface. This increases the time
required for a run to complete, but enables you
to examine results more quickly.

Note  Interactively Load Results only works with the Flowsheet Run Type.

❖     ❖     ❖     ❖ 
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12 Examining Results and
Generating Reports

• View simulation results interactively
• Checking the completion status of a run
• Checking the convergence status of a run
• Displaying stream results
• Generate an Aspen Plus report file

Viewing Simulation Results Interactively

You can view results whenever the status message in the bottom window status
bar is one of the following:

Message Means

Results Available The run has completed normally, and results are present.

Results Available with Warnings Results for the run are present. Warning messages were generated
during the calculations. View the Control Panel or History for
messages.

Results Available with Errors Results for the run are present. Error messages were generated
during the calculations. View  the Control Panel or History for
messages.

Input Changed Results for the run are present, but you have changed the input since
the results were generated. The results may be inconsistent with the
current input.

Use the results status indicators, which appear in the Data Browser to guide you
to forms and objects. For a complete list of the status indicators, see Chapter 1.
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Viewing Current Simulation Results
You can view the current simulation results after using the Stop or Step
commands. To do this:
1. From the Run menu, click Settings.

2. In the Run Settings dialog box, ensure that the Interactively Load Results
option is cleared.

3. From the Run menu, click Check Results.

Use the results status indicators, which appear in the Data Browser, to guide you
to forms and objects with results.

Checking the Completion Status of a Run

Use the Results Summary sheet to examine summary information about the
convergence and completion status of a run. This form indicates whether the
calculations were completed normally.

To display the Results Summary sheet, do one of the following:
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From the Select

Simulation Run
toolbar or the
Control Panel

The Check Results button  

Data Browser Results Summary in the left pane of the Data Browser

Run menu Check Results

If errors or warnings exist:

1. When on a particular form, click the Status button  on the toolbar of the
Data Browser window to see specific messages.

2. Check the Control Panel and History file for information, diagnostic, warning,
and error messages generated during calculations.

Checking Completion Status in the Control Panel
The Control Panel displays error, warning and diagnostic messages from the run.

The number of messages can be controlled globally using the Setup Specifications
Diagnostics sheet or locally using the block BlockOptions Diagnostics sheet.

The messages on the control panel are similar to those printed in the history file
(*.his). The diagnostic level of the history file and the control panel can be
adjusted independently.

If a high level of diagnostics is needed, the diagnostics should be printed to the
history file and not to the control panel. This means you will not slow down
performance by writing a lot of information to the screen.

To view the Control Panel, do one of the following:

From the Select

View menu Control Panel

Simulation Run
toolbar Show/hide control panel window button 

The Run Messages file (*.cpm) is a text file that includes all of the messages
printed on the control panel. Run Messages files must be exported from the
simulation to be saved. For more information, see Chapter 15.
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Checking Completion Status in the History File
The History file displays error, warning and diagnostic messages from the run.

The number of messages can be controlled globally using the Setup Specifications
Diagnostics sheet or locally using the block BlockOptions Diagnostics sheet.

To check the History file:

➤ From the View menu, click History.

A history file cannot be directly saved or exported from the Aspen Plus User
Interface. However, the file is saved automatically when a run is saved as an
Aspen Plus document (*.apw). You can also save the viewed history file using the
text editor.

The history file is similar to the Run Messages file (*.cpm). The diagnostic level
of the history file and the control panel can be adjusted independently. If a high
level of diagnostics is needed, they should be printed to the history file and not to
the control panel so as to not inhibit performance by writing so much information
to the screen.

Checking the Convergence Status of a
Run

Design specifications and tear streams both have associated convergence blocks.
The Aspen Plus generated convergence block names begin with the character “$.”
User-defined convergence blocks must not begin with the character “$.” For more
information on Convergence, see Chapter 17.

Summary of Convergence Block Results
To see a summary of all of the convergence blocks for a run:
1. In the left pane of the Data Browser, click Results Summary, then select

Convergence.

2. This table shows which sheets to use for summary information:

Select this sheet For a summary of

DesignSpec Summary The convergence status, final manipulated variable value, and final
errors for all design specifications in the simulation

Tear Summary The convergence status and final maximum errors for all tear
streams in the simulation
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Detailed Convergence Block Results

To see detailed results for a convergence block and its iteration history:
1. From the Data menu, point to Convergence, the click Convergence.

2. From the Convergence Object Manager, select a convergence block ID.

3. Click the Edit button.

– or –

4. Double-click a convergence block ID.

5. From the Results form:

Select To see

Summary How tightly each tear variable or manipulated variable was converged

Spec History The errors at each iteration. You can plot the iteration history.

Tear History The maximum error at each iteration among all tear stream variables
converged by this block. You can plot the iteration history.

Max Error/Tol The maximum error divided by the tolerance at each iteration  for all tear
streams and design specifications.

Tear Variables The value at each iteration of all tear stream variables converged by this
block.

Displaying Stream Results

This table shows how to display stream results:

To display Do this

A single stream 1. Click the stream.
2. Click with the right mouse button on the stream.
3. From the popup menu that appears, click Results.

The inlet and outlet streams of a block 1. Click the block.
2. Click with the right mouse button on the block.
3. From the popup menu that appears, click Stream Results.

All streams From the Data Browser, point to Results Summary, then Streams.

On any Results Summary Streams sheet, click the down arrow in the Display box
to select whether all stream or selected streams are displayed:

To add a stream to the display on any Results Summary Streams sheet:
1. Move to a field in the top row of a column.



12-6 Aspen Plus User Guide
Version 10.1-0

Examining
Results and
Generating
Reports

2. Click the arrow to see a drop down list of streams.

To remove a stream from the display:
1. Click the stream ID.

2. Click the right mouse button.

3. From the popup menu that appears, click Clear.

This table shows which sheets display which results:

Select this Results Summary
Stream sheet

To display

Material Results for all or selected material streams in a spreadsheet format

If you designate any batch streams, Aspen Plus displays the
batch stream results (such as cycles/day, cycle time, down time).

You can format the stream results, transfer the stream results to
the Process Flowsheet as a table, or print the results. For more information, see
Chapter 14 .

For more information about stream summary formats, see Formatting Stream
Results on page 12-7.

Heat Heat flow results for all or selected heat streams in a spreadsheet format

Aspen Plus uses heat streams to transfer duties to or from unit operation blocks.

Work Power results for all or selected work streams in a spreadsheet format

Aspen Plus uses work streams to transfer power to or from pumps or
compressors.

Vol. % Curves The Volume percent curves for all or selected streams.

TBP curve, ASTM D86 curve, ASTM D1160 curve, Vacuum at 10 mmHg curve,
API curve, and Specific gravity curve can be viewed.

For more information, see Chapter 32.

Wt. % Curves The Weight percent curves for all or selected streams.

TBP curve, ASTM D86 curve, ASTM D1160 curve, Vacuum at 10 mmHg curve,
API curve, Specific gravity curve, Molecular weight curve, and
ASTM D86CRK curve can be viewed.

For more information, see Chapter 32.

Petro. Curves Petroleum property curves for all or selected streams.

For more information, see Chapter 32.



Aspen Plus User Guide 12-7
Version 10.1-0

Chapter 12

Formatting Stream Results
The settings you specify on the Setup ReportOptions Stream sheet determine the
contents of the Results Summary Streams Material sheet. For more information
on specifying stream results, see Chapter 5.

The table format file (TFF) shown in the Format box of the Stream Summary
sheet determines the format (order, labels, precision, and other options) of the
stream results.

Aspen Plus provides built-in TFFs tailored to each Application Type. The default
is an appropriate TFF for the Application Type you choose when you create a new
run. You can also create your own TFFs. For more information on creating your
own TFFs, see Chapter 36.

Choosing a Table Format File

To choose a TFF:
1. From the Data menu, click Results Summary, then Streams.

2. Click the Material sheet.

3. In the Format box, click the drop down arrow and select a TFF from the List.

If you are using built-in TFFs, it is recommended that you select a TFF for
your Application Type. For example, if you are using a Petroleum Application
Type, choose a TFF beginning with PET.

Tips

You can also specify the TFF on the Setup ReportOptions Streams sheet.
Aspen Plus uses the TFF you select for all Stream Summary sheets you display,
until you select another TFF.

Some TFFs filter the calculated stream results. If you want to make sure you see
all calculated properties, select TFF FULL.

Displaying Heat and Work Stream Results
To display results for heat and work streams, follow one of these procedures:

To display results for Do this

A single stream 1. Click the stream
2. Click the right mouse button and from the popup menu that appears, click Results.

All streams 1. From the Data Browser, click Results Summary, then Streams.
2. Click the Heat or Work tab.
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Generating a Report

You can generate a report file documenting the complete input specifications and
simulation results for your Aspen Plus run. Use the Report Options forms to
control report contents. For more information about report options, see Chapter 5.

Before generating a report, the results of an interactive run must be available.
You need to make an interactive run if:

• You have not yet run the simulation.
• You changed input specifications since running the simulation.
• You changed settings on the Report Options forms since running simulation.
• You opened a run saved in backup format, and have not run the simulation in

the current session.

To make an interactive Run:

➤ On the Simulation Run toolbar, click the Run button   .

– or –

➤ From the Run menu, click Run.

To generate a report:

➤ From the View menu, click Report.

Export a Report File
To save the entire report file from an interactive run:
1. From the File menu, click Export.

2. In the Save As Type box, select Report files.

3. Enter a filename. The file can be in any directory on the local computer.

4. Select Save to create the report file.

Aspen Plus generates a report automatically during a batch run. The filename is
the Run ID, with the .rep extension. The report file for a batch run is saved on
the computer running the Aspen Plus simulation engine. If Aspen Plus is
running on a remote computer, the report file is saved on that computer's file
system.

For more information on managing files, see Chapter 15.
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Viewing a Section of the Report
To view the entire report or a selected portion of a report in a text editor:
1. From the View menu, click Report.

2. Select the part of the report that you would like to view:

Select To display

Block The results of a specified unit operation block

Convergence The results of a specified Convergence block

Sensitivity The results of a specified Sensitivity block

Transfer The results of a specified Transfer block

Fortran The results of a specified Fortran block

Streams The results of a specified stream or of all streams

Balance The results of a specified Balance block

Pressure Relief The results of a specified Pressure relief block

Regression The results of a specified Regression block

Simulation The entire Report file

Table Of
Contents

Table of contents for the report

Flowsheet
Balance

Material and energy balance for the flowsheet

Connecting
Streams

The connecting streams (feeds and products) for a selected block

 

3. If necessary, select the ID for the block, stream, or other object.

4. Click Apply to display your selection in the text editor.

5. Repeat steps 2-4 to display any additional sections of the report.

6. Click OK.

Tips

Any of the sections of the report can be saved or printed using the text editor.

Use Copy and Paste to copy results from any sheet into another Windows
program.

❖     ❖     ❖     ❖ 
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13 Working with Plots

This chapter describes how to generate, customize, and print plots from any input or
results sheet that has tabular data, including:
• Generating plots
• Working with plots
• Printing plots

About Plots

Aspen Plus plots are a useful way of viewing the date from a run.  You can use
plots to display:
• Input and results profiles for unit operation blocks
• The results of flowsheeeting options and model analysis tools such as

Sensitivity, Optimization, and Pres-Relief.

There are three steps involved in generating a plot:
1. Displaying the sheet containing the data you want to plot. The sheet may

contain either input or results data.

2. Generating the plot either by:

• Using the Plot Wizard
–or–

• Selecting the dependent, independent, and parametric variables
3. Customizing the plot appearance.
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Step 1: Displaying the Data

To display data:
1. From the Data menu, click Data Browser.

2. In the left hand pane, click the form containing the data that you want to
plot.

3. On the form, click the sheet to display the data.

This sheet can be either an input or a results sheet though it is much more
common to plot results.

3. To plot results, make sure that the simulation run has results available.

If results are available, the status message in the main window will be
Results Available, Results Available with Warnings, Results Available with
Errors, or Input Changed. For more information on status messages when
results are present, see Chapter 12.

If results are not available, run the simulation.

Step 2: Generating a Plot

You can generate the plot in either of these ways:
• Using the Plot Wizard
• Selecting the dependent and independent variables

Using the Plot Wizard
Use the Plot Wizard to generate a plot quickly by selecting from a list of
predefined plots. The Plot Wizard is available for most blocks and other objects
which have tables of results.

After you have displayed the data:
1. From the Plot menu, click Plot Wizard.

Note   The Plot menu is only visible when you have the Data Browser in the
current window.

The Plot Wizard Step 1 appears.
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2. Click Next.

3. Select the type of plot from the list of available plots, then click Next.

4. Select the options for the plot type you have selected.

The options that are available depend on the plot type selected.

5. Click Next.

6. Select the general options for the plot type you have selected.

The Plot Wizard guides you through the options.  These include:

• Changing the Plot type
• Modifying the Plot and Axis titles
• Choosing whether you want the plot updated when new results are

available
• Selecting if you want to display the plot legend
• Adding a time stamp
For further details on these, see Step 3: Customizing the Appearance of a Plot
on page 13-7.

7. To end the Plot Wizard and generate the plot, click Finish.

For information on changing the plot attributes after exiting the wizard, see
Step 3: Customizing the Appearance of a Plot on page 13-7.
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Example of Making a Plot of Flow Rate for a Radfrac Column
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The plot generated:

Generating a Plot by Selecting Variables
The Plot Wizard is usually the quickest way to generate a plot.  However, if the
plot you are interested in is not available in the Plot Wizard, you can generate
the plot by selecting the independent, dependent, and parametric variables.

To select variables:
1. Click the title of the column of data you want to plot on the X-Axis.

2. From the Plot menu, click X-Axis Variable.

3. Select all the dependent variables:

• Hold down Ctrl and click the title of each column of data you want to plot
on the Y-Axis.

• From the Plot menu, click Y-Axis Variable.
4. If you want to plot a parametric variable:

Click the title of the column of data you want to plot as the parametric
variable.

5. From the Plot menu, click Parametric Variable.

This table shows the types of variables available for a plot:
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This variable Is You can

Y-Axis variable The dependent
variable

Select as many Y-Axis dependent variables
as you like for a plot. You must select
at least one Y-Axis dependent variable.

X-Axis variable The independent
variable

Select only one X-axis independent variable
or accept the default independent variable
(usually the first column of data)

Parametric
variable

The third variable Use this variable to plot a dependent variable
against an independent variable for several values.
For example, you might use a sensitivity block
to generate a plot of reaction conversion (the dependent
variable to be plotted on the Y-axis) versus residence time
(the independent variable to be plotted on the X-axis)
for three temperatures (the parametric variable).

Step 3: Customizing the Appearance of a
Plot

You can customize the appearance of your plot by:
• Adding and modifying annotation text
• Changing the plot properties

Adding and Modifying Annotation Text
You can:

Do This And

Add text to annotate a plot The text can be attached or unattached.

Attach text to a point on a plot line The text moves with the point as you zoom in and out
and scroll through the plot workspace.

Place unattached text anywhere within the
plot workspace

The text stays in the same place within the window as
you zoom in and out and scroll through the workspace.

To add text to a plot:
1. Display the plot on which you want to add text.

2. Click the right mouse button on a plot and from the popup menu that
appears, point to Modify, then click Add Text.
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3. Use the Plot Text Setting dialog box to add or change the text.

Use this text sheet To

Text Enter the annotation text and specify color and orientation

Attribute Attach the text to data point. You can connect it without an arrow or
with a small, medium or large arrow.
The default is to attach it with a medium arrow.

Leave the text unattached. You can either left, center, or right justify it.
The default is to left justify the text.

Font Select the font, style and size for the text

4. Click OK.

5. Click the location on the plot where you would like to have the text placed.

6. If the text is attached to a data point, Aspen Plus automatically draws a line
to the nearest curve. If this location is not desired, the point of attachment
can be selected and dragged to any point on any curve in the plot.

To modify text on a plot:
1. Select the text that you want to modify. It will be highlighted once it is

selected.

2. Click the right mouse button and click Edit.

3. Use the Plot Text Settings dialog box to change the text.

4. Click OK.

You can also change the default text font on a plot.  For information on
changing plot defaults, see Changing Plot Defaults on page 13-17.

Changing Plot Properties
Most of the elements of a plot can be modified using the Plot Control Properties
dialog box. To access this dialog box:
➤ Double-click the plot.

– or –

Click the right mouse button over the plot and from the menu that appears,
click Properties.

The following sections describes the changes you can make to a plot.



Aspen Plus User Guide 13-9
Version 10.1-0

Chapter 13

Changing Plot Attributes

You can change the appearance of data lines on a plot. The color, line, type and
marker type can be modified for each variable.

To change the attributes of the data lines on the plot:
1. Display the plot.

2. Click the right mouse button on the plot and from the menu that appears,
click Properties.

3. Click the Attribute tab.

4. Select the variable.

5. Select the Color, Marker, and Line type for that variable.
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Displaying the Plot Legend

To show a legend on a plot:
1. Display the plot.

2. Click the right mouse button on the plot and from the popup menu, point to
Modify, then click Show Legend.

Modifying the Plot Legend

You can modify the legend text and font:
1. Display the plot.

2. Double-click the legend.

– or –

When the cursor is positioned over the legend, click the right mouse button
and then click Edit.

3. On the Plot Legend dialog box, click the line of the legend that you want to
change and it appears in the Legend Text box.

4. In the Legend Text box, change the legend.

5. Click Replace.

6. Repeat steps 3–4 for every line of the legend that you want to change.

7. On the Font tab, you can modify the font for the entire legend.

The legend can be hidden and then revealed, and all changes to the legend
will be preserved.

You can also change whether a legend appears by default on your plots. For
information on changing plot defaults, see Changing Plot Defaults on page 13-
17.
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Changing the Axis Map

If a plot has more than one dependent variable, by default Aspen Plus displays
the plot with a separate Y axis scale for each dependent variable. You can map
all variables to a single axis, or you can map groups of variables to designated
axes.

For example, if you plot column mole fraction profiles for five components, you
can plot all components against a single Y axis scale. If you plot temperature,
liquid rate and vapor rate on the same plot, you can plot temperature on one axis
and both flow rates on another.

To specify axis mapping:
1. Display the plot.

2. Click the right mouse button on the plot and from the popup menu, click
Properties.

3. Click the AxisMap tab.

4. Select a dependent variable.

5. This table shows what you can do:

Use To

The Up and Down arrows Change the axis number the variable is mapped to. If you reduce an axis number
to zero, the plot of the dependent variable is not displayed.

The All in One button Map all dependent variable to a single axis.

The One for Each button Map each dependent variable to a separate axis.

6. Click OK.

Changing Plot Titles

You can change the text on the plot titles at any time by customizing the font,
style, and size for the text.

To change the plot title for a specific plot:
1. Display the plot that you want to change.

2. Double-click the title that you want to change.

3. On the Text tab, enter the text for the title.

4. On the Font tab, select the font, style, and size for the text.

You can also change the default text font for plot titles. For information on
changing plot defaults, see Changing Plot Defaults on page 13 - 17.
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Changing Plot Axis Labels

The text on the plot axis labels can be modified at any time. The font, style, and
size for the text can also be customized for each label.

To change the plot axis labels for a specific plot:
1. Display the plot.

2. Double-click the axis label that you want to change.

3. On the Text tab, enter the text for the axis label.

4. On the Font tab, select the font, style, and size for the text.

5. Repeat steps 2–4 for any other axes that you wish to modify.

You can also change the default font for all plot axis labels. For information
on changing plot defaults, see Changing Plot Defaults on page 13-17.

Changing Plot Axes

The scale options for the X and Y axes can be changed in order that a specific
area of the plot can be viewed. If a plot has more than one Y axis scale, the scale
for each one can be changed separately.

To change scale options for the X or Y axis:
1. Display the plot.

2. Double-click the Axis values that you want to change.

3. Select whether you want a linear, log or inverse scale.

4. Change the Grid interval.

– or –

To return to the automatic grid interval determined by Aspen Plus, turn off
the Lock grid option.

5. Use the Axis Range settings to plot only a subset of the data, or to specify
endpoints for the axis scale. To return to the automatic range determined by
Aspen Plus, delete the entries from the Range text boxes.

6. The Value Range boxes (displayed below the Axis Range boxes) show the
range of data.

7. If you want to invert the axis to display the variable values decreasing from
the origin, check the Variable Descends box.

8. On the Font tab, select the font, style and size for the text.
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Changing the Grid Display for a Plot

To change the grid and line display options for a specific plot:
1. Display the plot.

2. Double-click the plot background.

3. Click the Grid tab.

4. Change the options desired.

This table shows the display settings that you can change:

Choose this Plot Option To

Grid Define the type of grid for the plot. Choose from:

Mesh (Horizontal and vertical grid)

Horizontal

Vertical

No grid

Line Select the line style for the data curves. Choose from:

Lines & markers

Lines

Markers

Flip coordinate Flip the x and y axes

Square plot Set the range of the x and y axes to be the same

Diagonal line Draw a diagonal line where x=y on the plot

Zero line Draw a horizontal line at the zero point of the x axis

Marker size Modify the size of the markers displayed in the plot
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You can also change the default display options for plots. For information on
changing plot defaults, see Changing Plot Defaults on page 13 - 17.

Adding a Time Stamp

A time stamp can be added to a plot to mark the date and time that the plot was
created. The time stamp can include any combination of:
• Date
• Time
• Version
• RunID
• Username

To add a time stamp to a plot:
1. Display the plot.

2. From the Edit menu, click Insert Time Stamp.

The time stamp is simply text. To modify the time stamp, use the same
instructions for modifying text.

You can also change the default time stamp for plots. For information on
changing plot defaults, see Changing Plot Defaults on page 13 - 17.

Working with Plots

This section describes working with plots, including:

Updating Plots When Results Change
If you leave a Plot window open when you rerun a simulation, by default
Aspen Plus does not redraw the plot using data from the new run.

To have a plot updated when results change:
1. Display the plot that you want to modify.

2. From the Edit menu, click Live Plot.

This option can also be selected in the Plot Wizard.
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Adding Data to Plots
You can add additional curves to existing plots.

To add data:
1. Display the sheet that contains the data you want to add to an existing plot.

2. Select the dependent and independent variables.

The selected data needs to have the same x-axis variable as the existing plot.
For example,  if the existing plot is temperature vs. stage number, the data
selected needs to be something vs. stage number.

3. From the Plot menu, click Add New Curve.

4. In the Plot Window List dialog box, click the Plot where you want to add the
new data.

5. Click OK.

The new curve is added to the plot.

Comparing Runs Using Plots
You can use the Add New Curve feature to compare the results from different
runs in a single plot.
1. After the first simulation, create the plot.

2. From the Plot menu, ensure that the Animate Plot option is not checked.

3. Change the input specifications and re-run the simulation.

4. Display the results sheet containing the data you want to compare against
the first run. Select the same independent and dependent variables as in the
first plot.

5. From the Plot menu, click Add New Curve.

6. In the Plot Window List dialog box, click the Plot where you want to add the
new data.

7. Click OK.

The new curve will be added to the plot.
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Deleting Data Points and Curves from Plots
From an existing plot, you can delete:
• Selected data points
• An entire curve

After you delete data points from a plot, Aspen Plus redraws the curve
automatically.

Note   You cannot recover deleted data points. You must regenerate the plot if
you want to see them again.

To delete selected data points from a plot:
1. Display the plot.

2. Hold down the left mouse button and drag the cursor to form a rectangular
outline around the data points that you want to delete.

3. Click the right mouse button.

4. From the menu that appears, click Delete Points.

Note   You cannot recover deleted data points.

To delete an entire curve:
1. Display the plot.

2. Click the right mouse button.

3. From the popup menu, point to Modify, then click Hide Variable.

4. Select a variable and use the Hide and Show arrow buttons to move the
desired variables from the Shown Variables list to the Hidden Variables list.

Hidden curves can later be revealed using these same steps.

Displaying a Different Range of Data on a Plot
Use the zoom commands to display a different range of data on a plot:

This zoom option Zooms

Zoom Auto In by an automatic amount

Zoom Out Out by an automatic amount

Zoom Full To the full plot

For example, to zoom in on a specific range of data:
1. Display the plot.



Aspen Plus User Guide 13-17
Version 10.1-0

Chapter 13

2. Select the region of interest on the plot. To do this, hold down the left mouse
button and drag the cursor to form a rectangle outline.

3. Click the right mouse button in this region and from the menu that appears,
click Zoom In to display the region you selected.

4. To display the entire plot again, click the right mouse button in the plot and
from the popup menu, click Zoom Full.

Changing Plot Defaults
To change the defaults used to generate a plot:
1. From the Tools menu, click Options.

2. From the Plots tab, click the defaults that you want to change.

3. Click the Title, Axis label, Axis scale, or Annotation buttons to modify the
default font for the different types of text on a plot.

4. Use the lists to select the Grid Style and the Line Style used for new plots.

5. Use the Marker Size box to specify the size of data markers in plots.

6. Check the Show legend and/or Show Time Stamp boxes to display these
elements by default on a new plot. The components of the time stamp can also
be selected in this manner.

Printing a Plot
You can print a selected plot. To do this:
1. Display the plot that you want to print.

2. From the File menu, click Print.

For more information on printing, see Chapter 14.

❖     ❖     ❖     ❖ 
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14 Annotating Process
Flowsheets

This chapter describes how you can annotate your flowsheets, including:

• Adding annotations
• Displaying global data
• Using PFD mode
• Printing

Adding Annotations

Additional text, graphics, and tables can be added to your flowsheets.

For example, this illustration shows annotation turned on to show a title and a
table of stream results.
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Adding Stream Tables
You can add stream tables to your flowsheets to display stream properties in a
birdcage format.

To generate a stream table in your flowsheet:
1. Ensure that the flowsheet has results available. If results are not available,

run the simulation.

2. From the View menu, ensure Annotation is selected.

3. Display the Results Summary Streams sheet. To do this, in the left pane of
the Data Browser, click Results Summary, then Streams.

Results for all of the streams are displayed. For more information see
Chapter 12.

If you only want selected streams to be displayed:

• In the Display box, select Streams instead of All Streams.
• Then select the desired stream from the list at the top cell of each column.

4. In the Format box, select the format you want. The format controls how
Aspen Plus displays results. Options include order, labels, units, and
precision. (See Chapters 12 and 36)

The different formats are created using Stream Summary Format Files (*.tff
files). All of the files with this extension in the system directory or in the
working directory will appear in the Format list.

5. Click the Stream Table button.
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Aspen Plus adds the stream table to your drawing.

The table is scaled for printing so if you cannot read its contents on screen,
you can zoom in on it, or resize it.

6. Move the table to the position you want, using the keyboard or mouse.

7. You can attach the table to a block or stream. From the Table popup menu,
click Attach.

8. To arrange the table in multiple rows of streams, from the Table popup menu,
click Stack Table.

Resizing Stream Tables

You can resize stream tables by changing the font size. To do this:
1. Click on the stream table to select it.

2. On the Draw toolbar, change the font size.

The stream table resizes accordingly.

Adding Graphics Objects
To add lines, circles, or boxes to a flowsheet:
1. From the View menu, ensure Annotation is selected.

2. Ensure the Draw toolbar is displayed. Click here for more information.

To do this, from the View menu, click Toolbar and ensure Draw is selected.

3. From the Draw toolbar, select the drawing tool that you want, and the line
style and fill color that you want.

4. Move the cursor to where you want to place the object.

5. Hold down the mouse button until the cursor changes to the resize shape (+).

6. Drag the cursor to create the object in the size you want, then release the
mouse button.

7. To fill in the graphics object, select the object and check fill on the object’s
popup menu.

You can change the attributes of an object after you place it. Select the object,
then select the line style or fill color from the Draw toolbar.

Use the mouse or keyboard to move and resize graphics objects. You can attach
the graphics object to a block or stream by clicking the block or stream with the
right mouse button and from the popup menu that appears, clicking Attach.
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It is helpful to show the grid and use grid options when placing, moving, and
resizing graphics objects. For more information see Aligning Objects in
Flowsheets on page 14 - 12. For information on how to use and customize the Grid
and Scale options, see Chapters 4 and 16.

Adding Text Objects
To add text annotations to a flowsheet:
1. On the View menu, ensure Annotation is selected.

2. Ensure the Draw toolbar is displayed. Click here for changing which toolbars
are displayed.

To do this, from the View menu, click Toolbar and ensure Draw is selected.

3. From the Draw toolbar, click the text button .

4. Move the cursor to where you want to place the text and click the mouse
button.

5. Type the text.

Use the mouse or keyboard to move and resize text you have placed.

You can also attach the object to a block or stream. To do this, click the block
or stream with the right mouse button and from the popup menu that
appears, click Attach.

It is helpful to show the grid and use grid options when placing, moving, and
resizing text. For more information see Aligning Objects in Flowsheets on page 14-
12. For information on how to use and customize the Grid and Scale options, see
Chapters 4 and 16.

Specifying Text Attributes

You can change the appearance of text objects after you place them in your
flowsheet by selecting the text object then using the Draw toolbar to specify the
attributes.

To specify the default text attributes for all subsequent text that you add:
1. Ensure no text objects are selected in the drawing.

2. In the Draw toolbar, specify the attributes you want.
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Editing Text Objects

In a flowsheet, you can edit a text object.

To edit a text string:
1. Select the text string and click the right mouse button.

2. From the popup menu that appears, click Edit.

About Global Data

Global data consists of simulation results for each stream, and for each block that
calculates duty or power.

You can display the following global data directly on a flowsheet:

This data Is displayed

Stream temperature, pressure, flow rate In symbols attached to stream IDs

Heat stream duty In symbols attached to stream IDs

Work stream power In symbols attached to stream IDs

Block heat duty and power Next to the block icon

This example shows a process flowsheet window where global data is turned on
to show temperature, pressure, and flow rate for each stream:
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Displaying Global Data
To display global data in a flowsheet:
1. From the View menu, ensure Global data is selected.

2. Ensure that the flowsheet has results available. If results are not available,
run the simulation.

3. From the Tools menu, click Options.

4. Click the Results View tab.

5. Select a units set for the data from the list.

6. Select the results you want to display.

For each result, specify a numerical format.

The recommended format is %10.2f. This format prints values with two digits
to the right of the decimal, if there is room. If the number is greater than
9,999,999, Aspen Plus eliminates the fractional digits, then spills over the
field range to the left.
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Other common formats used in stream tables are:

Stream table format Prints

%10.0f Whole numbers, with no decimal digits or exponents

%10.nf Numbers without exponents and with n digits to the right of the decimal point, if there is room.
Decimal points line up, unless decimal digits have been eliminated in some numbers.

%10.nE Numbers in exponential notation, with n+1 significant digits

7. Click OK to close the dialog box and display the data.

A legend box shows the global data symbols and units. You can move and
resize the legend in the same way that you move and resize blocks.

About PFD Mode

Aspen Plus has a special Process Flow Diagram (PFD) mode that enables you to
create customized diagrams from your simulation results. In this mode, you can
add or delete unit operation icons to the flowsheet for graphical purposes only.

Using PFD mode means that you can change flowsheet connectivity to match
that of your plant.

To use the PFD mode:

➤ Turn PFD mode on and off from the View menu.

The default is PFD Mode turned off.

Using PFD Mode to Change Flowsheet Connectivity
In the simulation flowsheet, you may need to use more than one unit operation
block to model a single piece of equipment in a plant. For example, a reactor with
a liquid product and a vent may need to be modeled using a RStoic reactor and a
Flash2 block. In the report, only one unit operation icon is needed to represent
the unit in the plant.

Alternatively, some pieces of equipment may not need to be explicitly modeled in
the simulation flowsheet. For example, pumps are frequently not modeled in the
simulation flowsheet; the pressure change can be neglected or included in
another unit operation block.
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When PFD mode is on, you can:

• Add blocks and streams that are not in the simulation flowsheet
• Delete blocks and streams that are in the simulation flowsheet

In summary:

Have PFD mode When you

Off Create a simulation flowsheet (default)

On Prepare customized PFD-style drawings for reports

Example of Aspen Plus in Simulation Mode and PFD Mode

When the PFD mode is on, PFD mode is shown on the status bar and a aqua
border is displayed at the edge of the Process Flowsheet Window.

Simulation Mode:
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PFD mode:

Creating a Process Flow Diagram
To create a process flow diagram:
1. Display the simulation flowsheet.

2. From the View menu, ensure PFD mode is checked.

You are now in PFD mode. Aspen Plus displays a copy of your simulation
flowsheet.

3. Modify the drawing, as described in subsequent sections of this chapter.

4. To exit PFD mode, from the View menu, clear the PFD mode checkbox.

Important   PFD-style drawing is completely separate from the graphical
simulation flowsheet. You must return to simulation mode if you want to make a
change to the simulation flowsheet.
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Grouping Objects

You can create temporary or permanent groups of text and graphics objects in your
flowsheet.

example,  this diagram shows  a temporary group that includes the text
“Methylcyclohexane Recovery Column” and the Unit Operation Icon for the
column:

You can select a region containing both the objects and flowsheet blocks and
streams. You can move the selected text, graphics, and flowsheet objects as a
unit. But you must perform all other operations separately for the different
groups in the region.

When you select a temporary group, you can move, resize, or change attributes of
all objects in the group together.

A permanent group becomes a single object in the drawing. You can select, move,
resize, rotate, or change the attributes of all objects in the group together. You
can attach the entire group to a flowsheet block or stream. For more information,
see Attaching Objects to the Flowsheet on page 14 - 13.
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Creating Temporary Groups
To create a temporary group in your flowsheet:
1. Select a region that contains text or graphics objects by using the mouse to

draw a box around the region.

2. You can add or remove objects by holding down Ctrl and clicking the mouse.

3. Work with the selected group to perform the operations you want. For more
information see Working with Temporary Groups on page 14 -11.

4. To deselect the group, move the mouse away from the group and click.

Working with Temporary Groups

After creating a temporary group, you can perform these operations:

To do this Use the And

Move the group Keyboard or mouse Move the group as if it were a single object.

Resize the group Resize button or + and - keys Drag the mouse or hold down the key until
the group is the size you want

Change attributes Draw toolbar Select the attribute you want.

Zoom in or print Popup menu. Click the right mouse
button within the region, but
outside the group select buttons.

Select Zoom In or Print.

Use other group
commands

Popup menu. Click the right mouse
button on the group.

Select a command.

Creating Permanent Groups
To create a permanent group:
1. Select a temporary group.

2. Click with the right mouse button on an object in the group.

3. From the Group popup menu that appears, click Group.

You can attach a permanent group to a flowsheet block or stream.

Making Permanent Groups into Temporary Groups

To convert a permanent group to a temporary group:
1. Click the right mouse button on the group
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2. From the Group popup menu that appears, click Ungroup.

Aligning Objects in Flowsheets
If the Snap to Grid option is on, any text or graphics objects that you add or move
align to a grid.

To display the grid:
1. From the Tools menu, click Options.

2. Click Grid/Scale.

3. Check Show Grid to see the grid on the screen.

You may need to position or size objects more precisely than the default grid
allows.

You can turn off the Snap to Grid option, reduce the grid size and display a ruler.

• Turn off the Snap to Grid option
• Reduce the grid size

You can also use the Process Flowsheet toolbar to perform all these operations
quickly.

To turn off the Snap to Grid option:
1. From the Tools menu, click Options.

2. Click the Grid/Scale tab.

3. Clear the Snap to Grid checkbox.

To change the grid size:
1. From the Tools menu, click Options.

2. Click the Grid/Scale tab.

3. Select the Grid Size from the list.

You can display a ruler to help you see where you are within the overall drawing
grid:
1. From the Tools menu, click Options.

2. Click the Grid/Scale tab.

3. Check Show Scale to turn it on.

When precisely aligning text and graphics, it is helpful to zoom in on the area of
the flowsheet where you are working.
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Attaching Objects to the Flowsheet
You can attach stream tables, permanent groups, and OLE objects to flowsheet
blocks or stream IDs. Attached objects move with the parent block or stream ID.
For example, text annotation attached to a block maintains its position relative to the
block, no matter where you move the block in a drawing.

To attach an object to a flowsheet:
1. Click the object to select it.

2. Click the right mouse button on the object.

3. From the popup menu that appears, click Attach.

The mouse changes to the connect pointer.

4. Click the block or stream to which you want the object connected.

5. Move the object where you want it, relative to the parent block or stream ID.

When you select an attached object, small boxes indicate the parent block or
stream.

To unattach an object:

➤ From the object's popup menu, deselect Attach.

Printing
This section contains information on:

• Specifying your print settings in the Page Setup dialog box
• Viewing the page layout and adjusting the page breaks

You can print the following in Aspen Plus:

• The entire flowsheet
• A section of a flowsheet
• Plots
• Online Documentation and Help

Tip   To print Aspen Plus forms, copy and paste the information to Microsoft
Excel, then print.
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Using Page Setup
Use Page Setup to control the appearance of printed sheets, paper size, including
margins, orientation, and other printing options.

Aspen Plus uses the Number of Pages setting only when you print an entire
drawing or flowsheet section. Aspen Plus superimposes the drawing on a page
layout. The layout is defined by:

• Number of vertical and horizontal pages
• Page orientation
• Paper size

You can use Page Break Preview on the View menu to see where the page breaks
are located on the drawing.

Aspen Plus scales drawings proportionally to fill the page in the limiting
direction (horizontal or vertical), within built-in margins. It does not distort the
drawing to fill the page in both directions.

Specify your settings for printing the flowsheet window on the Page Setup dialog
box:

Ê From the File menu, click Page Setup.

Viewing Page Breaks

You can view the page breaks in order to visualize the layout and adjust what is
going to be printed. You should avoid printing drawings with icons or IDs
spanning page boundaries.

Adjust the position of the drawing on the page by:

• Repositioning the flowsheet objects on the individual pages
• Moving and resizing the page layout frame

You can change the page layout at any time by changing the settings on Page
Setup. Aspen Plus will redraw the page breaks.

To view the page layout:
1. From the View menu, click Page Break Preview.

2. Complete the Page Setup dialog box or accept the defaults if this sheet has
not been viewed previously.

In the Page Setup dialog box, you can specify the number or horizontal and
vertical pages, the paper size and source, the paper orientation (portrait or
landscape), and the margins.
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3. When the flowsheet is superimposed on the current page layout, you can
select the borders to move the location of the pages, and you can select a
corner to change the size of the pages relative to the flowsheet.

Note   All the pages must remain equally sized.

4. You can also move elements of the flowsheet such as the unit operation icons,
tables, and annotation to a desired location. In this way, you can determine
what is present in the print area.

Hint   It is often helpful to select Zoom Full from the View menu in order to
view the entire Flowsheet before adjusting the page breaks.

Printing a Flowsheet
To print a flowsheet:
1. Click in the Process Flowsheet Window to make it active.

2. Click the Printer button on the Standard toolbar.

– or –

From the File menu, select Print.

3. Choose the printer and desired settings in the Print dialog box.

4. Click OK.

Printing a Section of Flowsheet
To print a section of flowsheet:
1. From the Flowsheet menu, click Flowsheet Sections.

2. Choose the flowsheet section you want to print and click OK.

3. From the View menu, click Current Section Only.

4. Click the Printer button on the toolbar.

– or –

From the File menu, select Print.

5. Choose the printer and desired settings in the Print dialog box.

6. Click OK.
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Displaying and Printing Attached Objects with
Flowsheet Sections

In a flowsheet divided into sections, when the View only current section option is
on in the Section Object Manager, attached objects display and print with the
section they are attached to.

For example, you can generate a stream table consisting of all the streams in a
section and attach it to a block in the section. If you print the section, the stream
table prints with it. Unattached annotation objects or OLD objects display and
print with all sections. For more information on flowsheet sections, see Chapter 4.

Printing Large Flowsheets
For large flowsheets, it is often necessary to print the flowsheet on multiple
pages. You may also want to only print one flowsheet section at a time.

To print on multiple pages:
1. From the File menu, click Page Setup.

2. Specify the desired number of horizontal and vertical pages.

3. From the View menu, click Page Break Preview.

4. Select the page borders to move the location of the pages, or select a corner to
change the size of the pages relative to the flowsheet.

Note   All of the pages must remain equally sized.

5. You can also move elements of the flowsheet such as the unit operation icons,
tables, and annotation and arrange them to fit on a desired page.

❖     ❖     ❖     ❖ 
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15 Managing Your Files

This chapter describes how to manage the files you create when running
Aspen Plus including:

• File formats used during Aspen Plus runs
• Saving Aspen Plus document files
• Exporting Aspen Plus files
• Importing Aspen Plus files
• Saving an Aspen Plus run
• Managing files in a client-server environment

File Formats in Aspen Plus
These are the major types of files used in Aspen Plus:

File Type Extension Format† Description

Document *.apw Binary Quick restart file containing simulation input and results
and immediate convergence information

Backup *.bkp ASCII Archive file containing simulation input and results

Template *.apt ASCII Template containing default inputs

Input *.inp Text Simulation input

Run Message *.cpm Text Calculation history shown in the Control Panel

History *.his Text Detailed calculation history and diagnostic messages

Summary *.sum ASCII Simulation results

Problem Definition *.appdf Binary Binary file containing arrays and intermediate convergence
information used in the simulation calculations

Report *.rep Text Simulation report

†
In this context a “text” file is one that you can read using a standard editor such as Notepad®. A binary
file cannot be read by the user. An ASCII file can be opened in an editor, but is formatted to be read by a
program, not a person. ASCII files are portable across different hardware platforms.
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Document Files ( *.apw)
Aspen Plus document files contain all input specifications, simulation results,
and intermediate convergence information. If you save a run as a Document file
before you exit from Aspen Plus, the next time you open the run it is in exactly
the same state as when you saved it. If you reopen a run saved as a Document
file, Aspen Plus restarts the calculations using the previous results.

Document files can be opened in the Aspen Plus User Interface and saved.

Disadvantages

Document files (.apw) are not compatible across different versions of Aspen Plus.

Advantages

For longer simulations, Document files are much quicker to load into and save
from the Aspen Plus User Interface.

Because Document files contain intermediate convergence information, the run
can be started exactly where it was saved. Intermediate results are especially
useful when you save a file while in the process of trying to converge a large
flowsheet.

Backup Files (*.bkp)
Aspen Plus Backup files contain a compact version of your Aspen Plus run. They
occupy much less disk space than files saved in Document format, and are thus
preferable for long-term storage.

Backup files contain all input specifications and simulation results, but no
intermediate convergence information. If you reopen a converged run stored as a
backup file and rerun the simulation, Aspen Plus:

• Reinitializes the streams and blocks
• Reconverges the entire simulation

Backup files are ASCII files. You can use them to transfer runs between:

• Computers
• Versions of Aspen Plus

The advantage of the Backup (.bkp) files over Document (.apw) files is that the
Backup files are upwardly compatible through different versions of Aspen Plus
and are portable. For example, they can easily be emailed.
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Backup files can be opened and saved in Aspen Plus. They can also be imported
into a current run, and partial or complete flowsheets can be exported. For more
information, see Exporting Aspen Plus File on page 15 - 8.

You can import runs saved in Backup format into your current run. Aspen Plus
merges the information and specifications contained in the backup file with your
current run.

For example, you can have two sections of a flowsheet stored in separate backup
files. You can import these two backup files into a single run, merging the two
flowsheet sections.

For information on inserts (partial backup files that you can import at any time),
see Chapter 34.

Maintaining Upward Compatibility

When importing a backup file, you can control compatibility between Aspen Plus
versions.

The Upward Compatibility dialog box appears when you open a backup file that
was created with the Aspen Plus simulation engine, or with a previous version of
Aspen Plus.

New features in Aspen Plus Version 10 may mean your results differ from those
of previous versions. To maintain upward compatibility and obtain the same
results as your previous version of Aspen Plus, ignore the new features of Version
10. To do this:

In the Upward Compatibility dialog box, select Maintain Complete Upward
Compatibility.

To use the new features of Version 10:

In the Upward Compatibility dialog box, select Use the Following New Features,
and check the features you want from:

• New pure component databanks
• New property methods
• New built-in binary parameters
• New ADA/PCS procedures
• Calculated molecular weight obtained from formula
• Checking of user-specified sequence

Note   If you are opening a file created by Version 9 of the Aspen Plus user
interface, you will get only the option of using the new pure component databank,
PURE10.
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Template Files (*.apt)
You can select a Template when creating a new run. Templates set defaults for
some or all of the following:

• Units of measurement
• Property sets for reporting stream properties
• Composition basis for stream reporting
• Stream report format
• Global flow basis for input specifications
• Setting for Free-Water option
• Selection for Stream-Class
• Property option set
• Required components (such as water)
• Other application-specific defaults
• 

For detailed information on the built-in template and creating templates, see
Chapter 2.

Input Files (*.inp)
Aspen Plus input files are compact summaries of the specifications for a
flowsheet simulation. An input file can include graphical information about the
layout of the unit operation blocks and streams in the Process Flowsheet
Window.

An input file can:

• Be used as the input file for a stand-alone Aspen Plus engine run
• Provide a compact summary of the input specifications for a simulation (for

example, to be included in a report)
• Provide the documentation of record for a simulation study (for example, as

part of the archives for a design project)
• Help expert users diagnose problems

You can generate an Aspen Plus input file from your simulation specifications at
any time. To save an input file, you must export it from the Aspen Plus user
interface.

The input file can be run directly by the simulation engine. Click here for
details.For more information on how to run an input file using the simulation
engine, see Chapter 11.

Import the backup file as described in Importing Aspen Plus File on page 15 - 8.
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Report Files (*.rep)
Aspen Plus Report files document all of the input data and defaults used in an
Aspen Plus run, as well as the results of the simulation. These are text files that
can be read by the user.

Report files must be exported from the simulation to be saved. Report files
cannot be opened in the Aspen Plus User Interface.

If applicable, the DFMS input file (*.dfm), the Prop-Data file (*.prd) and the
Project file (*.prj) are exported along with the report file.

Summary Files (*.sum)
Aspen Plus Summary files contain all the results from the simulation that are
displayed in the Aspen Plus user interface. Summary files are ASCII format files
used to load the results into the user interface. Summary files can also be used
by other programs to retrieve the results of the simulation.

Summary files must be exported from the simulation to be saved. For more
information, see Exporting Aspen Plus File on page 15 - 8. Summary files are
automatically generated when running the Aspen Plus simulation engine
standalone. The summary file generated is called runid.sum.

The results included in summary files can be imported in the Aspen Plus User
Interface. For more information, see Importing Aspen Plus File on page 15 - 8.

Run Messages Files (*.cpm)
Aspen Plus Run Messages files are text files that include the error, warning, and
diagnostic messages from the run. These are the messages displayed on the
Control Panel during a run. The number of messages and the detail can be
controlled globally on the Setup Specifications Diagnostics sheet. You can also
control the messages localy for each block on the block BlockOptions Diagnostics
sheet.

Run Messages files are similar to history files (*.his). The diagnostic level for
history files and the control panel can be adjusted independently. If you need a
high level of diagnostics, print to the history file (not to the control panel). This
prevents any performance degradation that might result from lengthy
diagnostics on the screen.

Run Messages files must be exported from the simulation to be saved.
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History Files (*.his)
The History file is a text file that includes an echo of the input summary and the
error, warning, and diagnostic messages from the run. The number of messages
and the detail can be controlled globally on the Setup Specifications Diagnostics
sheet. You can also control the messages locally for each block on the block
BlockOptions Diagnostics sheet.

When you select History from the View menu, the Aspen Plus history file is
copied from the host computer to your local computer. Aspen Plus executes your
file editor to view the history file.

A history file cannot be saved or exported from the Aspen Plus User Interface.
Save the file using History from the View menu. A history file is saved
automatically when you save a run as a Document file.

The history file is similar to the Run Messages file. The diagnostic levels for the
history file and the control panel can be adjusted independently. If you need a
high level of diagnostics, print to the history file (not to the control panel). This
prevents any performance degradation that might result from lengthy
diagnostics on the screen.

Opening Aspen Plus Files

You can open an existing Aspen Plus file from within Aspen Plus.
1. From the File menu, click Open.

2. In the Open dialog box, select the file type from the Files of Type list.

3. Enter a filename or select a file from the available list, then click Open.

4. The message “Do you wish to close the current run before opening new run?”,
appears. Click No for the new simulation to be opened in a separate window.
Click Yes to close the current run.

Tip   To speed up your search for files or directories, in the Open dialog-box.
click the Look in Favorites button to display a list of pre-selected directories.
Use the Add to Favorites button to place frequently used directories into this
list.
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Using the Favorites List
By default, the Favorites list contains 5 directories that are provided with
Aspen Plus. The files in these directories are designed to assist you in creating a
suitable simulation model in Aspen Plus.

This table shows the directories:

Directory Description

Assay Libraries Petroleum crude assays compiled from literature for  different regions of the world
and selected crude  assays from the Phillips Petroleum Crude Assay Library

Applications Application examples of real world problems covering gas processing, petroleum
refining, chemicals, pharmaceuticals, and metals processing industries

Data Packages Special property data packages for industrially important systems

Examples Selected examples

Electrolyte Inserts Electrolyte data packages for many industrially important systems

Saving a Run

To save a file in Aspen Plus:
1. From the File menu, click Save As.

2. In the Save As dialog box, select the appropriate file type from the Save as
Type list.

3. Enter a filename. The file can be saved in any directory.

4. Click Save.

You can save these types of files:

File Type Extension Description

Document .apw Quick restart file containing simulation input and results and intermediate convergence
information

Backup .bkp Archive file containing simulation input and results

Template .apt Template containing default inputs
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Exporting Aspen Plus Files

To generate and export an Aspen Plus file:
1. From the File menu, click Export.

2. In the Export dialog box, select the appropriate file type from the Save as
Type list.

3. Enter a filename. The file can be saved in any directory.

4. Click Save.

You can export the following types of Aspen Plus files:

File Type Extension Format Description

Backup .bkp ASCII Archive containing simulation input and results

Report .rep Text Report file

Summary .sum ASCII Simulation results

Input .inp Text Simulation input information without graphics

Input File with
Graphics

.inp Text Simulation input and graphical information

Run Messages .cpm Text Calculation history

Flow Driven Dynamic
Simulation

.spf

.inp
Text Aspen Dynamics input and Aspen Plus input

Pressure Driven
Dynamic Simulation

.spe

.inp
Text Aspen Dynamics input and Aspen Plus input

Importing Aspen Plus Files

To import an Aspen Plus file:
1. From the File menu, click Import.

2. In the Import dialog box, select the file type from the Files of Type list

3. Enter a filename. The file can be saved in any directory.

4. Click Open.

5. If the Resolve ID Conflicts dialog box appears, there are objects that have the
same ID as objects in the current run. For information about using the
Resolve ID Conflicts dialog box, see Chapter 38.
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Tip   To speed up your search for files or directories, in the Open dialog-box.
click the Look in Favorites button to display a list of pre-selected directories.
Use the Add to Favorites button to place frequently used directories into this
list.

You can import the following types of files:

File Type Extension Format Description

Backup *.bkp ASCII Archive containing simulation input and results

Template *.apt ASCII ASCII file used as a template

IK-Cape .ikc ASCII IK-Cape neutral file for physical property information

Summary *.sum ASCII Simulation results

Deciding How to Store a Simulation
Problem Definition

You can save an Aspen Plus simulation in the following threeways:

• Save the Aspen Plus Document file
• Save the Aspen Plus Backup file
• Export the file as an Input file

This table summarizes the characteristics of the file formats used to store the
simulation problem:

Characteristic Document Backup Input

Simulation Definition (input
specifications)

✓ ✓ ✓

Intermediate Convergence
Information

✓

Results ✓ ✓

Graphics ✓ ✓ ✓

User Readable ✓

ASCII Format ✓ ✓

Readable by Aspen Plus
User Interface

✓ ✓ ✓



15-10 Aspen Plus User Guide
Version 10.1-0

Managing
Your Files

Managing Files in a Client-Server
Environment

You can run the Aspen Plus user interface and the simulation engine:

• On the same computer
• On different computers in your network

Usually, you do not need to be aware of how or where Aspen Plus is installed.
However, you should be aware of some file management issues, described in the
following sections.

The local computer is where the Aspen Plus user interface is running. The host
computer is where the Aspen Plus simulation engine is running.

Specifying the Working Directory on the Host Computer
If you have not specified a working directory, files created by the Aspen Plus
simulation engine are stored in your default login directory on the host computer.
To specify the working directory where the simulation engine should execute:

From the Run menu, click Connect to Engine.

Saving Files
When you save a run as an Aspen Plus Document (.apw) file using Save or Save
As from the File menu, Aspen Plus creates these files in the following locations:

File Location

runid.apw Local directory where you are running the user interface,
or the directory specified on the Save As dialog box

runid.his Working directory on host computer specified in the Connect to Engine dialog box

runid.appdf Working directory on host computer specified in the Connect to Engine dialog box
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View History
To copy the Aspen Plus history file from the host computer to your local
computer:

From the View menu, click History.

Aspen Plus executes your file editor to view the history file.

Tip   If the history file is large, copying the history file to your local computer
can take a long time. In such a case, you should log onto the host computer and
view the file.

Specifying the Text Editor

To specify the text editor:
1. From the Tools menu, click Options.

2. Click the Startup tab.

3. In the Text Editor box, type the name of the editor.

4. Click OK

❖     ❖     ❖     ❖ 
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16 Customizing Your
Aspen Plus Environment

Configuration options are default settings that affect how you use Aspen Plus. For
example, configuration options enable you to specify:

• Grid and scale settings
• Default Application Template file
• Which binary databanks are used as defaults

This chapter explains:

• Choosing settings for the current run
• Choosing settings for all runs
• Specifying your default options
• Customizing Application Template files

Choosing Settings for the Current Run
To change your configuration option settings for the current run:

From the You can select

View menu Any command

Tools menu Options

Window menu Any command
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Customizing Settings for All Runs

To create a custom environment for subsequent Aspen Plus runs:
1. Open a blank run.

2. Customize the settings, then exit.

You do not need to save the blank run.

Your  customized settings are saved in the Windows registry and are used for
all subsequent runs. If you modify any settings, the new settings are used in
subsequent runs.

Note   Some settings are saved with the simulation. If a setting that is saved
with a simulation differs from the setting in the registry, the setting that is
saved with the simulation will be used for that simulation; however,
subsequent simulations will use the setting that is in the registry.

Choosing View Options
You can change which elements are visible by using the options on the View
menu. Display or hide elements, depending upon what you need at any given
time.

These options are available from the View menu:

Click this option To

Toolbar Select the toolbars that are displayed

Status Bar Select if the status bar on the main window is displayed

Model Library Select if the Model Library is displayed

Control Panel Select if the Control Panel is displayed

Zoom In Magnify a portion of the drawing on the screen. If a Group or Region has been selected, the selected region will be
expanded to fill the screen. When you zoom in on a selected region, the portion of the drawing displayed may not be
exactly what you selected, since proportional vertical/horizontal scaling is maintained at all times.

Zoom Out Shrink the drawing on the screen in order to show more of the drawing or to make room for more blocks or symbols.
As you shrink the drawing, text and some symbols will disappear from the screen due to the screen resolution. These
objects are not deleted, they reappear when you zoom in, and print.

Zoom Full Display the entire drawing as large as possible in the workspace

Center View Display the selected object in the center of the screen

Continued
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Click this option To

Pan Choose a region of the flowsheet to display at the current zoom level

Bookmarks Create bookmark views or  got to a bookmark

Page Break
Preview

Select if the page breaks are displayed in the Process Flowsheet window
For more information see Chapter 14.

Reset Page Breaks Reset page breaks you have defined

Current Section
Only

Select if only the current flowsheet section is displayed
For more information on using flowsheet sections see Chapter 4.

PFD Mode Select whether PFD mode is on or off.

Reset PFD Delete the current PFD mode drawing and create a new one

Global Data Select if global data is displayed for each stream.
See Results View Options for information about how to customize the global data.

Annotation Select if text annotation on the Process Flowsheet window is displayed

OLE Objects Select if OLE objects are displayed
For more information, see Chapter 38.

Input Summary View the input summary
For more information about the input file, see Chapter 15.

History View the history file
For more information about the history file, see Chapter 15.

Report View a section of the report file
For more information about the report file, see Chapter 12.

Using Toolbars
The buttons on a specific toolbars cannot be customized. However, the toolbars
can be viewed, hidden, or moved to another location.

Toolbar settings are not saved with the simulation file. The toolbar configuration
is saved in the registry and will be used for all subsequent files that are opened
in Aspen Plus.
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These toolbars are available:

Toolbar Buttons

Standard Standard Windows buttons used for basic operations
New, Open, Save, Cut,  Print, Print Preview, Copy, Paste, Help

Data Browser Buttons used to display the next required step, the Data Browser,
or one of its various elements

Simulation Run Buttons used to control the execution of the simulation

Process Flowsheet
(PFS)

Buttons used to manipulate the unit operation, graphical or
text objects located in the process flowsheet

Draw Buttons used to add or modify graphical or text objects

Dynamic Buttons used for dynamic simulations using Aspen Dynamics

Section Buttons used to manipulate flowsheet sections

Detherm Buttons used for Detherm application

Viewing Toolbars

You can choose which toolbars are shown in the main window of Aspen Plus. To
do this:
1. From the View menu, click Toolbar.

2. Select the check box of each toolbar you want to view.

The toolbars that are checked are those that appear by default.

Moving Toolbars

Toolbars can be positioned elsewhere in the window. To do this:
1. Click and hold down the mouse button on the edge of the toolbar you wish to

move.
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2. Drag the toolbar to the desired location, which can be either:

• On any edge (top, bottom, or sides) of the Aspen Plus window
• In the center of the window

Specifying Default Options

There are various options you can set as defaults. To do this:

➤ From the Tools menu, click Options.

The Options dialog box appears.
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This table shows which tab to use:

To Use this tab

Specify general options such as the default method to save
documents and if inline Fortran is checked for syntax errors

General

Specify the databank search order Component Data

Select what information is included when Global Data is
displayed

Results View

Control various naming, display and placement options on
the process flowsheet

Flowsheet

Set and display the grid and scale on the process flowsheet
window

Grid/Scale

Specify the default fonts, grid style, line style, marker size,
and time stamp components used when creating plots

Select if a legend and time stamp are displayed by default.

Plots

Select run options for interactive runs and specifications for a
remote server

Run

Specify startup options for a new flowsheet such as Run
Type, application template, and working directory

Startup

Using the General Tab
From the Tools menu, click Options, then click General. The General tab is used
to specify general options related to running simulation, saving Aspen Plus
documents, and making OLE links between an Aspen Plus run and another
application.
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The following parameters are available on the Tools Options General tab:

Use this box To Saved with
Simulation?

Allow run only when
input is complete

Allow a run only when input is complete

Turning off this option allows you to initiate an interactive or
batch run even if the status in the toolbar is not Required
Input Complete.

This option is primarily for advanced users who are familiar
with keyword input language.

Yes

Check inline Fortran for
syntax errors

Check inline Fortran for syntax errors

When this option is checked, basic Fortran syntax error
checking is done on all the Fortran and Declarations
sheets. This option sometimes needs to be turned off when
advanced Fortran is used.

Yes

Accounting information
required to complete
input

Allow a run only when accounting information has been
completed.

When this option is checked, you are required to specify
accounting information on the Setup Specifications
Accounting sheet. The accounting information includes an
account number, a project ID, a project name, and a user
name. This is stored for the run by the Aspen Plus
Accounting System, if it is active for your installation.

No

Always create backup
copy

Always create backup copy.

When this option is checked, an Aspen Plus backup format file
(*.bkp) is created whenever an Aspen Plus document file (*.apw) is
saved. This is used as an additional backup safety mechanism.
The document file (*.apw) allows you to quickly restart previously
saved simulation, using a binary file. The backup file (*.bkp) stores
the same run information in a condensed ASCII file.

No

Save Aspen Plus
documents as

Specify the default method to save documents.

Saving documents as document files (*.apw) allows you to quickly
restart previously saved simulation, using a binary file. Saving as
backup files (*.bkp) stores the same run information in a
condensed ASCII file.

No

Copy buffer format Specify what information is included when a cell is copied
into the copy buffer.

Every variable, when copied for OLE links, occurs with four
attributes: Value, Units, Label, and Basis. You can set the default
attributes here, or you can specify the attributes you need, from the
Edit menu by clicking Copy with Format.

Yes
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Using the Component Data Tab
Use the Component Data tab to:

• Change the databanks search order
• Choose which databanks are searched
• Copy regression and estimation results onto Parameters forms
• Generate input language using component name or component alias

Changing Databanks Search Order

The order in which the pure and binary components databanks are searched can
be changed using the Tools Options Components Data dialog box.

To change the pure and binary component databank search order:
1. From the Tools menu, click Options.

2. Click the Component Data tab.

3. In the Searched list, click the databank that you want to reorder.

4. Click the up or down arrow to reorder the databank.

The databank at the top of the list is searched first. The data found first for a
component or a component pair is the data that is used in the simulation.

Pure Component Databank Search Order—This specifies which pure component
databanks Aspen Plus will search and the search order for all simulations.

The order in which the databanks are listed is the order in which Aspen Plus
searches for data. For a specific simulation run, you may change the list and
order on the Components Specifications Databanks sheet.

Binary Databank Search Order—This specifies which binary parameter
databanks Aspen Plus will search and the search order for all simulations.
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The order in which the databanks are listed is the order in which Aspen Plus
searches for data. These databanks contain:

• Binary parameters for equation of state models.
• Binary parameters for Wilson, NRTL, and UNIQUAC models.
• Henry’s law constants.
• Binary and pair parameters for electrolyte NRTL models.

For a specific parameter in a particular run, you may change the list and order
on the Properties Parameters Binary Interaction and the Properties Parameters
Electrolyte Pair folders.

Choosing Which Databanks are Searched

To move a databank to the Searched list:
1. Click the databank you wish to move.

2. Click the right arrow to move the databank to the Searched list.

To move a databank from the Searched list:
1. Click the databank you wish to move.

2. Click the left arrow to move the databank to the Not Searched list.

To move all of the databanks at once from one list to the other:

➤ Click the appropriate double arrow.

Reorder the databanks using the up and down arrows.
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Example of Reordering Databanks

For pure component data, the PURE93 databank is searched first, the
AQUEOUS databank is searched second and then, the SOLIDS, INORGANIC
and COMBUST databanks are searched, in that order.

The AQU92, ASPENPCD, PURE10, and PURE856 databanks are not searched at
all.

For binary data, the ENRTL-RK databank is searched followed by the VLE-IG,
VLE-RK, VLE-HOC, LLE-LIT and LLE-ASPEN databanks.
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Copying Regression and Estimation Results

You can retrieve regression or estimation parameter results and display them on
the Parameters forms. To do this:

➤ On the Components Data tab, check the Copy regression and estimation
results onto Parameters forms box.

The parameters will be used in all subsequent runs.

When this check box is clear, the parameters are available on the appropriate
Physical Properties Parameters form, using the drop down list, but are not
displayed on the forms. The parameters will not be used in subsequent runs.

Changing Defaults for Generating Input Language

You can use the Components Data tab to select whether you generate input
language using Component name or Component alias.

Use the Formula column (up to 12 characters) or the Component Name column
(up to 32 characters) on the Components Specifications Selection sheet to
generate the COMPONENTS paragraph in the Aspen Plus input file.

Using the Results View Tab
Global data such as stream temperature and pressure can be viewed by selecting
Global Data from the View menu. The data displayed can be customized using
the Tools Options Results View tab.

For more information on using global data see Chapter 14.
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The following parameters are available on the Results View tab:

Use this box To Saved with simulation

Output Units of
Measurement

Select the units of measure for the global data output. No

Heat/Work Variables Specify if Heat or Work is shown (if available for streams) when
global data is viewed.

Use the Format box to specify the variable format.

Yes

Temperature Specify if Temperature is shown (if available for streams) when
global data is viewed.

Use the Format box to specify the variable format.

Yes

Pressure Specify if Pressure is shown (if available for streams) when global
data is viewed.

Use the Format box to specify the variable format.

Yes

Total Flow Rate Specify if Total flow rate is shown  (if available for streams) when
global data is viewed.

Use the Format box to specify the variable format.

Yes

Duty/Power Specify if Duty or Power is shown (if available for heat and work
streams) when global data is viewed.

Use the Format box to specify the variable format.

Yes

†
These are shown if available for streams when global data is viewed.

Format for Numbers

You can control the format of global data on the process flowsheet window. There
are three conversion formats:

• %-xx.yye
• %-xx.yyf
• %-xx.yyg
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This table explains the variables:

Variable Explanation

% Percent character. Lead character for format specification.

- Optional minus sign, which left-justifies the number.
Without the minus sign, the number is right-justified.

Xx A digit string specifying a minimum field length for the converted number.
The number takes at least this much space to print, and more if necessary.

Yy A digit string specifying the precision, (that is, the number of digits)
to be printed to the right of the decimal point.

E Number is converted to the form [-]a.bbbbbbbe[+]cc.
Length of b is specified by yy (Default is 6).
Use upper case E in the format specification for upper case E in the printed numbers.

f Number is converted to the form [-]aaa.bbbbbb.
Length of b is specified by yy (Default is 6).

G The shorter of %e or %f is used.
Use upper case G in the format specification for upper case G in the printed numbers.

The recommended format is %0.f which prints whole numbers.

Other common formats used in stream tables are:

Format Explanation

%10.0f Whole numbers, with no decimal digits or exponents.

%10.nf Numbers without exponents and with n digits to the right of the decimal point,
if space permits. Decimal points line up, unless decimal digits have been
eliminated in some numbers.

Using the Flowsheet Tab
Use the Tools Options Flowsheet tab to set various naming, display, and
placement options on the Process Flowsheet.



16-14 Aspen Plus User Guide
Version 10.1-0

Customizing
Your Aspen
Plus
Environment

The following parameters are available on this tab:

Use this box To Saved with simulation

Automatically Assign Block
Name with Prefix

Have blocks automatically assigned a name
beginning with the specified character string.
For example, if B is entered, the blocks will be
named B1, B2, B3, etc.

When this option is off, Aspen Plus will prompt
you to enter an ID each time a block is
created.

Yes

Display Block Name Have future block names displayed with the
icon on the Process Flowsheet.

Yes

Automatically Assign Stream
Name with Prefix

Have streams automatically assigned a name
beginning with the specified character string.
When this option is off, then Aspen Plus will
prompt you to enter an ID each time a stream
is created.

Yes

Display Stream Name Have future stream names displayed on the
streams in the Process Flowsheet.

Yes

Automatically Place Blocks
When Importing

Automatically place blocks when importing a
flowsheet

Use this option to specify whether or not
Aspen Plus automatically places any new
blocks when you import an Aspen Plus backup
file that does not contain graphics layout
information.

When this option is off, the Unplaced Blocks
menu appears showing blocks that are not in the
process flowsheet .  You can later place these
blocks automatically or manually. Blocks and
streams already in the drawing and whose
connectivity has not changed are not affected
by this option.

For more information on  placing and
unplacing blocks, see Chapter 4. For more
information on importing a flowsheet, see Chapter
15.

Yes

Lock Block Spacing Factor at Lock the block spacing factor at a specified
value.
A spacing factor of 2.5 is generally appropriate
for flowsheets drawn with the block icons. For
flowsheets drawn with pictorial icons, a factor
of 1.5 is often better.

No

Continued



Aspen Plus User Guide 16-15
Version 10.1-0

Chapter 16

Use this box To Saved with simulation

Label Size Scale Factor Control the size of block and stream IDs for
printing.

When Global Data is on, this factor also
controls the size of the displayed global data
values and legend box.

This is a relative factor. Use a larger value for
larger IDs and global data values. A factor
between 2-3 is generally appropriate when
printing relatively large flowsheets.

Yes

Using the Grid/Scale Tab
Use the Tools Options Grid/Scale tab to set and display the grid and scale on the
process flowsheet window.

The following parameters are available on the Grid/Scale tab:

Use this box To Saved with simulation

Show Scale Display a scale at the top and left of the process flowsheet
window

Yes

Show Grid Display the grid in the process flowsheet window.
The grid lines can help you position objects, especially
graphics and text objects.

Note  For the grid to be displayed, you must be zoomed in
enough for the grid points to be distinguishable.

Yes

Snap to Grid Align objects in the process flowsheet window to the grid
when they are placed, moved, or resized

No

Grid Size Specify the interval between grid points.

When Snap to grid is on, inserted graphic objects
are snapped to the grid lines.

If you are zoomed in, you may want to decrease the grid
resolution factor to position objects precisely.

The grid sizes to choose from are 0.2, 0.1, 0.05, 0.025,
0.0125

Yes

Zoom Out Scale Factor Set the degree for zooming in or out on the process flowsheet

Values range from 1.0 to 10.0. A value of 10.0 will zoom out in
greater increments than a value of 1.0.

No

Scroll Step Size Set the percentage for scroll bar stepping†

Scroll step affects only the scroll bars for the process
flowsheet.

No

† 
A scroll bar step is the amount that the screen scrolls with one mouse click a scroll bar arrow.
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Using the Plots Tab
Use the Tools Options Plots tab to specify the default fonts, grid style, line style,
and marker size used when creating plots. This tab is also used to select if a
legend and time stamp are displayed by default.

The following parameters are available on the Tools Options Plots tab:

Use this box To Saved with simulation

Default Fonts Change the default font for the Title, Axis label, Axis
scale, and Annotation

No

Grid Style Define the type of grid for the plot. Mesh, Horizontal,
Vertical, or No grid can be selected.

No

Line Style Select the line style for the data curves. Lines &
markers, Lines, or Markers can be selected.

No

Marker Size Select the size for the markers. Values from 1-20 can
be selected.

No

Show Legend Show a legend No

Show Time Stamp Show a time stamp  No

Using the Run Tab
Use the Tools Options Run tab to select run options for interactive runs and
specifications for a remote server.

The following parameters are available on the Tools Options Run tab:

Use this box To Saved with Simulation

Express Run Use Express Run for maximum simulation speed when you
run the Aspen Plus simulation engine on a PC, or
interactively on other platforms.

Express Run turns flowsheet animation off, and changes the
Control Panel (terminal) message levels to 0.

You can change the Control Panel message levels on the
Setup Specifications Diagnostics sheet.

If you change the Control Panel message levels on this
sheet, and then turn on Express Run, Aspen Plus will not
save the values you entered. When you turn Express Run
off, all Control Panel message levels are set to 4.

Continued
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Use this box To Saved with simulation

Interactively Load
Results

Load results only for objects you select in an interactive run

When Interactively Load Results is off, Aspen Plus loads all
simulation results into the Graphical User Interface at the
end of the simulation.

Interactively Load Results speeds up processing time by
only loading the results you are interested in. It is useful if
you run a simulation several times, but are only interested in
the results on a few particular forms.
When Interactively Load Results is on, you can still load all
results using Check Results from the Run menu.

Interactively Load Results only works with the Flowsheet
Run type.

Yes

Animate Flowsheet
During Calculations

Highlight blocks as they are executed during an interactive
run

Turning animation off can sometimes result in a slight
increase in simulation speed.

Yes

Edit Keyword Input
Before Starting
Calculations

Edit the input language file before beginning an interactive
run

Aspen Plus displays the generated input language file in
your editor before starting interactive calculations. This gives
you a chance to make small modifications or additions to the
file, or to diagnose problems. These modifications will not be
reflected on the input forms.

This feature is intended for advanced users who are familiar
with keyword input language.

No

Server Type Specify the Server type for remote server. No

Server Name Specify the name of the remote server. No

Username Specify the Username for the account on the  remote server. No

Working Directory Specify the working directory on the remote server. No

Using the Startup Tab
Use the Tools Options Startup tab to specify startup options for a new flowsheet.
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The following parameters are available on the Tools Options Startup tab:

Use this box To

Run Type Select the default startup Run Type.

Application Template Select the default application template

Working Directory Select the default working directory for Aspen Plus simulation runs. All
new files will be created in the specified working directory.

This does not affect any existing files that you open - all the run files,
including temporary ones, will be created in the directory where the file
is.

Enable forms for layered products Enable the forms for Aspen Plus layered products

The forms for BatchFrac†, RateFrac, Aspen Dynamics, and
POLYMERS PLUS can be enabled.

This option is not available if the layered product is not installed.

Text Editor Select the default text editor

Specify the text editor to use for editing ASCII files that are obtained
from the View Input Summary, History and Report commands from the
View menu.

Print Text File Command Select the command used to print

†
Rigorous 2 or 3 phase batch distillation process model. This model is not available in Aspen Plus
Version 10, but will be available in Aspen Plus 10.1

Using the Window Menu
The following parameters are available on the Window menu:

Use this option To

Cascade Create a cascade of all of the open windows

Tile Tile all of the open windows

Arrange Icons Arrange the icons of any minimized windows

Normal Display the Process Flowsheet in a normal window. The Process Flowsheet window can be moved,
brought to the top and minimized.

Flowsheet as
Wallpaper

Always keep the flowsheet fully open at the back of the program window

Flowsheet as Wallpaper can only be used if Workbook Mode is off.

Workbook mode Select if the Windows are displayed using Workbook mode

Workbook mode can only be used if Flowsheet as Wallpaper is off.
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Using Workbook Mode
Use Workbook mode to help organize all of your open windows.

In Workbook mode, each window has a tab that appears at the bottom of the
screen. This makes it easy to see which windows are open.

To use Workbook mode:

➤ From the Window menu, click Workbook Mode.

To make the desired window current:

➤ Click the appropriate tab at the bottom of your screen.

Tip   You can also select any visible part of a window behind the current
window by clicking it.
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Customizing Application Template Files

An Application Template file contains simulation defaults commonly used by
specific industries or companies. You can select an Application Template when you
create a new run. You can use and modify a built-in file, or you can create your own
Application Template files. For detailed information on the Application templates, see
Chapter 2.

Use the built-in Application Templates as a guide when creating your own
customized Application Template files.

There is no limit to the amount of information that can be included in a template:
setup information, components, unit sets, property specifications, and even unit
operation models can all be saved in a template if desired. Too much information
may be inconvenient; however, objects or specifications in a template can be
deleted if they are not needed in a simulation.

If you want to customize the stream summary format, you will need to create or
modify a TFF file. For more information on how to create a TFF file, see Chapter
36.

Note   Application Template files are not intended for problem specifications,
such as when you want to save defaults or partial specifications for a particular
process or unit. In such cases, create a backup file or an insert instead of an
Application Template file.

Saving a Template File

To save an Aspen Plus template file:
1. From the File menu, select Save As.

2. Select Aspen Plus Templates (*.apt) from the Save as Type list.

3. Select the directory and enter a filename. The file can be in any directory.

4. Click Save.

Tip   If you save your customized templates in a folder inside the Templates
folder, they will appear as a separate tab on the New dialog box.

Tip   The format for a Aspen Plus template file is the same as for a backup file;
therefore, it is possible to create a template from a backup file by simple
changing the extension from .bkp to .apt.
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Importing a Template File

To import an Aspen Plus template file:
1. From the File menu, select Import.

2. Select Aspen Plus Template (*.apt) from the Files of Type list.

3. Select the directory and enter a filename. The file can be in any directory.

4. Click Open.

5. If the Resolve ID Conflict dialog box appears, there are objects that have the
same ID as objects in the current run. For information on the Resolve ID
Conflict dialog box, see Chapter 38.

❖     ❖     ❖     ❖ 
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Solids

conventional 6-20
defining 6-12
identifying 6-20
nonconventional 6-21

Solids templates 2-24
Specialty Chemicals template 2-20
Specifications

thermodynamic condition 9-3
Standalone

runs 11-9
Starting

new run 2-3
Startup tab 16-17
State variables

specifying 9-2
Status

indicators 1-11
messages 11-5

Stoichiometry
mass balance checking 5-12

StreamClass form 9-19
Streams

analysis types 9-9
analyzing properties 9-10
changing ports 4-12
classes 4-23, 5-5, 9-16, 9-17, 9-18, 9-19
composition 9-4
displaying properties interactively 9-10
heat and work 4-7
IDs 4-19
including in report 5-22
moving 4-17
moving corners 4-19
moving segments 4-19
placing on flowsheet 4-4
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property analysis 9-9
pseudoproduct 4-7, 9-25
renaming 4-11
reports 5-22, 5-24
rerouting 4-19
results 12-5, 12-7
specifying 9-2, 9-3, 9-19
tables 14-2
thermodynamic conditions 9-3
types 1-7
work 9-23

Substreams
creating 9-18, 9-20
defining 9-20
modifying 9-18

Summary files 15-5
Supercritical components

Henry's law 7-15, 8-3
parameter requirements 8-3

Symbols
definition 1-11
explaning status 1-11

System options
overriding defaults 5-15

Systems sheet 5-15

T

Table Format Files
selecting 12-7

Tabular data
adjusting for pressure 8-30
adjusting reference states 8-30
entering 8-27

Temperature
specifying limits for flash 5-13

Templates
about 2-3
Air Separation 2-16
Chemicals 2-18
choosing 2-3
creating your own 16-20
Electrolytes 2-19
Gas Processing 2-15
General 2-10
Hydrometallurgy 2-22
Petroleum 2-12
Pharmaceutical 2-21
Pyrometallurgy 2-23
Solids 2-24
Specialty Chemicals 2-20

Ternary parameters 8-22
Text

adding 13-7
adding to plots 13-7
changing 13-8
modifying 13-8

Text editor
specifying 15-11

TFF
choosing 12-7

Thermodynamic condition specifications 9-3
Toolbars

available 16-4
customizing 16-4
default 1-5
description 1-5
moving 16-4
Simulation Run 11-2

Tools Options Startup tab 16-17
Types

of run 11-1
of stream analysis 9-9

U

UNIFAC groups
specifying 6-25

Unit operation blocks
specifying 10-35

Unit operation models
in mass balance only runs 5-10
placing in flowsheet 4-2
selecting 1-6, 1-7

Unit Sets form 5-16
Units of measure

about 5-16
user-defined 5-16
viewing 5-17

Units sets
defining your own 5-17–5-18
example of defining 5-19
viewing 5-17

Unplace
using 4-20

User Defined Component Wizard
opening 6-8

V

Valid phases
changing 5-6
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Variables
selecting for plots 13-6

Venturi scrubbers
about 10-33

Viewing
flowsheets 4-7, 4-9
forms and sheets 1-8

Views
bookmarks 4-9

Vscrub
about 10-33

W

Warnings
requesting 5-13

What's This button 3-5
Work streams

defining 4-7
results 12-7
specifying 9-23

Workbook mode 16-19
Working directory

specifying 15-10
Workspace 1-4
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